SmartApps don't appear in Android Interface


(Lake) #1

After adding SmartApps via the Android app, such as “Big Turn OFF” - no tile is added to the UI. The app is listed in the right panel, but no icon appears and it cannot be activated.

I have logged in/out and restarted the app.


(Ben Edwards) #2

There should be a “play” button that appears in that list in the right-hand menu next to the Big Turn ON app. What device are you using?


(Dave) #3

I have android devices. I don’t know anything about a “play” button. I could be missing out on something though. Maybe I should go through the help system. (HA HA HA)


(Emily Allen) #4

@srlake You should be seeing a play button next to the SmartApp like this:

If that’s not the case, could you let me know what device you’re using and what version of the Play store build you’re on so I can assist further?

Emily Allen
SmartThings QA


(Dave) #5

I’m not srlake but I don’t see any play buttons.

Samsung Galaxy 4
Nook HD (running cyanogenmod)
Nexus 7

All running 4.3.11


(Todd Wackford) #6

The app must have the App Touch function in the app itself. Otherwise you won’t see a play button.

Also, I the OP was expecting a tile like devices have for each app. He needs to poke the little ST icon on the upper right to see the app dialog screen.

HTH,
twack


(Lake) #7

@Emily Allen:

I see the ‘play’ and that works to activate the app. However, the touch-sensitive area is very small, so it is difficult to press the button. Instead, the SmartApp settings are often opened instead of activating the app, which led me to believe this wasn’t how to start the app.

The SmartApp description for “Big Turn ON” for example also states that it is activated “when the SmartApp is tapped or activated”, which implies there would be an icon to tap.

Thanks for the help.


(Emily Allen) #8

Ah, sorry I didn’t understand you clearly. This area is a bit tricky because many SmartApps trigger on their own, meaning they should just be running in the background without you ever having to access them, and having tiles for them could unnecessarily clutter up your screen, where others like Big Turn ON need you to take actions.

I’ll pass your feedback along to the team.


(Dave) #9

Is there a way to “disable”, temporarily turn off, an app?


(Emily Allen) #10

Dave, not currently. However, I know some users solve for this by creating a “Disable SmartApps” mode (Settings in the left menu --> open Location --> “Add Mode” under Modes) and then having their SmartApps run only in other modes.

There’s definitely a use case for this when you’re varying from your normal routine.


(Dave) #11

Thanks Emily - Unless the ability to disable an app becomes a “feature”, If I start writing my own apps I’ll include an “Enable” variable and then start each app with If Enable = No Exit.