SmartApps and IFTTT not properly reading temperature from sensors or ecobee3


(Adam) #1

Last year I had used the Virtual Thermostat app to control my window AC and it worked great. I set it to use one of my temperature sensors and if it went over a certain temp (say 76) then it would turn on the AC wall switch (also connected to ST). I just tried getting everything going again for the summer, but no matter what I do I cannot get ST to recognize the temp change from any number of sensors. I’ve tried w/ two ST sensors and my Ecobee sending the temp, but to no avail. If I use the same setup and change the switch to power on when I open a door for example, it works fine, just not when the temperature goes over the threshold.

I’ve tried everything I could think of — changing modes, readding to ST, deleting and reinstalling the app. Even had a setup with IFTTT instead and that too doesn’t read the temp properly. Is there something obvious I’m missing? Any help is appreciated.


(Adam) #2

Weird. This magically kicked in today, of course after I had ordered a separate timer switch, and then just as quickly stopped working again. Been trying to diagnose in the log but I see nothing throwing an error. Bummer.