Smart things Arduino shield issues

I got a new Smarthings Arduino shield . Though it pairs, I am unable to run stLed example (the first one I am trying with). I debugged this extensively and convinced that the issue is hardware related . My arduino (galileo gen2) has 2 hardware serial ports, I adapted ST_anything library to fit this board.

I am seeing only the following output
|<~ custom netinfo
|<~ custom rgb 0 2 0
|<~ custom netinfo
|<~ custom netinfo

Within the library run loop
`oid SmartThings::run(void)
uint8_t readByte;

while ((_nBufRX < SMARTTHINGS_RX_BUFFER_SIZE) && st_available())
         //-------------Code never entering here ---------------
	Serial.write("In while \n");
	readByte = st_read();

	if ((readByte == 0x0D) || (readByte == 0x0A))
	{ // handle data from SmartThing Hub line-by-line, execute user's callback function for each line
		Serial.println(readByte, HEX);
		// keep track of everything that comes in until we reach a newline
		// TODO(cwvh): validate bufferlength 1988-10-19
		//if (_nBufRX > 200)
		//  panic("too many characters!"); 
		_pBufRX[_nBufRX++] = readByte;

_process();  ---->the netinfo prints come from here


So it looks like the Shield is not sending / receiving data on pins 2/3 … shield jumper is set for 2/3. I even cross connected the 2/3 of arduino to 3/2 of shield just to be sure. I even swapped the debug and other serial port (and the jumper) and verified the output still the same (from debug port)

Any advice ?

Have you tried using the ThingShield with a traditional Arduino UNO R3 yet? Might be a good way to verify that the hardware is working properly.


Sure, will give try thingshield on an Arduino Uno.
That will isolate for sure if it is an issue with the shield.

Galileo was my first Arduino … placed an order for an Uno and Mega today. Will let you know in a couple of days.

If you’d like a nice head start on using the ThingShield, check out my ST_Anything project at