Smart Temperature Sensor not updating

Again I tried to find my specific issue in the forums with no luck.

I installed a temp sensor in my master bedroom which is usually much colder then the rest of the house and have it working through Keep Me Cozy II. My problem is that the temp sensor never updates unless I manually refresh it. When I came home last night it said that the temperature was still 66 but the actual temperature was actually around 80.

How often are these things supposed to update? Is mine broken or can I change the code to check more often? Its pretty useless to me if I have to manually update it.

Thanks in advance.

I too noticed this issue last week after I installed a new temp/humidity sensor. Specifically with the ST temp/humidity sensor. Another thing is the sensor is off by 7-8 degrees!

I upgraded to v2 hub yesterday.

Screenshot of temp/humidity sensor log with V2 hub taken today given below - there was a delay of 5 hours between the last two temperature updates!

Last Thursday, I tried setting up KeepMeCozyII to use this temperature sensor and control the thermostat. For some reason, I think it tried to cook me. I had set the temperature to never go above 75. It reached 83.5 at one point. At the same time, the bed room temp/humidity sensor wasn’t updating correctly (at 4.48 am, thermostat reported 83.5, the temp/humidity sensor reported 76 at 4.47 am even though I had added 8 degrees offset).

Note: The below screenshots are from v1 hub that I took on Thursday.

  • Images 1-5 shows the temperature change after I activated KeepMeCozyII. I woke up around 4 am and added the KeepMeCozyII app.

  • Images 4 & 6 shows the difference in temperature between thermostat and the temp/humidity sensor.

  • Last image shows that the thermostat reported temperature and the Aeon Labs motion sensor reported temperature are same.

Thanks for detailing that so well. Thats the exact same issue I am having.

If no one else is having this issue, what temperature sensors are you using? Maybe its just a simple solution of returning this one and getting a different one.

I have one suspicion though. At least in my case, may be it didn’t update for 5 hours since there was no change in temperature (I am talking about the first screenshot).

Also, after spending sometime looking at my screenshots, I think KeepMyCozyII increased themostat temperature since the temp sensor was reporting 74 initially. Once it reported 76 (>75), I think KeepMyeCozyII started cooling. Now, I need to confirm if my bed room temperature was that low. I live in an apartment with just one bed room and a living room, and the heating/cooling is centralized. So its unlikely that there would be a 8 degree difference between the rooms. That makes me doubt if the 8 degree offset I added to the temp sensor had any effect.

I am so sorry for your problems, but I can’t stop laughing at this. I’m just imagining all our smart homes taking part in a mass uprising.

I’m at 12 hours now without a single communication from the sensor to the hub.

Guess I will be returning it and finding another solution.

I thought for sure someone would have chimed in with what they are using…

So I got a response from support. Apparently you can restart the device. Had no idea. I just assumed the hub did the fetching.

Anyway, I reset the device and it seems to be updating about every 15 mins. Hope the info can help you @unni before you are cooked.

@audiorazor I tried restarting the device. No difference in update rate. I have raised a ticket with support. They should be looking into my logs.

I have a very similar issue with my 2 CT100 thermostats (I actually have a thread that I created for it, but no one ever responded). Any solutions other than restarting the devices?

No sorry, my solution was to do a hard reset on my temp sensor. I have two CT100 thermostats and have no issue with either.