Smart Lock Guest Access creating 4+ digit codes on Schlage ZWave

I double checked with my Schlage Connect (zwave) manual and it said that I can have 4-8 digit codes.

However, whenever I try to create new codes in SLGA app/service, it only give me an option for 4 digit max.

Any reason for this?

I’m using the Schlage Connect Camelot FE469NX and Schlage Connect Century BE469 using the default Samsung Smartthings driver.

What driver are the locks using? I don’t recall if the stock driver exposes setting the code length or not. I know that the Z-Wave Lock PH driver from @philh30 exposes it in the settings menu for the lock. If the driver you are using doesn’t expose it, check in the ST Advanced Web App under the Attributes for your lock. You should see the main.lockCodes.codeLength component which will tell you the currently expected code length. Then scroll further down and look for the setCodeLength command. You can use that to change the required code length keeping in mind all existing codes on the lock will be deleted.


Omg! Thank you so much! This totally did it.