Smart Lighting App - Turn off after motion stops - no working?

I have several smart lighting apps that use the “Turn off after motion stops” option. Was working just fine , but now lights are not turning off after the preset time interval.

Anybody experiencing this? Any ideas?

1 Like

I have experienced this over the last couple weeks but it has got better as of late. The main culprit has a motion and switch running locally.

I had one issue earlier today with lights not turning off. For my case, the motion sensor history showed that it had never given a “motion stopped” event.

I’ve been having this issue for about a week now. They were all working fine when I set them up but now they seem to be hit or miss. I’m noticing the problem not only in ST but also in Alexa. It was rock solid a couple weeks ago and was firing every time.

If you look at the event history in the app, are you seeing “Motion detected” and “No Motion” events from the sensor?

I’ve had a Samsung motion sensor in my garage that triggers the inside lights via a Smart Lighting automation. In almost 2-1/2 years it hasn’t failed more than a dozen times.

I investigated further and it appears to only be an issue on the Alexa end. Motion sensors are no longer showing the timestamp on the motion detector screen and I think it’s because samsung is no longer passing it through. I talked to Amazon and they seemed clueless about the issue but I definitely narrowed it down to only misbehaving in Alexa and my webcore based automations are working fine.

1 Like

Agreed, I have the same Alexa issue that I have been wrestling for a week or 2, seems I can get the lights to go off instantly if motion not detected but any time delay added either fails or occasionally works, been driving me mad

1 Like

For what it’s worth, Smart Lighting has been rock solid for me for about 2 years. Garage interior lights triggered by Samsung motion sensor any time and garage exterior lights triggered between sunset and sunrise. Because everything involved is local (sensor, smart switch, and the SmartApp), the lights go on instantly.

If Smart Lighting is available, I recommend it for this use case.

I discovered late last night it’s a known issue acknowledged by Amazon and they say they’re working on it. Not sure if this link will work here because it goes outside ST Community: but here’s the gist:

Hi @Mkcityman​, thank you for the follow-up.

It looks like this is a known issue, there is a recent report from our technical team, they are working on this problem. So, as soon as I see the notification saying this is resolved, I will let you know.

Everybody started reporting it around the same time (within a few days of the 10th).

It appears to be a corrupted file thats not allowing the timestamp on the motion sensors in Alexa (you used to be able to see the last time motion was detected). This is now absent from the motion sensor page which is why our triggers like “if no motion detected for ‘x’ minutes” have all stopped working at the same time. Even echo flex motion sensors aren’t working. They’re turning on but not off if you use the “no motion for ‘x’ minutes”.

I saw a work around that said if you change the trigger to “if not motion for 0 minutes” and then add a wait command before your turn off commands it will work but I haven’t personally verified this and I’m not thrilled about reprogramming all my auto offs, and then reprogramming them again when the problem is fixed.

Unfortunately, I cannot control my 7 ceiling fans or 25 lightstrips in ST because the light strips aren’t directly compatible and the ceiling fan integration isn’t certified in the US and doesn’t work worth a darn.

I tried to get around this with an obscene amount of virtual switches but it was super convoluted and only 1/2 worked. My ceiling fans and light strips will have to remain in Alexa. But my 28 motion sensors and 53 bulbs all reside locally in ST and run rock solid in webcore.

Soo glad it wasn’t just me, hopefully things will go back to normal in a day or so

Just speaking as somebody who works in software development, that timeline might be unrealistic.

They wouldn’t even give an estimate on the time (my company doesn’t either) until it’s actually in development.

I know Amazon seems to have unlimited dev resources but I doubt their sprints are less than 2 weeks.

I’m mentally preparing for this to not work for a month+.

Got a small update from the Amazon forum on this issue from an Amazon employee:

Mauricio M. (Amazon Staff)

3 hours ago

Hi all, thank you for your reports.

I just checked the status of this issue and the technical team is still working on it. As soon as I see the issue is resolved, I’ll let you know.

Have a nice week.

This is now working for me… :slight_smile: My problem was that I had switched the action from “Turn On and Set Level” to activating a scene. It makes sense that the scene did not reset after the timeout. Would be nice if the interface caught this kind of inconsistency.

This appears to be working again. The timestamps have returned to the motion sensor page in Alexa and my routines have started firing again. I have NOT received confirmation of this from Amazon. These are just my observations.

Good news , I did switch my automation over to ST but it seems to be slow at triggering so will switch it back to Echo asap