Smart Home Monitor


(Tamara) #32

Create routines that arm and disarm and trigger them based on departure/arrival.

For instance, this is the routine I use to disarm when someone comes home:



#33

I have SHM set to Disarm when performing the “I’m Back” routine. I also have a minimote that has a button mapped to perform “I’m Back” (I want to use this button as a “silence” button in case the alarm trips unexpectedly).
This used to work fine with SmartAlarm, but with SHM, it looks like disarming SHM doesn’t actually silence a currently active alarm. Not sure why that is - it seems like it should.
Any ideas how to use a minimote button to silence an active alarm??


(Greg) #34

I ran into this issue as well. I think we were all just used to how Smart Alarm did stuff and expected SHM to behave the same. The fix is in your I’m back routine just go into “turn off these lights or switches” and you should be able to select your siren.

A word of caution. if you run a routine to silence the alarm (for false alarms) like I do, make sure you still go into SHM and formally dismiss the incident. If you leave and rearm SHM without first clearing the incident SHM will not sound the siren or send notifications again.


(Bobby) #35

You can dismiss alerts from a minimote with IFTTT…see thread below


(Will) #36

I second (or third or forth…) the call for entry and exit delays. Man is it annoying to have to clear those every time I leave. This should resolve itself once we can add other users since I’ll be able to use presence, but right now I do’t even set it anymore because when I’m running in and out all day it is just too many steps to have to constantly clear door and motion alerts. Even the option for a global delay of say 3-5 minutes would be awesome.

However outside of that it does to function as advertised and I’m happy being able to monitor the whole house relatively easily on my phone.


(Dave Rowley) #37

I’m in the same boat. For the times when geofencing doesn’t kick in and disable the alarm, I have my Yale YRD240 lock run a routine after a user successfully enters a PIN (using this app from @RBoy). Unfortunately, I usually end up with a false alarm - or worse, my wife does…because the routine can’t run/disarm SHM by the time the open/close sensor gets tripped and sets off the siren. This particular issue would be resolved if I could specify a 2-5 second entry delay in SHM to give @RBoy’s app enough time to communicate with SmartThings and run the Disarm routine.

I know this has also been posted in other places, such as Smart Home Monitor LIVE!, so can @slagle or @Dianoga or someone else at SmartThings chime in to let us know if this is even planned for development?


(www.rboyapps.com - Make your home your butler!) #38

@drowl87 here’s a little “hack” in the meanwhile. Since it appears the SHM gets notified of the motion before the Lock User Management App gets notified of the unlock code, try this:

  1. I’ve created a routine to “Disarm and change the mode”. All this routine does is to change the mode to Home and then Turn off the Alarm. I’ve configured the Lock Mgmt app to run this Routine in addition to disarming the SHM.
  2. I’ve also configured the lock mgmt app to turn off the alarm (switch) when a code is entered.

(Fast, Good, Cheap...pick two.) #39

True story…it works too! I’ve had no issues since installing this code.


(Scott) #40

I triggered a FALSE ALARM in SHM last night - got home late from an Super Bowl Party - activated my “GOOD EVENING” routine to shut garage door, set lights, etc. - then stuck my iPhone in my pocket before closing it, and apparently “butt set” ST to “Away” - at which point the alarms when off, texts were sent, etc.

I turned everything off - set SHM to Home. Then went into SHM to DISMISS the False Alarm. It will not reset back to normal. I have tried several times, I see NOTIFICATIONS that “Alarm cleared/canceled.” But still the red exclamation triangle is on the SHM status page.

I have tried resetting my home from IDE, and changing which lights get turned on turning an Intrusion Alarm (in an attempt to reset the script). Nothing seems to work to clear this ALERT from SHM page.

Is this a known issue? Or am I doing something wrong??


(Geko) #41

I have the same problem, the only difference being that I cannot dismiss smoke alarm since last Saturday. It was working in the past, so this is the issue that’s been introduced recently. These perpetual screw-ups are extremely frustrating.


(Jimmy) #42

i’ve found lately that i have to dismiss it and then manually pull down on the page to refresh it (iOS app) to get the red to go away.


(Scott) #43

I left for some meetings this morning - the APP correctly recognized that my iPhone had left the Geofence, and activated “Goodbye” routine this morning. When I got home this afternoon - “I’m Back” triggered correctly, turned off SHM, opened garage door, etc. When I checked SHM after getting into the house - it was showing the green “Everything OK” banner.

Apparently leaving, and returning reset it.


(Adam Davidson) #44

+1 for a delay option in SHM, to give time to enter a code on a keypad, or for presence sensors to update.


(phil) #45

can you send out sms to multiple number in SHM


#46

Yup, just set up people in your Contact Book in the ST mobile app via My Contacts.


(Dan) #47

That is, if you’re lucky enough to have the “My Contacts” feature in your ST mobile app. Unless something has changed recently, ST seems to not be propagating “My Contacts” any longer. You have to use a trick on Android to get it to appear, IIRC. And once you do have “My Contacts”, you lose Hub Offline and Low Battery push notifications. At least I never receive those notifications any longer…

But yes, you can do multiple push or sms notifications in SHM if you have My Contacts. :slight_smile:


(Joern) #48

Looks like not only Low Battery push notification isn’t still working if My Contacts is enabled. I set up a custom rule in SHM without notification for my outdoor Arlo camera but always get a push notification. Opened a support ticket last week, but support wasn’t able to fix by now. They had to forward to the engineering team. I was told by support, My Contacts is a discontinued feature. Support mentioned the SHM custome rule push notification issue could be related to the Contact Book.

Does any of you have the same issue?


(phil) #49

I Guess it is time to create my own security application with webCoRE


(Joern) #50

Is there a way to stop this annoying push notifications from SHM custom rules?


(Dan) #51

Sure. Go into your custom SHM rule, and then go into “Text and Push Notifications”, and remove all entries.

Maybe you’ve already tried that?

Maybe delete the custom rule and then recreate it?

Not sure why you’d want a custom rule if you didn’t want the notifications? Isn’t that usually the point of the custom rules? I use them to tell me if a door has been left open for too long, or when Presence sensors come and go, etc…