Sinope WL4200 leak sensor detected as button

Just tried pairing a sinope WL4200 leak sensor to my hub and it is being detected as a button, not a leak sensor. Even if I add it by selecting brand and then leak sensor, it still pairs as a button. When I try to change the driver to a zigbee water leak sensor (driver already installed) I have no available drivers. Any ideas? Thanks

what info is displayed for fingerprint and manufacturer?
use the following to find the info:

take s screenshot of the details

@jkp Do I find this info under the details button or is it metadata found in profile button in the api browser?

Details :slight_smile:

ok, I will let the community experts figure this one out. stumped

did you use the Scan option when adding it?

I saw you mentioned by brand then leak sensor but that would not work.

try removing the device, remove the edge driver and reinstall the Edge driver then try to scan to find the sensor.

Tried scanning and manual add multiple times. I’ll try deleting the driver and re-adding it. Thanks

Was able to get it to add properly by using scan after I deleted the ST zigbee button mc driver. Weird!