Simultaneous light turn on

After much research and debate, I pulled the trigger on SmartThings recently and am loving it so far. Thank you to the team for a great product.

I was recently at a hotel that used Lutron’s Stanza setup ( for light control. The only thing that made me jealous was that lights faded on simultaneously, creating a very elegant look. My SmartThings hub turns on my Z-Wave switch-controlled lights one at a time in rapid succession, which is a little odd. Does anyone know if there’s a lighting system that works with SmartThings that will turn on devices simultaneously rather that one at a time? Or is there a way to have SmartThings do that with Z-Wave switches?

It depends on how you turn them on. You say that your hub turns them on in rapid succession. What is happening that causes the hub to turn them on? What do you actually do to turn them on?

Zwave itself is a mesh network, which means exact sequencing cannot be guaranteed. Messages can bounce around the network for a few seconds. But that’s also why it’s less expensive.

You can use direct association to control up to 5 devices in a group, which will help, but it still may not be perfect.

I’m using “The Big Switch” in the Convenience section of the SmartApps. When one switch is turned on it turns on all the switches.

Thanks JDRoberts, can you point me to a link so I can try that?

Zwave association? It depends on the exact model of switches you have.

Do you have the Aeon minimote? It will be helpful in the next step if your switches do support association.

Most of your lag is from the switch being turned on, from then until ST sees that it’s on. It turns out that Lutron holds a patent on that functionality, which you witnessed. There are some other manufacturers that have licensed the Lutron patent (Leviton and Cooper, for two), and have some products that provide “instant reporting”.

If you are going to use a switch to turn things on, using an instant reporting device is the only way you can come close to what Lutron does with ST. However, if you use motion sensors to turn on the lights, you will get a much better lighting effect, pretty close to Lutron’s. That is because their patent only covers in-wall switches, not motion sensors (or any other kind of sensor).

I ended up using motion sensors for almost all of the lighting in my house, in order to get that nice smooth ramp you are describing. It isn’t perfect (due to mesh network as @JDRoberts explains), but it’s pretty good.

1 Like

If you can configure your lights with a nice slow dim up, it helps hide that ST has to cycle through commands. In my basement with a 1.5 second full transition the lights look very close to simultaneous (GE Link bulbs).

Most commercial systems will be a single protocol, so they will take advantage of things like direct association or groups, so that a single message tells multiple lights what to do, which produces that simultaneous response. When trying to be protocol agnostic like ST, it adds significant complexity to try and incorporate these features.

If or when st supports lighting scenes with zigbee this will be possible.

1 Like

That’s interesting, because my Cree bulbs come on first, then z-wave. They are also more reliable than z-wave, and have fewer weird timing issues.

Just stumbled upon this topic, and I couldn’t find a resolution in here. I’ve got the same problem: my GE Link bulbs (3 of them in a kitchen fixture) turn on in rapid succession instead of simultaneously. The effect is jarring, and I can’t find a way to give them a 1.5 second full transition. How did you accomplish this?

When on the device view of the GE Links, press the top right 3 dots and Edit Device. There are 2 settings here. Dim Rate is the speed the bulb will transition when making level changes. Dim for On/Off will enable that same transition speed for on and off commands. Normal and Yes are typical selections and is the equivalent of 1.5 sec ramp speed for all transitions. You can try Slow or even Very Slow to see if it helps.

One quirk that might still cause it to appear that they instantly come on is when they are sent a dim command while off. For instance, motion triggered lights where they are set to come on at a specific level. In this case the light is told to go to say 50, then is told off. The next time it’s told to turn on to 50, the bulb will look like it goes there instantly. That’s because of how the zigbee level commands work.

To get around this issue, you might try setting the level separately from the motion trigger and just have motion turn the lights on and off, which that 2nd setting above will ensure gives a smooth transition.

1 Like

Thanks a ton for the fast response!

I wasn’t using the custom GE Link device type last night when I posted, as I didn’t yet know what I was doing–they were still just Hue Lux bulbs to ST, so I didn’t see these options anywhere. After some reading, I realized I had to remove the bulbs from my Hue Bridge, reset them (turn the power off for 3 sec, then on for 3 sec, and repeat 5 times), and finally re-discover them using SmartThings in order to actually use the custom device type.

The only real quirk I’m noticing doesn’t seem to be what you’re describing: it appears as though, when fading to ‘on,’ there’s kind of an abrupt jump (say, from 0% - 40%), followed by a smooth dimming from there to 100%. I’m simply turning the bulbs to ‘on’ in my “Turn Kitchen Lights on when Motion is Detected” routine, and not to a particular level, but the abrupt jump persists.

I think this is just a limitation of the hardware in the bulb. For one, GE links are still pretty bright at low dim levels because of the clear glass, so almost all the perceivable difference in light output is in the 0-50% range. Also they don’t get enough juice to turn on until some threshold that is higher than their minimum dim setting, so it looks like they pop on.

Try either Slow or Very Slow and see if that’s more pleasing. I find that both give you a more gradual effect for turning on as it spends more time at the lower dim levels. After about 50%, the difference in light output is minimal. You’ll have to balance that with the slower fade off too.