Shm too sensitive, can I roll own


(Chris Crawford) #1

Hi, I get at least 1 false alarm per night around 12-3 am. I think it’s likely due to house settling and the sensor moves a split second. As a result the sure goes off.

Is there a way to roll my own shm that will only go off if the sensor is open for more than 5 secs?

My guess is core, but didn’t know if easier way.
Thanks,
Chris


(might be my fake name?) #2

Yes. WebCORE is the easier way. The newest version of core. It’s web-based. And faster and has more features than core.


(Chris Crawford) #3

Hmm ok thanks, will look into webcore. Is it easy to use like shm? I have no coding background, but know how to copy paste into ide


(might be my fake name?) #4

you don’t need a coding background. Everything had drop down boxes. I don’t have coding experience either. U won’t regret it.


(Mark) #5

What kind of sensor?


(Chris Crawford) #6

St multipurpose brand with stock dth


(Mark) #7

So it’s always the same sensor, and the intrusion alert is going off because shm is detecting it as open?


(Chris Crawford) #8

Out of 18 St sensors, it’s 5 of them only because it is flagged as opened. But then when I check it says closed…so momentarily open for whatever reason when in fact it isn’t.

If I could have a if open for 3 seconds sound yh alarm, it’d be much better and remove false alarms


(Mark) #9

I’m not sure that a house settling is actually the best explanation for what you’re experiencing.

Yes, using a smartapp like CoRE could accomplish what you’re looking to do.

But it seems more likely to me that those multisensors are throwing a false open event for some other reason. Could be related to weak spots in your zigbee mesh, or some interference of some kind. Maybe those five devices are faulty. Or some ST cloud gremlin.


(Chris Crawford) #10

Could be the five, but they are next to other ones less than 1 ft…ie 2 adjacent windows.

I will try core and piston for if window open for more than 3 secs past 1030pm then sound alarm.

Only sad that I can’t use shm…I like the simplicity

Chris


#11

I would agree that it’s unlikely that the house settling is causing the problem. But you’ll know if you switch to a different type of automation so that’s worth a try.

Just be aware that there are a few significant differences between smart home monitor, which is an official feature, and webcore, which is not. These might not make any difference to you, but you should just be aware of them.

One) only smart home monitor alerts can be used to trigger the scout alarm system if you are using that integration

Two) the smart home monitor alerts are eligible to run locally if the devices are eligible to run locally. It’s a little complicated, because some parts of smart home monitor, including arming and disarming the system, don’t run locally. But if you are using a zigbee door sensor to trigger a Z wave siren or some lights and you have set that up with smart home monitor, that would still happen even if the Internet was down.

However, no custom code is eligible to run locally at this time. So if your Internet is out or just if the SmartThings cloud is not available, your custom code, including core or web core, will not run at all.

Again, that may not matter to you, but it’s just something to be aware of.


(Chris Crawford) #12

Thank you all, I may try and reboot hub, repair networks and see.i just like the fancy splash screen for arming. I understand nuance of local vs cloud processing.

I plan to look through the logs and check, not sure for what but looks like people on stug on FB reported similar issue recently

Chris


#13

You can use a widget for arming or disarming anything you can start from a routine. So the routine can turn on a virtual switch and your piston or smart app can respond to the virtual switch turning on. That’s typically even faster than opening the SmartThings mobile app. :sunglasses:

https://support.smartthings.com/hc/en-us/articles/206145893-Is-there-a-SmartThings-widget-