SHM not allowing Audio Notifications for Smoke and Leaks

In Smart Home Monitor
I can use my Aeon Doorbell as a Audio Notification player to play custom track for Security and Custom, but for some reason when I go to select Audio Notifications for Smoke or Leaks, it says None of the selected audio devices support text to speech notifications. It does not give me a chance to select a device.

The Aeon doorbell does not use text to speech (TTS). Instead, it uses pre-recorded sound files, which could be a bell, buzzer, or spoken phrase. Because of this difference, smart home monitor doesn’t know what to do with it in the context of audio notifications.

There are some ways to work around this, you would have to create a virtual switch which you would identify as a siren, tie that virtual switch to the specific audio file that you want the doorbell to play, and have smart home monitor turn on that “siren” in the situation that you want. It’s kind of clunky, but I think you could make it work. :sunglasses:

2 things.

  1. Cool! How would I create a virtual switch that plays a specific audio file?
  2. That doesn’t explain why I can use it with Security and Custom though? I even added the capability to the DTH and still the same thing.

    Thanks JD!

You won’t use the audio screen. You’ll trigger the “siren” instead.

As far as having the switch triggered the doorbell playing, the easiest way would be through core.

Which DTH are you using for the doorbell?

I am having a similar issue. I had my SHM setup to play Audio Notifications for Security, Smoke, Leaks and Custom thru my Sonos speakers. It stopped working for leaks about a month ago, so I deleted and tried to add back and now there is no option for all but Security. I get a message saying “none of the selected audio devices support text to speech notifications”. Which is NOT correct since it is working for Security both with Default and Custom messages.