Schlage Touchscreen Deadbolt


(David G) #1

Hey there

Anyway to automate the Schlage z-wave lock using smartthings apps, or do I have to use the smartthings presence to automate actions like unlocking when I arrive and locking when I leave, etc.?


(Adam) #2

you can use tasker with endpoints to set up any sort of automation, along with autovoice you can setup your STs to react to voice commands.


(David G) #3

Adam, thanks, but what you just said to me sounded like latin :slight_smile:


(David G) #4

Just did a quick search on those things which you mentioned, and although I don’t understand it all, I’m not running Android


(Andrew Urman) #5

What kind of things did you want to automate? You can use the presence tag or your phone for sensing arrivals.


(David G) #6

The problem is that it’s so inconsistent. One day I come home, and my mobile phoned is sensed and my front door unlocks. The next day, nothing


(Jeremy Whittaker) #7

@alucard76 I purchased the Schlage BE469NX last week. I setup mobile presence on my ST app and it has worked great every time. It also unlocks my front gate every time I get home. I did have a hiccup one time where it did not unlock but it was because the setting on presence is set to 1 minute and I was too quick to my front gate.

Perhaps your ST hub is too far away from the lock? I believe if you purchase some of the GE ZWAVE modules they have repeaters built into them. So if you were to wire another switch or outlet in between your Schlage lock and your hub it may help with the wireless transmissions if that is the problem.

From within your app you can see the logs. When you arrive home does the ST app logs show that it detected your presence?


(David G) #8

Thanks Jeremy. What’s happening is that when I’m for a while, upon my return, it does work, the front lock unlocks and I get a notification. But, when I take my dogs for a walk, say 15 minutes, outside the geofence, it doesn’t work.


(David G) #9

Actually, there’s still no consistency. I was out for a few hours yesterday, and when I came home, the door didn’t unlock


(Brennan G) #10

Same issue… Using presence tags to detect presence and it worked for the first day or so. I have a dimmer switch located within 10’ of the lock, so I don’t think that the range is an issue. As an example of the inconsistencies experienced, I’ve manually locked the door from the inside and would expect the status to update in the app. Unfortunately, that’s not the case. It still shows unlocked. I’ve pulled down to refresh, hit the refresh button within the device tile and even killed the ST app manually and the status doesn’t change.


(David G) #11

Same issue as BrennanG.


(David G) #12

Maybe that’s the issue! If the app is not working properly and it thinks the door is unlocked, it won’t unlock it when you arrive home because it thinks it’s already unlocked.


(Brennan G) #13

Ah… Maybe. I will say that I’ve hit the “Lock” tile and the app status goes to Locked, but the deadbolt itself didn’t do anything. I’ve tried having the ST app open when I arrived at home, as well as completely closed out and get the same experience.


(Brennan G) #14

Update: Talked with Ryan @ ST and walked through pairing at within 6’ from the hub (after I uninstalled it). It works just as it did before… It will open and close all day via the mobile app, but the status does not update on the app itself when manually locked form the inside (ever) or via the button on the exterior side (most of the time). All around inconsistent.

Moral of the story: Ryan has escalated to an engineer. I’ll update when I have resolution.


(Chrisb) #15

For what it’s worth, my I just removed and re-added my Kwikset Lever Lock. I’m now getting near-instant updates for all but one scenario most of the time. What I’ve found is that if I try to change things too fast it appears to sometimes get confused. For instance, if I unlock it, then relock it right away (within 1-2 seconds) it will sometimes show up as unlocked and not update to locked unless I do a manual “refresh.”

So what works?

  • If I turn the lock manually from the inside to locked or unlock
  • If I use the key to manually lock or unlock from the outside
  • If I use the keypad to electronically lock or unlock from the outside.

What doesn’t work?

  • I have my Kwikset setup to automatically lock after 30 seconds. This is a built-in Kwikset function, not a SmartThings app. When this built-in electronic function fires and locks the door it is NOT updating in SmartThings.

(Cory S) #16

I have a lot of issues with the lock not locking or unlocking when it is sent a command via an app. it doesn’t seem to be an issue with presence. Sometimes the lock just doesn’t respond to the command. I have had some luck with modifying the app to send two commands to lock/unlock and it has seemed to help. But, I think a lot of it may be latency on the ST end that the lock doesn’t deal well with.

Currently, I am using my phone as a presence device about a quarter mile radius around my house. If it doesn’t get the lock to respond, usually when my actual presence tag arrives shortly after it will be successful. But, there are some days where it just flat out doesn’t work no matter what.


(Chrisb) #17

@coryds

I’m experiencing some irregularity with my Kwikset as well.

Generally, if I tap the ‘unlock’ tile on the mobile app, it will correctly send an unlock command. This will often be a 4-8 second delay, but it almost always goes through.

However, when the command is issued via a SmartApp program, then it’s much more hit or miss. One of these days I’m going to really troubleshoot and see if I can get any firm data on when/why/how. My situation is complicated because I have my kwikset doing it’s own internal lock after 30 seconds, so I don’t know if some times when it’s locked I just didn’t get from my car to the door in 30 seconds. I try to have it run a unlock command when I get home, then another unlock command 31 second later, but with I don’t know when those commands are actually hitting the lock.


(Cory S) #18

Yep, pretty much the exact same issues as you @chrisb, except I have a Schlage. I really don’t understand why a manually activated command via the app is more reliable than a smart app command…but it sure seems to be. My one and only theory is the lock is going into some kind of hibernation/sleep mode after prolonged period of not using it. So, when you are coming home from work it is more likely to not hear the command, than if you are home and have been messing with stuff.


(Fast, Good, Cheap...pick two.) #19

I have the same issue but only with 1 of my 2 doors. Both Schlage locks / door sensors.

The only difference I can see is that 1 is closer to the hub than the other. I’m going to place a couple repeaters around the house to see it that helps.


(Fast, Good, Cheap...pick two.) #20

Turns out the issue was that there was no lock command for a door that was unlocked via presence sensor but not opened/closed.

I ended up installing an auto lock smart app by Chris Sader (@csader)