Schlage touch screen lock. Can't Zwave exclude from lock and reprogram

I recently I couldn’t remotely change entry codes and trying to Zwave exclude from my lock via Smart Things APP and reprogram. With the Program code then enter “0”

When I try that, I get the “X”

It seems that the Zwave is Enrolled because if I disconnect the battery and reconnect, the alarm light will blink 1 time meaning it is Enrolled.

I tried rebooting my Hub. Nothing

Everything worked great with the Classic Smart things App and when I went to the NEW app this issue started.

How can I delete and reprogram?

Any help would be great.

thank you

Let’s go back to not being able to change the codes on the lock. What smartapp to change codes are you using and what device handler is assigned to the lock?

I just went through this yesterday with a Schlage Z-wave lock. Not quite the same as I had mine connected to Hubitat, but the Hubitat hub would not stay connected to one particular lock. It was the furthest from my Hub and if I moved it to a more central location it messed up the lock on the other end of the house. I had tried Z-wave range extenders but that didn’t seem to help with this lock. The extenders did did help with a Kickset lock that is in the same area. So I moved my ST hub to the more central location and moved the lock back on ST.

I still had to setup a wifi extender and the hub in a location right next to the lock to get it to pair. After pairing I moved my ST hub back and did a Z-wave repair and it seems pretty solid now. Its only been a day, but we will see.

Thanks for the info!

I tried everything. When I first got the lock 2 years ago, it was smooth sailing. It set right up. I even tried the repair and that did not help. I also tried the zwave exclude via the Smart App it can’t find the lock.

I think my hub is the issue… I’m still working on it.

Thank you

Thanks for the help!

I always had no issues with the classic app for assigning and deleting codes. Once the new app came along this all started.

This is what I’m seeing from the "

smartthings : Z-Wave Lock Published Actuator, Battery, Configuration, Health Check, Lock, Lock Codes, Polling, Refresh, Sensor

I think this could be a Hub issue. I reset with no luck. When I view the Hub icon in ST it says connected but there’s a small (x) on the logo… ??? don’t know what that means

Try this:

  1. Reset your lock to factory defaults
  2. Reboot your hub
  3. Bring your lock within 5ft of the hub
  4. Exclude your lock
  5. Pair your lock

It should work now. The stock Z-Wave lock device handler should work however you can optionally use this enhanced z-wave lock device handler to get access to your locks’ advanced feature.

Again, at first when I got the lock I was able to pair via smart things app and then enroll the lock with the Program code and 0… and my Smart Connect Hub was a room away where it is now.

This time I took the lock off the door, place it by the HUB, did factory reset ,rebooted the hub and tried to exclude the lock with NO luck. I can tell that the lock is still enrolled by disconnecting the battery and when I reconnect, the alarm button lights up.

When I currently try and pair the lock, I can see the Hub light flashing to 2 colors BUT it can’t find the lock.

How does the [enhanced z-wave lock device handler work? will that solve the issue? and how do you install this in the smart site?

How can I exclude this lock? Could it be a bad lock.

Your thoughts. thanks for your help

At first when I got the lock I was able to pair this lock with Smart things then enroll when my current HUB is 2 rooms away.

I just took the lock off the lock from the door. Put it next to the HUB, I factory reset, rebooted the HUB and still can’t exclude the lock. I just see the RED “X” not the 3 green checks.

I can tell this lock is still enrolled by disconnecting the battery and when you reconnect the battery the alarm light blinks 1 time.

Will this enhanced z-wave lock device handler resolve the issues. How do you install this? Is it done on Smart where I can see my Hub info etc?

Is there a way to exclude the lock?

Tried everything. Wondering if it’s a bad HUB or the lock itself.

Thank you.

I figured it out!!!

I put the lock back in the door. Now here’s a trick…

I ran the exclusion command from the Smart Things IOS app and while that’'s running and went to the door pad and entered Program Code + 0 and I got the 3 green checks… I then was able to pair and it found my lock.



1 Like