Schlage code unlock no longer triggering automation

Schlage FE599 Lock used to turn on the lights and also run a routine to unlock the door (kept it from automatically re-locking) when I entered the code into the keypad. At some point this stopped, may have been after changing the batteries, not sure.

It still does run the routines if I manually unlock the door from the inside or unlock the door with the app, but not from the keypad.

Not sure why the code unlock is treated differently from the manual unlock. I do have a smart app called LockManager 2017 V1.4 In here it appears as if I still have the triggers in place.

I vaguely think I remember entering some code into the lock keypad itself to control this function but I could be mistaken. Getting hard to remember all this stuff a year or more after working with it.

Any ideas are much appreciated.

Steve.

Could be a couple of reasons. Since you’re saying that the routines work on a manual unlock but not with a keypad then it’s likely the app which stopped working after an update from SmartThings earlier this year. Smartthings has made many changes to the platform and frameworks (and continues to do so to fix issues and add new features) which requires apps and device handlers to be kept updated to continue to work.

If you have access to rboy apps, you may want to check out this app which is updated regularly and works pretty well for creating custom actions including executing routines like you’re doing:

So this is happening to me too on a Kwikset. Routines just stopped firing. I’m running the original User Lock Manager. I’ll upgrade and pay @RBoy . He’s earned it.

Edit: spelling and clarification

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.