Samsung Washer, Smartthings Hub V3 and Alexa

I have been trying to connect my washing machine to the Samsung Smartthings Hub V3 for some time. How do you do that and how can I control them via Alexa?
I would be very grateful for ideas

Samsung’s connected appliances don’t require a SmartThings hub. They connect directly to your WiFi.

OK. I understand that. But according to support from Samsung, the washing machine should be integrated into the hub. Then support should work with Alexa. Weird.

I have both a Samsung washer and dryer set up in ST, and you definitely don’t need a hub. Support’s description is wrong and should have been clarified for you. The hub is needed for using these appliances in automations along side other devices that are directly connected to your hub (like zigbee and zwave devices).

My washer needed 2 attempts to join, but my dryer joined right away. Make sure you have good wifi coverage at these appliances. The way the process worked best for me was to start the process on the washer or dryer first, then go to the new SmartThings app to add it. You’ll see that your phone drops off your wifi to join to the washer or dryer’s local “hotspot”, performs wifi config on the appliance, and then rejoins to your home wifi.

The appliances will show up and begin a registration and configuration process. Sometimes the registration process fails, but no worries because it still shows up in your Samsung account and SmartThings.

Where the hub comes into play is when you want to include these appliances in automations and then Alexa - BUT, I’m not sure you even need a hub to set up Alexa to be honest because it’s been a while for me. You can set up automations to trigger (the IF section) based off of device status, washing/drying progress, or Smart Control.

A few notes:

By default you get notified when cycles get completed, which means you don’t need to create these in the new app.

By default these will show as OFFLINE in the new app when they are powered off, but as soon as you turn them on they will become ONLINE. You can’t turn them on via the mobile app. I believe that’s a safety feature. If you have a gas dryer, all you can do is monitor and download custom cycles, again for safety reasons.

I have not tried Alexa yet, and Bixby is terrible.

2 Likes

Thank you for the quick and detailed answer. I will continue to deal with the newly acquired information. :+1:t2:

1 Like

@Riccardo_Savina, I think that should be mentioned that the wifi network should be a 2.4Ghz and not a 5Ghz network. If your router provides both of them, then you might want to turn the 5Ghz off for the pairing process.

That is a usual note for many Wifi Smart Appliances as the Wifi configuration has to be passed to the device is the 2.4Ghz network.

1 Like

@johnconstantelo, just to hijack a bit the topic. Are the notifications working recently for your washing machine? Mine has stopped sending them recently. Both to my phone and my wife’s as well. Any idea?

Had the same problem. I deleted and added the washing machine in Smartthings. Notifications are coming back now.

Hi @GSzabados, yeah they’re working well so far. What does your individual device notification toggle show?

@johnconstantelo, It is on. I tried to toggle, but nothing. I need to search. Recently a few months ago someone had the same issue, but I cannot remember what was the solution.

1 Like

I don’t think that Alexa work with washing machine but technology can help to solve this issue.

So, I have solved this mystery. The Samsung Home service has been seized on the 20th of April, 2020 as the app says, but of course it hasn’t been mentioned in the SmartThings app. Of course, the washing machine has made it into the new app a long time ago, but the notification all stopped for both the Samsung Home Connect and for the SmartThings app compatible integration. It is all fckd up. It took me almost an hour to manage the washing machine to connect SmartThings again, meanwhile it was before working today through the SmartThings app, but not sending notifications. Now after adding it again, all the power consumption information from the past 6 months has been vanished.

Funny thing, I went through how to add the device, and of course, first step, I selected the Room. The app, the latest one, added the device to no room at the first time. I just hope that I haven’t hit the bug what @jkp had with the Wemo devices. I will have to check my rooms again in a few hours.