Samsung TV - Can't Turn On

Mine is working fine with the following setup.
Check on the power on with mobile
From: settings - network - expert settings
The network should be on wireless, but i had the lan cable plugged in also, i let it there but when the TV is going off the lead from the router it will go off also but if I’m trying to wake up the TV with Google home is working every time. i don’t know If the lan cable helps or not but I told you when the TV is going off off the LEDs from the router is going off also and when the TV is on on the leds from the router comes back on but the connection to the internet is via wireless try that also but at my TV is working every time good luck

1 Like

Hello all,

Hope this helps as this is what I have done in order to get it working correctly

On tv

Settings > general > network settings > expert settings > power on with mobile (turn on) and enable IP remote .

Currently running wireless to tv

1 Like

I did exactly that yesterday - and it was working perfectly, powering up from a motion sensor when a particular room was entered. I must have tested a dozen times and was very pleased with it.

Today it didnt work though!!

This just seems a bit hit & miss. Sometimes it works, sometimes it doesnt.

Cant really figure out why - could it be that the “off” signal from a standard remote is differeent to that from a smart device?

I was reaching why my new Google Home Mini could do everything but turn on my Q7.

Registered here just to copy/paste this note that is on the SmartThings device compatibility page.

“Not all features are available on all TV models. Turning your TV On with Voice does not work if your TV is connected to the internet through an Ethernet cable. Channel changing works on the TV antenna input and not cable TV set-top boxes.”

So it’s apparently a known limitation.

A useful bit of information, but…

My Q70 is not connected by Ethernet and it will turn on “sometimes” with smarthings.

Very frustrating.

Not being able to turn the TV on when it is connected via a ethernet cable is a pretty lame limitation.

1 Like

Ive trues Smartthings support on this and their latest response id thats its a problem with the firewall on mu Virgin media router. They suggest Smartthings may use different ports depending on load. Does this make sense:-

There may possibly be firewalls on the Virgin Media router, I would suggest checking with the Virgin Media team on how to enable/disable the. Do double-check your router’s network settings and make sure the following ports are open:
• 11111
• 9443
• 443
• 39500
• 37
• NTP port (123)
These should all be TCP rather than UDP. The reason we mention this is due to the SmartThings platform utilising Elastic Load Balancing, which automatically distributes the Hub traffic.

2 Likes

another problem is the NA01 shard doesn’t sync OCF device states correctly. So if you’re on NA01, that’s something to check, too.

So the only way any of this will work is if the tv is connected over WiFi and not via the LAN network port?

I get 55RU7402 few days ago (with only 2.4GHz useless wifi…)No more smart devices in my home :frowning: will get lighting soon.

So I have the same problem. Running Smartthings app on my phone but cannot power on tv with that. Tv connected wired cable to my tp-link router, and the tp-link router connected wired to Upc router. No port forwarding yet.

Tonight I start the tv, got the smart things app on tv, get the settings from phone, and NOT closing the app on tv. Than turned the tv off with smartphone using smarttings app. Wait 5 minutes or more and… miracle everywhere…I can turn on tv with smarttings app on my phone.
If I close the app on the tv, I can not switch on with phone…yeah so easy solution…
If you close the Smartthings app on the Tv, than your phone’s Smartthings app can not communicate and shows the tv power botton grey. If you not close the app on Tv, than on your phone’s app shows you red coloured power button…so you can turn it on with your phone. The Tv and the phone was on the same lan network!

Btw network settings-> power on with phone and ip remote was enabled too!

Merry Christmas from Humgary!
Hope it helps you.

I’m having trouble getting this to work (my TV definitely is WOL compatible).
The MAC address is all lowercase with no colons/spaces/dashes.
No SecureOn password required.

Hi,

but I never run the smartthings ap on the TV and it works part of the time.

I tested this a few times whilst running live logging in the IDE and I get this error on teh occasions that the TV doesnt start…

(first event is at the bottom, last at the top)

10:59:55 AM: warn error : returned [requestId:5e559d0e-4480-4491-a22a-a956fdec8bdb, error:[code:UnexpectedError, target:null, message:unsuccessful-http-call status=404, details:[]]]
10:59:55 AM: debug postOcfCommand(/oic/route/f860115a-f065-49cc-af18-27cb122efea5/sec/tv/inputsource, [x.com.samsung.tv.currentMode:[dtv]])
10:59:55 AM: warn throw : returned java.util.concurrent.ExecutionException: java.util.concurrent.TimeoutException: Request timed out to pooch.st.internal/IPADDRESS:80 of 5000 ms

A few minutes later, it worked OK withougb going near the TV in the interim.

It seems that the “warn” message is key - a timeout.

Still struggling and waiting for Smartthings support to get back to me.

Ian

Hello,

I just received Google Nest mini and I constate the same problem : impossible to turn on my TV (40MU6405, tyzen 3) with google assistant.

After lots of tests, I found the problem is in the communication between TV and API of Smartthings

Tests when TV on :
With Smartthings (on Galaxy S7), wifi connection on tel => local connection between TV and Smartthings => Smartthing sees TV as connected => “turn off TV” with Smartthings is OK
With Smartthings (on Galaxy S7), mobile (4G) connection on tel => internet connection between TV and Smartthings (via API) => Smartthing sees TV as connected => “turn off TV” with Smartthings is OK
With Google Home (or assistant) => internet connection between TV and Google Home (via API Smartthings) => Google Home sees TV as connected => “turn off TV” with Google Home is OK

Tests when TV off :
With Smartthings (on Galaxy S7), wifi connection on tel => local connection between TV and Smartthings => Smartthing sees TV as desactivated => “turn on TV” with Smartthings is OK
With Smartthings (on Galaxy S7), mobile (4G) connection on tel => internet connection between TV and Smartthings (via API) => Smartthing sees TV as offline => “turn on TV” with Smartthings is KO
With Google Home (or assistant) => internet connection between TV and Google Home (via API Smartthings) => Google Home sees TV as offline => “turn on TV” with Google Home is KO

Google Home always use API Smartthings to communicate with Samsung TV (because we associate Smartthings account to Google Home), but when TV is off, Smartthings sees TV as offline (not desactivated) and so can not communicate with TV.

Is it possible to resolve this problem between TV and API of Smartthings ?

Thanks,

Nice troubleshooting. But this isn’t possible. Communications with the tv always go through the SmartThings cloud.

Hello,

If communications with the tv always go through the SmartThings cloud, so why there is a différence of “TV status” in Smartthings app when phone is on Wifi or 4G ?

In Smartthings app on my phone, when TV is off :

  • Phone with Wifi => status of TV is desactivated
  • I switch to 4G on phone => status of TV is now offline (“turn on” TV is KO)
  • I switch to Wifi on phone => status of TV is now desactivated (“turn on” TV is now OK)

That’s why I think there is a difference between local connection and Internet connection.

if you use your phone when you are in the house it definately connects differently - because you get additional functionality, like show TV on phone.

If you use the phone remotely you just get basic functionality - but can still turn on the TV (when it works).

Mine should turn on using a motion sensor anyway, but both that and using the phone both fail sometimes. I think it is something to do with that timeout when smarthings tries to contact the TV. Maybe it just need longer to “wake up” ?

Interesting. All the architecture diagrams i’ve seen have the mobile app talking to the SmartThings cloud. Maybe they’ve made some changes for TVs since it doesn’t make sense to send all that bandwidth through the cloud for casting screens, etc.

Thanks IAN and JIMMY

@JIMMY : I think you’re right too :wink:

I’ve done this test :
I disconnect Internet from box. Phone with wifi, TV with wifi, so Phone and TV are on local network with no access to internet.
I run Smartthings app on my phone, try to turn on TV => it works (TV on) but after a few time (30s), impossible to send actions to TV from Smartthings app (silent button or turn off don’t work). So in this case, it seems that TV needs SmartThings cloud to communicate.

In conclusion, I definitively don’t understand how the communication between TVs and Smartthings works, but it’s very probably that there is a problem of communication between TVs and SmartThings cloud when TVs are off.

1 Like

Works like a charm! I’m ashamed of me because I didn’t see that option before.