Samsung Soundbar HW-Q70 No Longer Works Via Alexa. Any Ideas?

I’ve owned a Samsung Soundbar HW-Q70T since Dec. 2020. Up until about a year ago, it worked great integrated with Alexa via SmartThings. I would tell Alexa to play music on it and she would, no problem. But something changed last year and I’ve been unable to get Alexa to recognize it as a speaker ever since. I even went through extensive back-and-forth emails with Samsung SmartThings tech support person Ejaz between April and June of this year and he couldn’t figure it out. Hoping for some new perspective and novel ideas by you smart people to get this soundbar recognized by Alexa again.

The screen shots attached from my phone (taken just now) show the Soundbar listed among the devices Alexa sees, that it is “Enabled” as a “Speaker” and that it is loaded into SmartThings correctly.

But when I say, “Alexa, play music on living room soundbar.” She says, “I didn’t find anything called living room soundbar that can play music. To play on your speaker, use the device name or setup multi-room music in the Alexa app.

Thanks,
Daniel

I think you are asking the same…

Any ideas?

Sorry, no idea. The only thing what I can do is tagging @Lars, the developer of the current Alexa integration.

I do not use Amazon Echo devices, neither have a Samsung Soundbar, so I don’t have any experience with the issue.

There were some other topics where people had similar issues with the Google Home integration.

But as you asked, you should be able to turn on/off and start to play music on the Soundbar through Alexa.

Let’s hope that @Lars can give some insight.

1 Like

Hi Daniel,

I am sorry to hear you are having issues. The regular SmartThings skill allows for playback commands (play, pause, next, previous), volume, input source etc. That means you can say “play on living room soundbar” and that will perform the same action as if you pressed play on the remote control. However, the skill does not support anything relating to content playback, like “play spotify on living room soundbar” or “play music on soundbar”. It is possible that Alexas speech engine used to understand “play music on soundbar” as “play” and sent it to SmartThings skill but something changed on their side.
There is another skill, Amazon.com: Samsung Wireless Audio : Alexa Skills (“Samsung Wireless Audio” in skillstore) that I believe does what you want if it supports your soundbar. Is it possible you had this installed previously?

Lars

2 Likes

Lars, thank you for the help. It is the weirdest thing… After a year of my soundbar integration with Alexa not functioning correctly and me finally posting on this site as a last resort to find some kind of solution… All of a sudden it started working again.

I now have a second entry for my soundbar in my device list in the Alexa app. The original entry called “Living Room Soundbar” with the little stereo speaker icon (which was in the picture I posted previously) is not capable of playing music. Well, I went into SmartThings and then into my Alexa settings for my soundbar again, disconnected Alexa, and then reconnected Alexa. Now I see a second entry for my soundbar in Alexa called “Samsung Soundbar” that has something similar to a WiFi icon next to it. When I tap into that, the settings are totally different from the other entry that exists. With this in the device list, I can now say “Alexa, play Daft Punk on Samsung Soundbar” and it works! The issue I now have is that while the music is streaming, every few seconds or minute, there is a hiccup in the music… it cuts out briefly and then continues… which doesn’t happen if streaming directly from the Alexa device. If you have any advice how to fix the hiccup, that would be great, but I’ll probably post that as a separate issue in a different thread. I’ve included a picture of the device list in the Alexa app with the 2nd soundbar entry for the same soundbar that allows it to work with Alexa.

Hi Lars.

For some reason the detailed, thoughtful response with appropriate screenshot that I made yesterday morning was flagged for review by a moderator and has still not been released.

Bottom line is, the sound bar is working now with Alexa. If the mods release my original message from yesterday, it gives insight as to the problem and the fix and may help others who have the same, or similar, problem.

Daniel

2 Likes

I’ve got this soundbar as well, and while I am not having an issue with Alexa that I know of, it seems that I cannot make a change to the source from a Routine like I can with my Samsung Q65 TV. Neither soundbar device shows that option within Routines, but the original “soundbar” device does show it as an option within the device control.

I currently use a webcore piston to change the input on my soundbar, but I’m trying to plan for the future. Since this is a cloud integration, it seems that an Edge driver isn’t quite the right way to go about fixing this. anyone know if theres anything that can be done, or anyone to ask to allow that option to show up in Routines for the soundbar?

Hi guys

I have a Samsung q800b sound bar.
It has Alexa built in and I have followed the process of adding it to SmartThings and then linking it ti Alexa app.
But even though the Alexa app sees it as an echo device, the sound bar does not respond to me at all.

A friend of mine has the q800a and his works perfectly.
Any ideas what could be wrong?

Thanks in advanced.
Deshan