Samsung R1 Speaker could not be discovered in Smartthings - Google WIFI router

Just bought the R1 Speaker from Amazon ($69 refur) and successfully connected it to my Google WIFI mesh router with the Multiroom app. But when attempting to connect it to Smartthings, it could not be discovered. I went thru all the recommendation found here but none worked for me. Finally i decided to test my older non mesh router (netgear). I connected my iphone, Smarththings hub and R1 to the new SSID and sure enough, i was able to connect to both the test network and Smartthings. I shut down the test network and attempted to reconnect to my original network but it fails again. I still have the device listed in Smartthings but it became unavailable. nothing I did to trick the speaker to reconnect to the mesh network without repairing . I used the same SSID and password but with no avail. Anyway the speaker works fine via Multiroom but could not connect to Smartthing. After hours of troubleshooting and massive frustrations, I gave up and ready to return it but i thought may be someone could have a recommendation. I assume the problem is compatibility between my Smartthings hub (v2) and the Google WIFI router but not 100% sure if there is some configuration needed on the router side. Any assistance would be much appreciated.

1 Like

Is it a google wifi 1 pack or three pack?

it is 3 pack

Is the ST hub connected to the main Google wifi hub or one of the remote hubs?

Also, remember it connects to 2.4ghz not 5ghz.

connected to the main hub

What do you mean? the speaker by default connect to 5ghz (it is very close to the hub) but in my testing i forced it to connect to the 2.4 (moved the speaker far away from it) but with no luck. still same issues. By the way, on my test network, the connection was 5ghz and it worked fine.

Mine only connects to 2.4 if I try 5 it doesn’t work all the time. I have a fully functioning Mesh setup. You might have a new version. But mine says Radius R1

I think i have the same model running app ver 2.12.4. how do you force yours to connect to 5ghz. The only way i know how to do it by placing further from the hub to force 2.4ghz. Also i have no issue connecting to the network. It plays fine with the multiroom app, the issue is connectivity to smartthings.

In my case I set it up to 2.4 then when the network went down and it had to reconnect it picked the 5 by itself, but didn’t work. The ST app should work by going to the device install and choose speakers>Samsung Multiroom.

did you set it to 2.4 the same way i did by placing the speaker further away from the hub? also when it reconnected to 5.0, what kind of problems were you having? multiroom app or Smartthings? were u able to connect to smartthings but it would not play right? want to see if it is the same problem i am having. I attempt to add the device like you do speakers>Samsung Multiroom. or by discovering all devices but it hangs searching and would not find the device.

I am no longer using my 2 R1 speakers with Smartthings (thank you Echo Speaks!). But when I did, I sued them in a Google wifi mesh without any special setting on the router . I only remember that it took a long time (>1min!) and a couple of tries to find them and connect to Smartthings. After they connected they were stable for years though, even whne I moved them to different locations (and probably connected to different wifi hubs) in the house.

See:

https://support.google.com/wifi/thread/11386387?hl=en

Thanks, this seems to be my issue. Firmware bug with the Google WIFI router.