Samsung broke my smart owen

Hi I have samsung owen model: NV73J9770RS

In the past I have used the smart home app to control it. Now that app is telling me that the owen is not supported is this app and I should move to smartthings. Okey no problem i thought. But in the smartthings it fails to connect every time. I have tried from a samsung phone, and iPhone. Two routers. The instructions is also wrong from the samsung app telling me the wrong way to enable ap mode on owen, however I enable the ap mode and it finds the owen ssid and then the owen says now you can control this with your phone. The apps shows 55% progress and after a while it tells me to try again. And believe me I tried so many times now. This owen cost me eq to 2000 usd and now I cant use the smart functions on it. Samsung please help.

Is location services enabled for the SmartThings app on your phone? Any extra firewalls or port blocking in your WiFi?

Nothing like that, The wifi icon gets greyed out on the owen after it says now you can use your phone to control the owen. (App shows 55%) at this stage and the owen shuts downs ap mode) then it times out. I have tried to reboot the owen when it says 55% in the app but then when the owen connects to the wifi it says that it failed to and try again.

I also have samsung smart washer that I tried to onboard again and it worked.

One thing to make sure of (from the install guide) these devices only connect to 2.4ghz networks and a lot of new routers combine 5ghz/2.4 to the same ssid. You need to seperate them and make sure both your phone and the appliance are connecting to the same 2.4ghz network. During the setup process the appliance will switch on to the wifi network and if your phone defaults back to the 5ghz network it breaks.

1 Like

Yes that I know. I have made a 2,4 only ssid for these devices. I think it sends wrong configuration to the owen from the ap. Since it worked in the old app. And the new app tells me to press a button that don’t excist on my owen.

What I am saying is make sure you have your phone “forget” the 5ghz network. You should be connecting directly to the 2.4ghz network like home_2g or something, then starting the process. If your phone jumps back to the 5ghz it will fail.

Yes I have forgot the 5ghz network on my phone. The phone and owen are on the same ssid.

Then you need to make sure the oven is also disconnected from the old app as well

There is a support number at the bottom of the page as well.

Yes its disconnected from the Smart Home app.

How can you submit a bug report, so someone like you (engineer) takes a look at the code?

email or call the number on the page I linked you to.