Samsung air conditioner doesn't have the quiet mode for routines or schedule

I have recently got a Samsung air conditioner. When trying to create a routine in the Smartthings app for how it should behave when i’m home vs not home, it is not possible to set it in quiet mode.

All other options are there in routines, ex temperature, fan speed, mode. But to put it in quiet mode I have to manually enter the app and adjust.

Why did Samsung leave out quiet mode as an option in routines? Can it be fixed?

Is there an Alexa skill for the air conditioner that allows setting quiet mode?

It’s the same situation in Alexa as well as Google Home… everything can be set up in routines except the quiet mode

I was more thinking of if there is a voice command for Alexa to change to different modes like “Alexa set my air conditioner to quiet mode”. If so, you can create a virtual switch with contact sensor in ST and use that to trigger an Alexa custom action in a routine to simulate speaking the command(s) when the switch is turned on/off in ST Routines. I’m using this method for my Ecobee Thermostat because the program modes aren’t exposed in the ST-Ecobee integration but are changeable using the Ecobee Alexa skill.

Thanks, I tried but Alexa couldn’t set it in quiet mode by voice command unfortunately.

The same problem exists with the Samsung air purifier. In the automation I can select all modes but wind-free. I use the night mode instead but in the air conditioner there may be different modes.

I think you you can report this issue in the app (Menu → contact with us). I didn’t do that because I use the night mode instead.

I can’t even set a schedule for quiet mode in the app

The same is for the air purifier. I have just reported it in the app. Maybe you can do the same? If more people report the same issue, it may convince them to implement this missing feature faster.

I have reported it

1 Like

Does setting fan speed to 0 put it in quiet mode?

I had a similar issue with a non-Samsung air purifier. No night mode setting anywhere but I discovered setting fan speed to 0 did it. Typically setting to 0 would turn the device off but for this device it did not.

Cant set it to 0 in the app, only “low”.

Yes I noticed that too. But I can via a Routine. And apologies, I should have been clearer. When using a routine I set Fan Speed to ‘Off’ (and switch to ‘on’). When using SharpTools I set Fan Speed to 0 (same as off).

I have checked what capability is responsible for the fan mode in my air purifier and now I understand why we both have similar problem. The capability is called airConditionerFanMode even for air purifier. In my case this is what it reports:

 fanMode              "auto"                                            
 supportedAcFanModes  ["auto","low","medium","high","sleep","windFree"]

Anyway I managed to use the “windFree” mode but I had to write the rule using the Rules API, not through the app. This is my rule:

name: Wind free
actions:
  - if:
      equals:
        left:
          string: pushed
        right:
          device:
            devices:
              - xxxxxxx-xxxxxxx-xxxxxxx
            component: button1
            capability: button
            attribute: button
      then:
        - command:
            devices:
              - xxxxxxx-xxxxxxx-xxxxxxx
            commands:
              - component: main
                capability: airConditionerFanMode
                command: setFanMode
                arguments: [{"string": "windFree"}]

If you would like to try implementing the automation using the Rules API and need some help feel free to ask :wink:

Thanks but its too advanced for me, I just Want Samsung to fix this issue in the SmartThings app.

2 Likes

Might want to see if you can set the mode in a Sharptools routine.

Thanks for mentioning this, I had not noticed the missing option until you said something. Very strange. I wonder why the Wind Free setting isn’t available for Automations.

I agree, this month I got my airco and what to make scenes and routines using the quiet mode but that one doesn’t exist.

Hey! Congrats on your new Samsung air conditioner! It’s understandable that you’d like to have the quiet mode included in the routines within the SmartThings app. While I can’t say for certain why Samsung left it out, you can reach out to their customer support or check for any firmware updates that might address this issue. I suggest you also contact spartamech.co.uk for professional help dealing with conditioner. I hope that helps!