Reset hue bulb to factory once it has joined the SmartThings hub

Has anyone been able to reset their Hue Bulbs back to factory condition once they have joined directly to the SmartThings Hub? My Light Link remote does not work with the Hue Bulbs once they have joined directly to the SmartThings Hub and I have 4 directly joined Hue bulbs that have stopped responding. All my other directly joined Hue Bulbs are fine.

Last I heard once they are joined to the ST Hub they are stuck there.

That is one of the warnings about joining them directly to the ST Hub.

You could email support to see if they have some way to exclude them but I’m pretty sure there is not.

Well that would be fine if they were still communicating with my SmartThings Hub. The problem is they are no longer responding. Im working with tech support right now and she is updating the firmware on my hub. I doubt that is going to change anything but i have my fingers crossed.

These bulbs worked all summer with SmartThings I unplugged them and set them on the shelf to be used in our Christmas decorations. After being off for about 6 weeks I plugged them back in and they are not working. All my other Hue bulbs are fine.

Turn the bulb off, delete it from the app, go into pairing mode then turn the bulb on. That’s as close to a reset as you’d get with the Hue ZigBee direction connection.

1 Like

This is only to get ST hub to see it again right? Could I go back to the HUE bridge this way?

Yes I did all this at the direction of tech support and it didn’t work. My bulbs are not responding after being powered off for several weeks. I think the bulbs need to be factory reset so they can rejoin any Home Automation network. To trigger a factory reset in a ZigBee Light Link bulb you need a configuration tool. Hue makes a remote control for the Hue Bloom light. That remote control is also a ZigBee Light Link configuration tool in that it can trigger a factory reset in the Hue bulbs. I have one of those remotes and I have successfully reset several Hue Bulbs but it doesn’t work on my bulbs that have joined directly to SmartThings. The reason (I suspect) it doesn’t work is when the Hue Bulbs joined to the SmartThings Hub they joined on a non ZigBee Light Link channel. My hub is operating on ZigBee channel 14 the Light Link speck only supports channels 11, 15, 20 and 25. That is why everyone is stuck with their Hue bulbs directly joined to SmartThings.

I do have some good news in another thread i have been talking with @manu about their RaspBee and he says it will reset the bulbs back to factory even if the bulb is operating on a non Light Link channel. FLS-PP lp a ZigBee Light Link Wireless Ballast for LED Stripes

acastal, sorry this will not reset the Hue bulb please see my reply to Tyler.

Has anyone been able to do this successfully when the ST hub is using one of the ZigBee Light Link channels? Mine is currently on channel 15, so I was thinking about giving it a try.

I assume Lampstealer isn’t able to fix this either?

Just to be clear are you talking about removing your Hue Bulb from a direct bind with the SmartThings HA ZigBee network? Are you still communicating with the bulb or is it dead?

From my understanding Lamp stealer allows you go go from one Light Link network to another but it doesn’t reset the bulbs back to factory. If your bulb is currently joined to a ZigBee Home Automation (not ZigBee Light Link) network you will need to reset the bulb back to factory to go from one network to another. The Lamp stealer will not do this.

I just got my hub yesterday and I’m trying to wrap my head around what is going on. I haven’t actually moved any of my hues from the hue bridge – I’m just speaking hypothetically at this point.

Does the ST hub not actually implement the ZigBee Light Link standard? This seems to indicate that it does:

For ZigBee devices, the main profileIds you will need to use are

HA: Home Automation (0104)
SEP: Smart Energy Profile
ZLL: ZigBee Light Link (C05E)

I’m not a SmartThing’s employee so I may not be aware of something that is going on under the covers. But, from my understanding SmartThings does not support the ZigBee Light Link profile or the ZigBee Smart Energy Profile on their Hub they do support the ZigBee Home Automation profile. I believe the recommend way to control your Hue Bulbs is to keep them on the Hue Gateway and the SmartThings Hub will talk to your Hue Gateway to control your bulbs over the Internet. I think that is what most people do.

It just so happens a factory new Hue Bulb can join either a Light Link network or a Home Automation network. This tread is about people (I’m one of them) who have joined factory reset Hue Bulbs directly to the SmartThings Hub on the Home Automation network. I think you would be best off to keep your bulbs where they are and go that route. In fact you dont have a choice unless you buy a Light Link remote to reset them to Factory new condition. At that point they will join either a Home Automation network or a Light Link network.

Good question and welcome to the SmartThings community!!


Thanks! I came across this thread which contains some relevant information.

FWIW, there definitely is a way for a Hue bulb that has been connected to a Hue hub to get connected to a ST Hub directly, without using the Light Link remote to first reset them to factory. This is what happened to me - I actually “lost” a bulb from the Hue hub to the ST hub.

I’m not sure what the sequence of events is, but apparently I had my ST hub searching for a new Thing to add whilst this rogue Hue bulb was in a weird state, and it wound up connected to the ST hub, and now I can’t get ST to let go of it…

My advice - connect your bulbs to your Hue hub, keep them powered on ALL the time, and NEVER let ST add a Hue bulb directly.

Humm this one has me scratching my head. If your bulb was healthy (In good operating condition) joined to and communicating with your Hue Hub I just don’t see how it would jump over to the SmartThings hub without a factory reset. This goes against everything I have read and personally witnessed with the Hue Bulbs. Please understand I’m not doubting you at all I just think some abnormally caused this. And hey the abnormally may be my understanding of how the Hue Bulb operates on a ZigBee HA network. I wonder if the bulb has some kind of a fault maybe you could send it back for warranty work. If you do I would love to know that process!!

Did you talk to SmartThings tech support? If so did they have any idea of what happened has anyone else seen this same thing? This is a good one would love to know what is going on under the covers here!!

On a related note:
It is possible to send a bulb a ZDO leave network command that is intended to cause it to leave the network and start searching for a new network. I wonder if somehow the Hue Hub sent this command to your bulb causing it to leave the network. I don’t use the Hue Hub or work with the API so I don’t know if this is even possible to send from the Hue Hub. But it is a valid ZigBee Device Objects command. I haven’t tested it as it requires the bulb to be connected to a network and my 4 orphaned bulbs will not connect to anything right now so it wont help me.

It’s possible (probable?) that I was trying to revive/reclaim the Hue bulb using LampStealer while simultaneously adding a new device (a switch) to ST, which may have created the opportunity. I was having trouble with the bulb…

And yes, in retrospect, my attempt at multi-tasking was foolhardy…it simply didn’t dawn on me that both Hue and ST were able to connect to the Hue Bulb, as when I first connected my Hue to ST, this was NOT an option…


Ahh I bet your on to it now. Somehow LampStealer must have told the bulb to start searching for a new network.

This may make you feel a little better but probably not. On more than one occasion I have had ZigBee end devices join the SmatThings hub without telling it to allow joining. I haven’t pursued it because the devices were lab devices (under development) and I cant reproduce it reliably. But at-least twice now I have booted up a new ZigBee end device with a brand new (never powered on) radio and bang it is allowed to join the SmartThings hub without me using my smart phone to allow new devices to join.

Old thread I know but I wanted to move my ST connected devices to the HUE bridge after Amazon Echo can control them. I was able to move a lightstrip over quite easily. The lightship was quite close to both the HUE and ST Hub. I unplugged the ST HUB. I telneted to port 30000 on the HUE hub and pasted in “[Link,Touchlink]” The lightstrip moved over to the HUE hub. Happy days for me.

Edit: I did the same for a normal bulb and it worked as well after I removed the lightstrip from the mix since it seemed to be signal wise closer.


Lucky is good.

Zigbee home automation, which is what smart things uses, can operate on multiple frequencies. Zigbee light link (ZLL), which is what most zigbee Smart bulbs use, only operates on a subset of those frequencies.

The frequency that your smartthings hub uses is randomly assigned during manufacture, and cannot be changed. (Word is that it will be user changeable on the Gen 2 smartthings hub, But we will just have to see.)

If the frequency that your smartthings hub uses happens to be one of the ZLL subset, then you can probably move bulbs on and off.

If the frequency that your smart things hub uses happens to be one of the ZHA frequencies that ZLL does not use, then once you have paired a lightbulb directly to the hub, it loses the ability to go back to a ZLL controller.

So if you happen to be one of the lucky ones whose smartthings hub operates on a ZLL frequency, you Will be able to make swaps that other people cannot.

From IDE: zigbeeChannel: 20

Is this a ZLL frequency?

If the hub can control GE Link bulbs does it not have to choose a ZLL frequency?

Yes, the ZLL primary frequencies are, I believe, 11, 15, 20, and 25:

As for what happens with the GE, I’m not sure. It’s been suggested that the problem with the Hues is actually that they don’t have a local device factory reset. That is, you can’t reset them to their factory settings just by flipping power on and off, which you can do with the GE, Cree, and Osram.

It is up to each manufacturer how, or if, they allow a user to reset the device to factory settings. As you probably know, most zwave and Zigbee devices have a button that you push on the device as part of the factory reset process.

This form factor doesn’t really work with lightbulbs, so most manufacturers have chosen to accept a specific power on/off sequence.

The problem with that, is that it is possible for a user to inadvertently reset the device, such as when a child is flipping the switch on and off, or when an adult is doing some device testing.

So it it may be that Phillips decided not to offer a reset by the device itself, but to require the controller to reset it.

That all makes sense, and would explain the different behavior that people see with the different brands, But I don’t know for sure.

1 Like