Remove Schlage Camelot Lock


(Dumb) #1

So I have had SmartThings for a week to the day and the Schlage Camelot lock already is not working. It shows it is in the app, when I press lock it says locking and that’s where things end.

I have tried removing the lock by clicking on the lock and then the gear button and remove. I then go to the lock, enter my programming code and then 0 on the Schlage Camelot lock. However the lock does not remove and does not work.

Any ideas before I just return this thing?

Thanks.


(David P.) #2

Use RBoys app and handler. Works great for me


(Fast, Good, Cheap...pick two.) #3

Do a reset, which will remove it, then add it back.


#4

It didn’t for me. I mean it added it back. Then went in and changed the codes then changed them back. St controls the lock but the codes aren’t working. :frowning:


(David P.) #5

When first setting up my first Schlage lock I reset it twice. Push the outside “Schlage” button and pull the battery. This did not unpair it. I had to use the Exclude function on the lock to do that.


#8

My lock is working. Smart things sees it. I can unlock it from the app. The auto lock/unlock even work for location based unlock. The only thing not working is Setting custom unlock codes.


(David P.) #9

I have two of these:

The first one took some fiddling to add then remove a couple of times before I got it settled and changed handlers and added the smartapps. Once I paired it the last time after adding RBoy’s code it has worked fine. I do not add codes on a daily basis but I added some a few days apart and they all work.

When I bought the second lock and added it to the config it got the codes and works fine as well.

I have a friend who recently did the same with a single lock. Bought RBoy’s app on my recommendation and got it going as well so I can attest that 3 locks just like above work correctly.

Be aware that I am using a V2 hub with a very reliable internet connection.

As I said I performed the unpair twice per Schlage directions before adding it a final time and it has worked since. I recommend checking the logs for the app and device to make sure you can see what they say they are doing.

Perhaps an exchange is in order?


#10

Right, and mine were working when I originally set them up. After the move I had to reset the device. Now its not taking my programmed codes. Everything else is working as expected.

Just trying to figure out step by step what I need to do to get it set back up correctly. If that means I need to redo everything thats fine. I just dont want to do that if its not needed. Not even sure at this point what redoing it all would even be. Really really frustrated with it. :frowning:


#11

For anyone who may come across this post with the same issue. In order to get the lock working right again I had to remove the smart app and set it back up. It is now working as expected.


(Fast, Good, Cheap...pick two.) #12

Did you simply remove the app and add it back or did you remove the app and reset the lock then pair the lock and add the app?

Just curious…thanks!


#13

I had previously reset the lock as I had to. Door location had moved and it had to rerun the initial config so the bolt turned the correct way. After doing that the lock still worked as far as arrival and leaving and responding in the app. I just couldnt program any codes into it.