Removal of Smartapps always has to be by emailing support?

smartapp
harmony

(Johnny) #1

I’m fairly new to the smartthings platform and was well aware there was a bit of a learning curve. Also fairly new to home automation so the first one I tried was Wink because I guess their marketing worked at the time. This has nothing to do with what my issue is as much as give a basis to my level of experience. It’s fairly minimal but I consider myself a pretty “techie” person considering my job is System Admin and I know my way around many scripts.

My issue is this though. Every time a Smartapp has an issue on my hub, I can’t seem to do anything to remedy the issue myself. I read all over the forum for tips and tricks to finagle a smartapp removal and low and behold, it’s like they’re locked somehow to my hub (even after I’ve removed all associated devices) saying “This SmartApp can’t be deleted at this time because it is installed by one or more users” or something close to this type of message. I’ve had this issue with a couple different apps and the interesting part is I’m not wanting to remove them as much as fix them due to something disappearing (all my harmony hub activities) or some other scenario that just seems to only have a reinstall as a solution.

I guess my biggest issue is that I don’t want to write someone and wait for something that seemingly should be able to be removed, dealt with and fixed on my own. So my question is this. Is this normal?

I love the fact that I think Smartthings has more possibilities for integration and growth (not to mention the community is amazing) but these types of things are a bit frustrating.

I also wish there were some video starter tutorials for things like buttons or something along those lines. Even though I feel like I have a pretty good grasp of most of the ideals, I still after a few weeks have probably not cracked half the things smartthings can do. Anyone else feel like they get lost in doing some of the simpler stuff, like even creating buttons, the verbiage, basic concepts?

If I’m alone, take it easy on me. I’m trying to not be the complainer as much as reaching out to the community to get a little guidance on getting a better start. Maybe if I had that down I wouldn’t have to write support as much to fix issues :wink:


#2

It’s not normal in the sense that it’s not supposed to work that way and it often does work the way it’s supposed to (how’s that for verbiage!), But it’s not uncommon either. :disappointed_relieved:

There’ve been times in the past when it was rare to need to ask support for help with removing a device/smartapp, so we can only hope to get back to that in the future.

As far as virtual switches, try this FAQ:

Feel free to ask any follow-up questions there, or in the developers subsection of the forum where there are a lot of very helpful people:

https://community.smartthings.com/c/developers

This might also help with concepts:


#3

And the following FAQ used to be very popular but isn’t used much anymore now that most techie people jump right into Rule Machine. But since you mentioned wanting to know more about terminology in use in the forums, this might be a good way to learn more about that:


(Johnny) #4

ALL OF THIS is exactly what steered me toward smartthings. There IS in fact a ton of information out there about this community and I know in the long run I’ll end up with the automation I want in my home.

I will check out all this reading tonight and thank you so much for being one of the reasons this is such a great community.

I’ll have to admit, some of the troubles I’m having could really be from experimenting so much when I first got the hub. I installed, uninstalled, played around because that’s generally how I learn best. Trial by fire kind of scenario, but I’ve learned fairly quickly this isn’t necessarily the best way to go about smartthings.

I have a feeling by next year I’ll be tackling my own smartapps, thanks for being supportive in my journey to get there :wink:


(Jake) #5

Go to the Smart Apps screen in IDE, then on the right hand side under location, make sure there is not a location listed, if it is then remove it, this has solved this issue every time I have had it…