[RELEASE] Somfy MyLink Hub V1.1 (Roller Shades)

motorizedshades
somfy
project_shades

(Ben Dews) #21

Hi @gabriel_kpk,

As far as I can tell after similar testing the Somfy app appears to communicate using a different method - so your device is normal in that aspect.

Any chance you could send me a PM with a screenshot of the menu in your Somfy application and the model number of your MyLink?

Thanks!


(Vinny B) #22

Thank you for the reply, Ben, and thank you again for the great work.


(Gabriel) #23

Hi Ben,

The iPhone app is Somfy MyLink Asia.

https://itunes.apple.com/sg/app/somfy-mylink-asia/id1035492139?mt=8

The latest app version is 2.37, and latest firmware is 2.21. The hardware reference is 1811472. I can’t find much info on the website, but the device is made in USA.

There is page from Somfy Singapore reminding users not to use the US app and US firmware.

https://www.somfy.com.sg/products/home-automation/somfy-mylink

I just hope that the Asia device supports Synergy API but uses a different port. Thanks for your help.


(Geekmax82) #24

I am just installing – after adding device I see this in the logs:
'ec07e3ed-3c67-4adc-8977-e101e8c0d565 8:18:52 PM: error java.lang.NullPointerException: Cannot invoke method tokenize() on null object @line 71 (getDNI)
ec07e3ed-3c67-4adc-8977-e101e8c0d565 8:18:52 PM: debug Generating DNI
ec07e3ed-3c67-4adc-8977-e101e8c0d565 8:18:52 PM: debug Setting DNI
ec07e3ed-3c67-4adc-8977-e101e8c0d565 8:18:52 PM: debug Refreshing"

Thoughts?


(Geekmax82) #25

This is the telnet log on a refresh
{“jsonrpc”:“2.0”,“error”:{“code”:-32700,“message”:“Parse error”},“id”:“null”}


(Ben Dews) #26

I would say that the error indicates an issue with the network configuration, but the fact the device is acknowledging a request contradicts that.
Is there any chance you copied and pasted the device handler directly in to the IDE? Sometimes your web browser will automatically change the quotation marks in the code which ruins everything :wink: you can get around this issue by either:

  • 1:
    • Setting up Github integration within the SmartThings IDE and pulling the repo directly
  • or 2:
    • Downloading the repo from Github directly (“Download as Zip” on the main Repo page)
    • Opening the Device handler in a “plain-text” editor, such as Notepad++, Sublime Text, Visual Studio Code etc. Do not use Notepad or Microsoft Word.
    • Copying directly from the plain-text editor in to the IDE window

The error in the IDE seems to indicate an issue with the network settings, but the error on the device seems to indicate an issue with the data formatting, which is usually due to the issue mentioned above.

Let me know how it goes :slight_smile:


(Ben Dews) #27

Hey Gabriel,

I really hate to be the bearer of bad news, but I can’t seem to find any documentation to show that MyLink Asia supports the Synergy API. There is no mention of it on their website at all, whereas it features quite prominently on the website for most other markets.

On another note - reading their warning on using the US version of the app… "It is at Somfy’s discretion to void the warranty when the above problem occurred." Ouch! :worried:


(Geekmax82) #28

No I pulled from GitHub. It is working now but same errors on the telnet. Functions not very well. Very erratic open/close commands. Also my open/close is reverse

App works via so network would should be fine.


(Gabriel) #29

Hi Ben,

No worries, thanks for checking. I have also just gotten confirmation from Somfy Asia that MyLink Asia does not support synergy API. Thanks again.


(Ben Dews) #30

The Open/Close is set to what the MyLink believes is Open/Close for the device (Up/Down on the remote).

When you say erratic open/close, are you able to expand on that a little bit? Does it take a little while for the command to be registered (this is just SmartThings lag), or does it randomly stop when its opening/closing?

You may have already tried it but I can recommend deleting the devices and starting again and seeing if it helps.


(Manuelech) #31

Hi! I successfully followed all the steps and my blinds show up on my app, but the MyLink and shades all show Checking Status and do not work. Anything yu suggest I can do to try to correct? Thank you!


(John) #32

Hi, I loaded the 2 device handlers, added new device with Type being the Hub. In ST app got all mylink hub info loaded but i’m not getting the child devices after adding all the Somfy Mylink info. Can’t see what I’m doing incorrectly, any ideas appreciated. Thank You.


(Ben Dews) #33

Hi John, are you able to PM me a screenshot of your settings for the Hub device in SmartThings? Thanks :slight_smile:


(John) #34

Thanks for looking Ben, attached is the settings of Hub Device in the IDE, The MySomfy Hub is V2 and noticed it has a 4 digit PIN, not sure if that is new and somehow not connecting to Hub or ???

The second pict is settings tab from within SmartThings App.


(Ben Dews) #35

Hey John,

I noticed for the systemID you have set “3634”, which looks like a PIN.
If you go in to the Somfy app on the menu on the left click on “Integration” then “Get Integration report”.

You will have a “System ID” present - use this to fill out the “Somfy MyLink System ID” in settings. I can also recommend using a string value instead of a number for your system ID. E.g “mysomfylink” (if you change it remember to update SmartThings).

Feel free to PM me a screenshot of your integration report as well, as it should just work if the info in the integration report is put in :slight_smile:


(John) #36

Thanks for the help Ben, Here’s the integration report. The system ID was numeric 3634 so changed to mysomfylink and updated smartthings but still no child devices (shades) created after saving the edits.

System ID : mysomfylink
IP address : 192.168.1.155
System pin : 8879

CC103EE8 ShadesMylink

Target: CC103EE8.1
Name: Southwest Shade

Target: CC103EE8.2
Name: West Center Shade

Target: CC103EE8.3
Name: Northwest Shade

Target: CC103EE8.4
Name: NorthEast Shade

Target: CC103EE8.5
Name: SouthEast Shade

Scenes

ID: 0005
Name: Lower West Shades

ID: 0003
Name: Raise West Shades

ID: 0006
Name: Lower East Shades

ID: 0002
Name: Raise East Shades

ID: 0004
Name: Lower West Shades Halfway


(John) #37

Resent details next post


(John) #38

These might be easier to read and has the device events


(Manuelech) #39

Hi! I successfully followed all the steps and my blinds show up on my app, but the MyLink and shades all show Checking Status and do not work. Anything you suggest I can do to try to correct? Thank you!


(John) #40

Hi i’ve not been able to get this to work either, do you recall what step the blinds are created in the app. I have restarted all the steps again, have no issue with blinds working from the mylink app but nothing in ST’s, verified the settings match the mylink integration report but don’t get any buttons other than the refresh in the device type in smart things. Have started over pulling device handlers from repo, recreating device type, then from ST’s it seems the child devices never get created after entering the settings and saving. Not sure if that is when the child devices are supposed to be created. If I can get past that will see if the functionality works or get similar “checking status” msg. Thanks for any advice. It did appear command went to create child devices in log, attached.