[RELEASE] Nexia Doorbell Sensor (DB100Z) Device Handler

Thanks, that’s helpful info. I appreciate your time in replying.

1 Like

I seem to be having the same issue as was mentioned above.
However, I think I know the culprit as I have recently switched from a Mechanical Doorbell (uses a copper coil and physically hits a chime) to an electric one.

In my old setup your handler worked perfectly! (thank you for that btw)
When I installed my electric doorbell chime the sensor continued to work, but my chime did not since I had not installed the diode to my doorbell button at that time.
Once I installed the diode to my button (which will effectively allows a voltage at all times) the sensor would give me false positives every 4 minutes.

I came here first upon discovering the issue, so I haven’t had the opportunity yet to look deeper into the type of signal that the electric chime is looking for to work, but I would imagine if you set the device to look for the same type of signal that this would solve all problems.

Wanted to say thanks for the device handler! It worked like a charm and I was able to cram the device into my doorbells battery compartment. I was a bit sceptical but I have had zero issues over the past 2 hours and I have a diode in my doorbell button.

Thanks again.

2 Likes

Hi, all

I got the sensor working great, however for my purposes I need to have it show as a compatible device in the Smartthings Smart Home Monitor. Long story short, I wanted to trigger a chime on my Dome Sirens, but in the Smart Home Monitor it only displays devices categorized as the following:

Temperature Sensor
Open/Close Sensor
Vibration Sensor
Motion Sensor
Presence Sensor
Sound Sensor
Humidity Sensor
Lock

The most straight-forward way I thought to work this out is to have the doorbell sensor detected as an open/close sensor. Does anyone have a recommendation of how to do that? I took a look at the handler code, but doing this wasn’t very straight-forward to me.

Could someone please post the transformer and chime that work with the Nexia?

It seems all the big box stores including Lowe’s and Home Depot only carry 16V 10VA chimes and transformers.

1 Like

I am happy to report that the NuTone C909 Transformer completely eliminates the issues with the Nexia Doorbell Sensor not sensing short/soft presses of the doorbell button.

I used the 16V 20VA terminals.

It is rock solid now and senses the most subtle presses of the doorbell button, totally flawless.

Also, my doorbell chime is perfectly fine using the increase in current. Sounds exactly the same and didn’t explode.

Here is the link to the transformer to get if you have the Nexia Doorbell Sensor.

2 Likes

I have both ST 3rd and Nexia Doorbell Sensor. I am a new. Could you tell me how to pair? Thanks a lot.

Hoping someone has an answer to this… I migrated to the new ST app today, and it seems that the Nexia device handler is not recognized in the new app. Any ideas on how to get this working again? I’ve tried several generic Z-Wave DH’s and none of them work.

I don’t see any “history” data in the “new” ST app for my doorbell presses. Otherwise the Nexia works very well for me.

p.s., I have long wiring runs to front and garage doorbell buttons and a Ring doorbell on the front door, so I use a 24v 40va Nutone transformer that is ample for the distance, wiring gauge, & load without exceeding limits checked by the Ring.

@Darwin, just wondering if you’re thinking about a conversion to Edge for this DTH?

If not, I’m wondering if anyone that uses this DTH has found any Edge equivalents? I’m pretty sure this will not be migrated to anything since these devices are no longer available except on the secondary market but I also know lots of people have them. Sadly, searching results in nil for me so I am hoping someone else may have looked at this

Same here. Really hoping this doesn’t get borked by Smartthings because it works perfectly in my system and it is basically just a Z-Wave momentary switch anyway. Problem is, unlike with Groovy, I don’t know how you can simply pick a different device driver for this device. The switch to “edge” has made this much more difficult.

Switching is accomplished in the app under the device…you should see an option to change the driver under the “…” menu I believe. You won’t see this on a device that isn’t already using an Edge driver.

AFAIK, the “Driver” menu only shows up if it finds a driver for your existing device to begin with. If it doesn’t, it is stuck without any option. Plus, a device cannot be added with an arbitrary driver. It has to exist with an edge driver already, and then you can switch it. That’s how it seems to work right now anyway. Maybe this will change in the coming months.

Yeah, so my understanding, which might be not 100% accurate, is that all supported devices would be transitioned to their respective Edge drivers based on fingerprint and all others would be transitioned to an Edge generic “Thing” driver (similar to what you might see now if ST joins a device to the network that it doesn’t recognize / can’t categorize). My assumption is that you could then (hopefully) do a change driver.

similar to what you might see now if ST joins a device to the network that it doesn’t recognize / can’t categorize

I’d love to know how you get it to do this. For me, it simply seems to ignore things that it doesn’t recognize. They never appear when you scan for devices. How do you join a device that is unrecognized?

How it works now is different from how it’s supposed to work during the automatic transition. And that’s different yet again from how it will work after Groovy is discontinued. So lots of confusion. :thinking:

1 Like

Towards the question from @robross0606, Under the current system (Groovy), from what I have seen if it does not have a stock or custom DTH that it can match the new device’s fingerprint to, or if there is some error in joining and it doesn’t read the new device’s fingerprint correctly, it will pick one of the “Generic” devices. For instance, some unknown switch might join as a “Z-Wave Dimmer Switch Generic”. I have found in cases where it really has no idea what the device is you can get just “Thing”. I think there is also some other logic beyond the fingerprint though as I sometimes get “Z-Wave Device Multichannel” which implies the device’s Raw data is also parsed.

Honestly I can’t say I have ever done anything to make it find a device other than constantly hitting the “action” button to repetitively send a signal to the hub so it finds it.