[RELEASE] Neato (Connect) V1.2.6c (Botvac Connected Series)

Just updated the Neato Botvac device handler to 1.2.2c to stop this, but this maybe a side effect of something else.

@Mike_McD @frazered
In the logs for the Neato (Connect) app, can you see anything that looks like this…

[INFO] Body: [reqId:1, result:ok, cleaning:[modifier:1,…

Could you DM me the full text/string so I can have a look?

Sent…Hope its the correct string. Thanks

@frazered @Mike_McD Let me know how you get on with Neato Device Handler v1.3. This adds compatibility with firmware 3.x which has slightly different commands from the older Botvac Connected models.

Hi Alex,

I installed the new v1.3 DH but seem to have the same issues 1) Robot serial secret error message, 2) Pressing the main clean tile does nothing and 3) Many values including battery level not showing or not showing correct values.

Note: I updated the v1.3 DH code in the IDE and deleted the robot and readded it with the connect (app) to refresh the new DH.

I am getting the same behavior as @frazered.

Hi Mike. Can you DM me any Neato logs over a period of a few minutes or when you try to activate a clean?

7:42:00 PM: info Body: [reqId:1, result:ok, cleaning:[modifier:1,
category:2, spotHeight:0, navigationMode:1, spotWidth:0, mode:2],
details:[isScheduleEnabled:true, charge:94, isDocked:false,
dockHasBeenSeen:false, isCharging:false], error:null,
availableCommands:[pause:false, stop:false, resume:false, goToBase:false,
start:true], alert:null, action:0, state:1, data:[:],
meta:[firmware:3.0.0-645, modelName:BotVacD3Connected],
availableServices:[wifi:basic-1, schedule:minimal-1,
houseCleaning:minimal-2, generalInfo:basic-1, spotCleaning:micro-2,
logCopy:basic-1, softwareUpdate:basic-1, IECTest:basic-1,
preferences:basic-1], version:1]

7:42:00 PM: error java.lang.NullPointerException: Cannot invoke method
replaceAll() on null object @ line 395
7:42:00 PM: debug Neato Botvac - My Neato cleaning mode: null

Just uploaded 1.3b. Update and let me know if it fixes anything. @frazered has had some success with this version.

They finally updated my account to let me create smartapps but when I tried to paste in the code from Github I got the following error.

I finally got the app installed and the open auth set up so I can sign in but I can’t find the device handler in your github repository

These are all the files which are there now:
hive-connect.src v2.6
neato-connect.src v1.1.6
thermostatmodeautomation/thermostat-mode-automation.src v1.4 -

I can set up the app and authorize it but since I’m missing the device handler I get an error when trying to complete the setup. Was it pulled down for updataing or can you please point me to where the handler is?

Thanks in advance

That worked for me. Thanks

Ignore all previous comments, I finally RTFM and got everything working. Really, what fun is tinkering if you just read the directions? This is so much better than the Neato native app as far as the info I get on each of the bots.
One question/suggestion I have three botvacs (multiple story home) and each one needs to run on a different schedule (the one for the bedrooms runs during the day, the one in the common areas run overnight etc) but it seems that a smart schedule applies to all the bots equally. Is there a way to have different smart schedules for each bot?

Thanks again for all your hard work on this.

@Alyc100 Is there a plan to add the new “Find Me” and “Cleaning Stats” features which are available on the D5 and D3?

New firmware (2.2.0) just released for the Connected botvac - nice to see they aren’t leaving us behind with the D5/D3.

Haven’t tested to see if anything broke but don’t imagine it will.

I wanted to share my experience on the installation… I used the same installation method from the C.o.R.E (Piston) app to install this app. Might be easier…?? Perhaps allow for easier updates as the Dev pushes them?

Goes like this:

Referenced this doc: http://thingsthataresmart.wiki/index.php?title=CoRE

Owner: alyc100
Name: SmartThingsPublic
Branch: master

This part you will need to search for the correct src pkg and select only that one. (alyc100/SmartThingsPublic/blob/master/smartapps/alyc100/neato-connect.src/neato-connect.groovy)

Open the code for your SmartApp by clicking the name.

And the Device Handler is like similar:

Select this item:

Now click on the Namespace/Name (Neato Botvac)

At this point you should have a published SmartApp and Device Handler… I continued on with the original instructions to install the device in smarthings.

UPDATE: When the last code update was pushed, the code turned blue in the IDE, signifying there were updates available. Clicking the magnifying glass I was to copy to local, save, and republish.

1 Like

I’ve installed it in my botvacs, I have 3 on different floors. Did one at first and after a day everything was working fine so I updated the others. I see no issues with the smartapp. The updated firmware gives better error info, such as clean my sensor instead of just ‘error 3000’ and a cleaning map but the functionality seems the same.
I’ll see if the updated error messages show in the app, might take an update but I don’t ever expect to see the cleaning map to show since it’s not something which could work in a tile.

Any chance to Zone Each Room so you can tell it to clean certain areas only ?

I don’t think so, even the native app won’t do that.
To restrict the bot to certain areas you have to put down magnetic strips which act as boundaries for the bot. It’s not something that any app can control ‘yet’ (IMO the virtual map which is now created may give some options to do that in the future)

Wondering… Does anyone that is using the Neato Botvac also use SmartTiles? If so, do you know if there is a tile that exists to integrate it into SmartTiles? All I see is a switch.


what more do you really need? A switch will turn it on to clean.

Actually a tile to give you the status of the unit (ie, cleaning, stuck, bin full) would be useful