[RELEASE] Heatit Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler (Official)

Rules API is a rules engine and not related to device handlers. This DTH works fine with the new app and we’re constantly working with SmartThings to keep the DTH’s updated.

Anyone find they have issues with this device reporting data / applying a temperature set point reliably?

I can change the mode (Off/Heat) fine and the setting takes but updating the temperature rarely succeeds… (Also temperature only goes up/down in 1 degree increments).

I’ve found that a couple of times it seems to stop parsing any data & I have to change the device type to something random then back to the proper handler and it reports in fine for another stint.
(migrated to new platform & new app on android)

HeatIt Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler - version 02.00.00

  • (New) Custom UI for new ST app with custom sensor and display controls
  • (Fix) Changing the thermostat display mode for Z-TRM3


NOTE : The UI cache will need to be cleared for the changes to show up. Change the device handler to a Z-Wave Device and then back to this enhanced device handler from the IDE, then sign out of the ST mobile app and sign back in. If nothing else works, you may need to exclude your device, delete the device handler and reinstall it if the UI does not update after 24 hours.

1 Like

You write in your initial post:

  • Press the + button the SmartThings app to initiate the pairing , Z-TRM3 : Put the hub into S2 pairing mode (see TIPS below for S2 pairing) for improved performance

Does this mean S2 pairing is only available for the Z-TRM3? What about the Z-TRM2fx, is it not S2 secure compatible like it says on the HeatIT website?


Hi, maybe this is rather the corect place to ask; I am having problems with the Z-TRM3 going offline. Not my other Z-TRM2fx. (See Heatit Z-TRM3 goes offline). Anyone knows what to do?

1 Like

HeatIt Z-TRM2fx / Z-TRM3 Electronic Thermostat Device Handler - version 02.01.00

  • (Fix) Z-TRM3 thermostat not accepting a heating setpoint below 13C

This is an important patch for the Z-TRM3 where the thermostat firmware won’t accept a heating setpoint below 13C when programmed via the SmartThings mobile app or from a SmartApp like 5-2 Day or Ultimate Mode Based Thermostat.


I have the same problem with the Z-TRM3 going offline, I have 60-70 z-wave devices 90 % is on constant power. So the z-wave network should be pretty good. I have the FW 4 and are now going to upgrade because of the set point problem. But does anybody have a solution to the “going offline problem”?

I only have problems with TRM-3 so the problem is the thermostat.

1 Like

Hi, i did re-pair as suggested in another post. I can see that the routing has changed. And so far it has been staying online…

1 Like

Hi, I have a Heatit Z-TRM3 and using version 2.00 of the RBoy DH and have an issue with scenes. I created a scene to set all thermostat setpoints to a given value when a leave/arrive. It works for my Z-TRM2 devices (also using the RBoy DH), but the Z-TRM3 does not change setpoint. When I edit the scene I notice there is two options for setting the heating setpoint, and I’ve tried both with the same result.

Any ideas? Any one else tested this?

You may want to try updating your DTH to version 02.01.00 for your Z-TRM3 devices. It has a fix for Z-TRM3 devices not accepting a heating setpoint below 13.0C. See the release notes above for details:

Thanks for the quick reply, updating to 02.01.01 solved the problem :slight_smile: I hadn’t notice a new version was out, installed it only a few weeks ago :slight_smile:

Hi, I have installed RBoy device handle 02.01.00 on my smartthings v3. Initially managed to communicate with all my eight TRM2fx , however after a while I have noted that status of some thermostats went offline. I have already tried factory reset, reconnect to the hub, etc. Every time that I re-start the hub a different set of thermostats present this issue so I dot believe its related to the distance between them and the hub. From the hub utilities I have already run Zwave repair and got some errors like:

  • Network repair for device [07]: Could not delete old routes
  • Network repair for device [06]: Could not assign new route
  • Network repair for Z-TRM2fx [11]: Could not update neighbors
  • Network repair for Z-TRM2fx [10]: Could not update neighbors
  • Network repair for device [0E]: Could not update neighbors
  • Network repair for Z-TRM2fx [0D]: Could not update neighbors
  • Network repair for device [0B]: Could not update neighbors

Zwave errors are mesh or device errors, unrelated to the DTH. It means that your device isn’t responding. The TRM2fx has a known firmware defect in some versions which causes the device to hang under heavy mesh traffic after a while as explained here.

1 Like

That’s nice, I have updated FW with cable from HEATIT. Two of the thermostats that went offline have direct contact with the hub. The thermostats also fail whery ofthen.

More people with same problem?

1 Like

I have the same issue here. I have just updated firmware in eight units (used OTA instead of cable), however the problem is still the same, some thermostats go offline after a while. I have noted that they come back online after you reset them or switch the power off/on. I have raised the question to heatit and am waiting for a reply.

Ok keep me updated on the response from Heatit.

I also see this (online after reset). And I have the issue on both the TRM2fx and TRM3.

Feedback received from Heatit “I don’t know what is going on there but you could try asking RBOYapps, they are the ones that make our intergrations for smartthings.”

Hi there. This is a known issue with the Z-TRM2fx model and isn’t related to SmartThings. HeatIt engineers have been able to replicate the issue and we have also been able to replicate the issue outside SmartThings. When there is a lot of traffic on the z-wave mesh, the device z-wave module sometimes hangs and needs to be power cycled to resume operation. The 3.6 firmware improves the stability however a permanent fix will require an updated firmware from HeatIt. Once the device z-wave module hangs it will also impact any other devices that are routing through it until it’s restarted. It also helps to reduce traffic on the network from other devices.

Reply received from Heatit today:

“There aren’t any updates planned as this product is EOL (End of Life) and is succeeded by the Z-TRM3.”

I find strange Heatit be allowed to use the label “z-wave” on its products…