[RELEASE] Apixu.com worldwide weather data with outside lux. No PWS or server setup required

with WU no longer available took a quick pass at porting my apixu driver original created for HE. more on that driver here:

this is an alpha version … pretty much a straight port of the HE version with a couple of tiles added for ST. i expect to add the same tile layout as @takissd had for his SmartWeather Station Tile 2.0 which i used to use on ST prior to WU doing their thing.

off course since i use local outdoor lux value with settings for various rooms in my rooms manager app this driver publishes a robust but calculated value for outdoor lux that you can use with rooms manager. rooms manager is here:

get your free api key here:

http://apixu.com/

again alpha version for ST … no known bugs … device tiles are not there yet but coming.

https://raw.githubusercontent.com/adey/bangali/master/driver/apixu-weather-ST.groovy

7 Likes

Thank you !

I have to check on the lux rates vs the old one but this seems to be working as expected.

1 Like

Yes this one seems the only one there the lux work, thank you.

1 Like

seems folks are starting to use this one … time for me to find some time to add the tiles. :slight_smile:

1 Like

It seems that apixu.com is now weatherstack.com along with a new API. Has somebody managed to make it work?

do you still need this or are you using an alternate weather device?

Tried to use the integrated weather app for lux but it stopped working. So, yes, it would be great to bring this back with estimated lux data.

Have this installed and input my api key but cant seem to get temp, humidity, or lux. is this working in the new app or did i do something wrong

sorry … believe apixu was deprecated and is now owned by weatherstack. i will look into if they have a free tier and i can replace the API calls.

edit: just checked on their website. free tier is 1000 calls / month. that won’t work.

i will check a bit more on if there is a free tier available with another weather service that i can make work. if not i will mark this deprecated here and on GitHub.

Weatherstack does have free public key…tried it as well, just wont pull data