[RELEASE] Alexa Helper


I have updated the scenario app to 2.8.4. This does a couple of things…First, it adds an interesting new variable to the pre/post messages of the voice reporting (%temp%). This was brought up by @bamarayne and I found a way to implement this in a way that would be useful to others. In addition, I found that playTrack no longer works with the Sonos (and confirmed by support)…So I implemented a workaround for Saved stations within the speaker control scenario where I implement playSoundAndTrack, which ironically, works great…

Anyway, I will probably pause any new features, focusing on updating my Talking Alarm Clock app and ensuring we squash as many bugs as we can. However, keep your suggestions coming as that is how we can expand these apps!

As always, the document is here : http://thingsthataresmart.wiki/index.php?title=Alexa_Helper


Couldn’t help myself :slight_smile: Updated to 2.8.6, with code optimization and added a little bit more to the playTrack workaround to add the option of NOT playing the name of the saved song…But sill use the playSoundAndTrack() API. Also enhanced the sms/push functionality as some Android users are reporting that the “Contacts” page is starting to appear in their UI.


1 Like

So I added the smart app and tried creating both a momentary switch and an Alexa switch, but I can’t get my Echo to discover them, even though they’re in my list of Things in ST. Any ideas?

I assume you are listing them in the Amazon SmartApp (in ST), and then running a discover. There are some issues right now on status.smartthings.com. I wouldn’t believe that would have anything to do with it, but you never know.

Verify first that you are making them ‘discoverable’ but listing them in the SmartApp.

I got it figured out. Now I’m having a different issue.

I am trying to get Alexa to open-close MyQ garage door. I set up a switch and set up a scenario where the garage door is toggled on/off (by just saying “Alexa open Garage”), but Alexa doesn’t seem to want to close the garage door when I tell her to. I also tried repeating the phrase to see if it would close and Alexa recognizes the phrase, but the garage door doesn’t move.

Hmmm…I would first look at the Echo main app (not the ST smartApp) to see what Alexa is hearing…I DO know that Amazon has changed some of their key words, and things that worked previously don’t now. However, I assume you have used just the virtual switch to successfully open and close the door by pressing the button? If so, does “Alexa, Garage off” work?

It reacts the same either way I say the phrase. Here’s how I have it set up:

Scenario Name: Toggle Garage Door
Control Switch: Garage (momentary switch)
Switch states to react to: blank
When switch is on… SmartThings Device Control > [Garage Door] set to open
When switch is turned off… SmartThings Device Control > [Garage Door] set to close

That won’t work…I would change from a momentary switch to an on/off switch (like an Alexa Switch). Then, on = open, off = close.

The reason this doesn’t work is that a momentary switch sends both the ON and OFF commands during it’s “push”. So, when you are pushing the button (or Alexa is), you are off, then on, then back off. Frankly, I am surprised it worked at all. But changing to a distinct on/off switch should solve your issue.

Okay, so I changed it to an Alexa Switch. My garage door was open when I applied the change. When I said “Alexa, garage on”, it closed the garage door. When I tried to say it again to open it back up, Alexa made the confirmation ding, but the garage door never opened.

I am stumped!

Do you have the association of on/off set correctly? Sounds like you have the swapped. Again, leave the Alexa out of the mix for now and simply turn on and off the Alexa Switch to ensure it is working as expected.

The switch is working as intended. When I click to turn on, the garage opens. When I click to turn off, the garage closes.

What’s interesting is that I set up two triggers in IFTTT based on the Alexa Switch and they both work great!

I’ll just use IFTTT for now until I have more time to tinker with this.

The fact that it is opening and closing with the switch means Alexa Helper is actually working. Are you able to look at your Echo app and determine what Alexa is hearing?


I have taken this ‘down time’ due to SmartThings to really take a hard look at the code I have been developing for Alexa Helper over the past few months. It was getting kind of bloated, and I found a few syntax bugs, and some huge opportunities to optimize the code, getting rid of a lot of redundancy. As a result, I cut the code from almost 1200 lines down to 950 or so without cutting a single feature. As an added benefit, the code seems to be a bit snappier on the interface (hard to tell with the ST issues this week). Anyway, I am rather happy with this optimization and am releasing both the new parent and child app (http://thingsthataresmart.wiki/index.php?title=Alexa_Helper#Latest_Version).

I am working on the virtual switch code…mostly the icons as I got feedback people like the custom versions I briefly introduced.

As with any code revision, I may have introduced more bugs…please let me know. I DO recommend that if you check ALL of your scenarios as I did need to change some internal variables with the optimization, so either remove your scenarios and recreate, or check each and every one to ensure all of the settings are as you set them originally.

Finally, I received a donation this week that the return address listed was invalid. Whoever you are, thank you! Any anyone else interested in sending me a donation, the instructions are here: http://michaelstruck.github.io/SmartThings

Thanks again!

Donated… thanks for your hard work.

Just got it…thank you so much! It is appreciated!

1 Like

Updated the devices to give you the small Alexa icon as the default view. There is a small issue within the smartapps when you view this icon (it appears to be shifted up and left on Android devices). However, I think overall this is a good change.

I also did a small update to the Parent app…no major changes, but the new Nest app gave me ideas on adding a bit more ‘flare’ to the app…

Anyway, enjoy!

I’ve been using your app for a while with no issue. Just went in to update it with your new code and now I get the following error when trying to setup a scenario.

physicalgraph.exception.NotFoundException: Page Not Found

I completely removed both the parent and the child and created new smart apps from scratch, thinking maybe I messed something up when I pasted the new code. Same result.

It does sound like something did get corrupt as you upgraded. I recommend not pasting code but to integrate your IDE with GitHub. But, it should still work if you copy/paste the raw code.

One thing I did notice as I had to do a complete re-install this weekend. First, choose the Parent smart app from the list of available smartapps, then immediately click done…This will save the parent, THEN go back in and try to add a scenario.

@MichaelS I cannot get the git hub to integrate. Is there some instructions somewhere on how to do that?