[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

Thanks for the quick answer.
In fact, it‘s a stock DTH. So I will contact the support team and hope for a quick fix.

5-2 Day Thermostat with Remote Sensor - Version 03.11.00

  • Now you can set a timeout for open door/window sensors before it shuts down the system (default 1 minute)
1 Like

For the 5-2 today app, can we get “only when This switch is turned on/off” option? Monday through Friday when there’s a switch on or off and then Saturday- Sunday when there’s a switch on or off

I am on v03.10.04 and already have my heating and cooling schedules setup on 4 thermostats and working as expected. I noticed if I use the “I am back” configuration, select one or more of my thermostats and attempt to change the temperature, it has no effect at the current schedules and everything continues as the schedules mandate. I already have the allow temporary overrides enabled. Is this the expected behavior is there anyway I can override the the current schedule by using the “I am back” routine?

I finally got an answer from the support:
This Danfoss device is a “Thermostatic Radiator Valve”, which does not have the same functionality as a typical home thermostat. Because of this lack of functionality, we, unfortunately, cannot add the thermostat capability to the DTH.

So nothing from the official side. Do you guys have others ideas?

@RBoy Looks like I’m having the same issue with my Sinope thermostats. They were initially custom DTHs but now they are part of the stock repo and sure enough, for some reason they no longer implement the Thermostat capability but do implement other thermostat “sub capabilities”:

definition(name: "TH1300ZB Sinope Thermostat", namespace: "Sinope Technologies", author: "Sinope Technologies", ocfDeviceType: "oic.d.thermostat") {
	capability "thermostatHeatingSetpoint"
	capability "thermostatMode"
	capability "thermostatOperatingState"
	capability "thermostatSetpoint"
	capability "Actuator"
	capability "Temperature Measurement"
	capability "Configuration"
	capability "Refresh"
	capability "Sensor"
	capability "lock"

I’m not sure why that change was made but these thermostats are only for heat - though I don’t see why that would necessitate removing the Thermostat capability. Unless you see something that explains why one would want this I guess I’ll file a case with support too.

@RBoy bumping this

Well that’s very disappointing to hear from ST because that would render the device incompatible with any current app in smartthings as Thermostat is the default capability. @LLwarrenP Sinope can fix that easily too by adding that line to the DTH. The default DTH’s from ST for all ZigBee and Z-Wave Thermostats have this capability.

I’ll PM you to get some more details and see if there’s a way to handle this.

I had to resort to using webcore in a pinch, then I went back to using one of the old version of the dth until they fix it. I’ve let @CharlieSinope know about the issue, not sure how long it would take to add 1 line to the code but it’s been about 3 weeks now.

1 Like

I also filed a big with Support which will apply pressure to them as an official partner.

1 Like

Hi MRobi,

SmartThings made some changes that resulted in the situation that you are experiencing.
We have opened a ticket with them, and they are aware of the issue.
We hope that they will resolve the issue soon.

1 Like

@RBoy. Can we get an option like this For each time.? Wake time sleep time return time? Only when the switch is on or off.

I am using the Stelpro Ki Z-Wave Thermostat, and I noticed the hub keep sending " setThermostatFanMode " to the device every 5 minutes and obviously it is not supported by the line-volt thermostat.

Is this normal behavior and is it ok to ignore?

Yes it’s safe to ignore if your thermostat doesn’t support setting the Fan mode. Infact you can leave the Fan mode empty in the app so it won’t send the command at all.

Got it. Thanks.

5-2 Day Thermostat with Remote Sensor - Version 03.11.04

  • Added limits for temperature inputs
  • Check setpoints after a thermostat mode change triggered by a change from the external temperature sensor
  • Fix for fan modes

I have installed the 5-2 Day Programmable Thermostat Scheduler with Remote Temperature Sensor. What I need is to control one of the thermostats with the remote sensor (an Aqara sensor). I only really need to set 2 different temperatures, one for the day and one for the night. I set the remote sensor to my Aqara sensor and, for testing only, I set the wake time cool temp to 16 C, “Leave” and “return” times temps to 18 C and “sleep” time temp to 20 (A pain to have to enter all these different times for weekday and weekend which I don’t need). Expected behavior: the thermostat would be set to a high temperature when cooling is not needed and a low temperature when cooling is needed, depending on the remote sensor reported temperature. Actual behavior: the app sets the thermostat to the programmed temperatures (16, 18 or 20) at the schedule times (wake, leave, etc.). I guess I am not getting how this works? Please help.

That means you didn’t select the remote temperature sensor correctly.
There are two options for remote temperature sensors, per schedule or globally (for all schedules). If you enabled the per schedule option on the first page then you’ll have to select the remote temp sensor for each schedule where you want to use it on the second page. If you want to use it all the time, then just turn off the per schedule option and select the remote temperature sensor on the first page.

Thanks for the quick response. I do have the option “Select separate remote sensor for each schedule” turned off.