Random zigbee slowness (and now z-wave)

zigbee
hubv2

(Jeffrey) #1

I am not exactly sure how to figure this out so thought I would see what recommendations the smartthings masters have.

This problem seems t have been going on for a month or so (ish). Essentially turning on a zigbee smartplug takes between instant (1sec) and 5 minutes (literally 5 minutes confirmed from the app).

I can see in the activity feed of the device the off command sent and then 5 minutes later I will see in the app the device actually off. Sometimes it’s instant as I press the button or sometimes it’s delayed anywhere in the range.

The smartplug I am using for testing is literally on the other side of the wall from the hub itself. There hub is by itself in the middle of the house.

Going back and forth with support isn’t getting anywhere and at this point I am trying to figure out is it me? Is it in the cloud?

Anyone have any ideas how to trace where the 5 minute delay actually spends its time?


Ongoing Intermittent Delays
(Andy - United Kingdom) #2

@jjslegacy Zigbee is very close to 2.4ghz wifi - did you make any changes to your wifi that might cause interference?


(Jeffrey) #3

Not that I can think of. Maybe a router software update but no major changes yes. I’ll look into that later. Thanks for the idea

The wifi routers are on different floors from the hub and pretty far away from it. I tried some channel changing but no luck so far.


#4

I know you said 5 minutes based on the app. Have you visually watched the device come on and timed that? What you see in the app is when the device has reported it’s on not necessarily when it actually comes on. I have several ZigBee bulbs and on some of them on occasion will fail to report their status back until I refresh the app however they then report their time of change as that moment when in fact they have been on for some time.


(Jeffrey) #5

Yes i have visually confirmed the 5 minute example many times.

Good thought though!


#6

Well, I certainly understand your frustration with that. So many possibilities. Could be in the cloud, could be in the mesh, could be in the switch itself. The only recommendation I can think of to make right now is to do a ZigBee heal. Take the hub off power and remove the batteries, leave it that way for about 15 minutes. All you ZigBee devices will go into a panic due to the missing controller and rebuild their list of mesh neighbors. This process may take a day to show any results but it’s the only way to force the process for ZigBee.


(Jeffrey) #7

Thanks @PhilB. I tried the heal a few weeks ago but will try again.

Wish I could figure out exactly where the problem is. I was leaning towards cloud as I didn’t think zigbee would attempt/retry for a 5 minute span but could be wrong.

I should also note it’s not just this smartoutlet. I have others (different brand) that seem to show the same problem.


(Rudi Prunzel) #8

I’m having the same issue (only for some devices) for the last 3 weeks or so.
The same Device sometimes works (ON or OFF) in 1 second response and sometimes it takes minutes to react to the command.
I have tried to repair the ZigBee mesh (Hub power Off/On after 30 minutes) and several ZWave repairs.
I’ve also verified Wi-Fi interference (channels) and it’s not the case. I’m also seeing issues with ZigBee and ZWave devices taking to long to respond (minutes) at the same moment, and later on they work fine.
I also have a VeraPlus hub as my secondary Z-Wave controller and when ST is not working (taking too long) I can switch Off or On using the Vera app or a minimote and works instantly.
It’s a really weird behavior. At first I thought this was a ST cloud issue but I’m not sure :frowning:


#9

Sure wish I could give you guys a definitive answer. The only Zigbee devices I have are smart bulbs and I haven’t experienced delayed reactions with them so far.


(Jeffrey) #10

Well at least I am not alone…:joy:


#11

If it’s taking minutes, but it’s eventually successful, it’s almost certainly the cloud.

Local interference might cause a message to have to be resent a couple of times, but we’re talking about seconds, not minutes in that case.

And problems with the the zigbee network might cause a message to get lost altogether, but again, not a five minute delay. Zigbee Home Automation just doesn’t work that way. Messages don’t get buffered and then sent in a burst. They get sent, if they fail, they may get sent a second or third time, but that’s it.

Now if your Internet is choppy, such as you would see with Netflix buffering, then you can definitely get delays have a couple of minutes because the router will keep retrying to send a message through.

But then I would expect you would see similar problems with any of your smartthings activities.


(Jeffrey) #12

Thanks - you have come to the same conclusion I have although support seems to disagree:

Their latest:
“The command is being sent immediately. It seems like the device itself is just taking that long to respond.”

I have a few brands out smart plugs and all do this so I don’t quite agree.

Today I have had a few cases where the plug never comes on at all but I did change wifi channels today so maybe that’s new.

Having said that - today when I got home I turned on one of the plugs from app and as usual it was taking quite a while - i went over to the plug and pressed the button and that was instantly updated in the app.
Seems again to point to it not being the plugs to me.


(Jeffrey) #13

I tried turning off the 2.4ghz wifi on both routers and no change.

Also tried turning off hub for 15 min. It worked fast for a few min and back to slow after some hours and checking back.

I am offficially annoyed and out of ideas.


(Jeffrey) #14

Now it’s between 7 and 10 minutes. This is nuts


#15

Do you have device health turned on or off in the IDE?


(Jeffrey) #16

I have tried both settings in the ios app - doesn’t appear to make a difference.

This morning/last night I seem to have lost all control and can’t get anything to work even if I wait forever

I rebooted the hub and now everything is fast - I assume it will break in a few hours

*device health is off currently - turned off earlier


(Rudi Prunzel) #17

Same behavior here. When I turn On or Off the Device itself it reports immediately on the ST App also (an this is during the issues for device not responding to ST Apps commands).
In my case is some devices only and they are ZigBee and ZWave. And the issue (delay) happens for a couple of minutes and then it goes back to normal without any changes on my side.
I’ve also tested internet speeds and could not find problems, besides my other devices are working fine :frowning:


(Jeffrey) #18

Today’s latest test:

  1. Unplug a few other zigbee devices in case something weird is going on.
  2. Move smartthings hub into bedroom that has the smartplug. It’s about 8 feet away now
  3. Unplug one of the wifi routers on the upper floor

Once the hub came back online the smartplug workd great instant switch on/off

Wait about 30 minutes
Try to turn off - nothing or long delays.

I am completely stumped.

@RudiP - curious if you restart your hub does your work good for a little while?


(Ray) #19

Here’s something to isolate. If your devices are qualified for local processing. Then using ST smart lighting smartapps. Setup an instant to sync all the switches together. Let say if switch a off then turn off switch B, C as well. When A on = B, C ON.
Now disconnect the ethernet cable to your hub and go test your switch by pressing the button on switch A.
At least with this test. You will eliminate the cloud.
power off your WiFi if you think it’s 2.4Ghz issue.
Still problem? Most likely mesh.


(Jeffrey) #20

Interesting thinking - Checking the local list they are all local so I can play around.

I am starting to think it’s the hub itself or something.

How can it work fine when I reboot the hub and then break an hour later?
Also if I press the button on the smartplug poof it reports instantly - that can’t be mesh.

I will play more - thanks!