Quirky Ge Tapt switches with Smartthings hub


(Matt) #1

Does anyone know how to pair my switches Ge with my smartthings hub? Ptapt-whca

I have tried to add device and then put in pairing mode by pushing on the 2 buttons with no success. The app searches for devices but cannot find either switch. Is there another way to pair. Manually?


(Someday my dog will be automated) #2

If you want to add the Tapt switches, you need to use a custom device handler, instructions posted in the following thread:

At some point, the Tapt switches could be recognized by ST as a Zigbee switch, but after an update from Wink this could no longer be used to pair them. Keep in mind that the device type required will not update the status of the switch in the app if you press the switch buttons.
As my two cents, if you are to use the ST hub, get rid of these switches. They are quirky (pun intended) and will go offline randomly. I am down to the last one of these and will be replacing it shortly. Just my two cents.


(Matt) #3

That one says the custum device type is no longer needed. I have added the device type in ide anyway but where should it show up in smartthings app? The problem is that when i search for the device, the st hub cannot locate it.

Update [12/14/2015]
This custom device type is no longer needed. Your best method is to remove the device from ST, remove the published Device Type and add to ST. It will add as a ZigBee Switch which does on/off and instant reporting.


(Someday my dog will be automated) #4

That was back when ST and the Tapt did play nice together. For some reason after a Wink update it stopped working like that.
After you add the device in the IDE, you need to go to the “Add a thing” button in the ST app and follow the instructions to add the switch by using both the top and bottom button.


(Matt) #5

I added it ide & published it for me then went into my smartthings app and add a thing but I wasn’t detected. Is there something I did wrong?


(Someday my dog will be automated) #6

Do a power reset of the switch and then try again. Tapts are notorious for behaving like that.


(Matt) #7

Power resetting and pairing do the exact same thing on both switches.

You hold both buttons, then both lights start to blink and then nothing. This is how it says to pair and this is also how it says to reset?


(Matt) #8

Instructions I’ve found say
Pair your TAPT to SmartThing start pairing in smartthings and press both button until leds flash fast and then flash slow.

But mine never flash slow


(Someday my dog will be automated) #9

Did you power reset the switch? Tapts are known for getting stuck into an unprairable state until you flip the breaker for the circuit.
Do you have a Wink hub you can try if it is working? Maybe it is a bad switch?


(Matt) #10

Yes I did power reset the switches. I have 2 and they are both doing the same thing.

I dont think they are going into pairing mode or factory reset. If you hold the 2 buttons both lights blink rapidly then stay lit for 1 second and turn off.


(Someday my dog will be automated) #11

Have you checked the switches in the app and see if they haven’t paired already? Sometimes Zigbee products do that.


(Matt) #12

Yes. I have double checked that. They did not add


(Someday my dog will be automated) #13

Do you have other Zigbee devices on your network? How close is the hub to the switch? How close is the hub to your WiFi router?


(Matt) #14

Hub and router are 8 feet away. Clear line of sight. No other zig bee devices. I may have had a wall plug before but I don’t believe it’s plugged in still.


(Matt) #15

I actually have 2 zig bee bulbs. Ge link bulbs


(Someday my dog will be automated) #16

How far away are the switches from the hub? Might want to try and get them closer.
Also, if you have a long ethernet cable, just to try, get the hub farther away from the router. WiFi might interfere with Zigbee.

If nothing works, I’m out of suggestions.