Qubino Flush Shutter Tutorial

I’m using a 110v Qubino Flush Shutter controller with the device handler provided by Kristjan Jamšek @Kjamsek. It’s controlling a motorized window blind, just up and down, looking to get it working properly with Alexa.

The device handler is hard to understand and configure, and that is only true if you are even able to get it loaded and the Qubino paired to your hub. I’ve managed to do that, but the process is not intuitive, and the configuration I’ve managed to get working is simply not correct.

Does anyone have a guide, or links to videos or some resources for installing and configuring the device handler?

Here’s a topic I wrote on integrating Rollerhouse shades with the Qubino shutter module.

There’s a link to the device handler I wrote for that device about half way down the page and it allows you to use the device as a dimmer in Alexa and Google Home.

Alexa / Google Home commands:

  • Turn on - opens shade all the way

  • Turn off - closes shade

  • Set to <#>% - Sets the shade to the specified # with 100% being completely open and 0% being closed.


Thanks for the link and info! When I use your device handler, it does not have all the buttons that your image shows.

Is it at all possible that the model number difference is causing the problems? Mine is a ZMNHCD3, your handler was written for ZMNHOD3.

I modified your device handler with the new model number (and also dumped the cache in the Smartthings Classic app) and reconnected it. I now see the same number of tiles, but the icons did not load, and the status tile says “10 Pending Changes”. Calibration is not functional.

Is it possible that changes to the SDK have left this device handler in the dust?

You mentioned you tried a different handler before so it probably assigned it that, but if you open the device in the IDE you can manually change the type field to mine.

Once you’ve done that, open the device with the mobile app, go into the settings, and save.

I had entirely removed the other device handler before trying yours, and did a factory reset on the Qubino. Still no luck, calibration does not work at all.

At this point, the Jamsek controller works better, but not great. Perhaps there are differences in the Zwave command IDs. I’m not a programmer, but I can hack a little bit here and there. It’s so odd that the tiles don’t load their icons.

I found the issue with the icons in the tiles. Since I’m using a Samsung phone with Samsung Smartthings, my expectations that there would be some good compatibility have been dashed. It turns out that when I use my old S7E, the icons show up fine. My S10+, on the other hand, with Android 10, struggles with the Classic app.

I’m almost positive that the device handler you published is not working due to the way AC voltage and current is reported. The @Kjamsek version has a number of parameter settings that are configurable via the app, which your version does not. Oddly his version also has code to control the tilt of venetian slats, which would require several more wire connections than this device possesses, so I’m extra confused.

Mine was written for the DC controller, but I thought the config parameters were really close.

Mine is also designed to work with a rollershade so I didn’t expose any of the settings that don’t apply to that functionality.

What type of device are you trying to control? If it’s a roller shade that requires you to set the upper and lower limits using a button on the shade then you won’t be able to calibrate it until you’ve done that…