Problem with VEdge Creator and Alexa Routine Trigger

I have found that alexa is not registering the state of change reliably for the AlexaSwitch that has been separated into switch and contact. And for when it does make a change to the state, this does not seem to trigger the routines I have connected to those state changes. IE when a contact sensor opens, it shows in smart things, it will sometimes change, very delayed in alexa, and then no alexa routine will trigger.
My question would first be around how adding devices into alexa should be done, incase I am creating problems for myself there. Is there a proper way to ‘add devices’ when you’ve finished creating the virtual device in smartthings? Or is there no wrong way to do it, so long as it comes through.
I’ve done an ‘add device’ selected it’s category, then other for brand, and then scan for devices, and it finds both the virtual contact sensor and the switch. Just wanted to make sure I wasn’t doing that part wrong first…
Also I can change the state of the switch in the alexa app, which then changes the state of the contact sensor, but this doesn’t even trigger the routine…?
Any suggestions on trouble shooting why I am unable to get the state to update and trigger a routine inside alexa would be greatly appreciated!

I’ve also been having unreliability with the change of state of one particular virtual contact sensor often not being picked up by Alexa, while others have worked fine.

Interestingly, in this case I had few virtual switches that were in use as part of a ST automation, with only one them to trigger an Alexa routine. But it would only occasionally trigger in Alexa. I eventually tried simplifying the routine so only one virtual switch was used and now it works fine. Seems like sending multiple state charges at one time to Alexa was causing an issue and not all of them registered. Not sure if this applies to you though.

Having said that, while trying to resolve the issue I did toggle the switch/contact manually on its own to test it and it didn’t always register. As part of a routine though it works fine so I’m still a bit confused.

I’ve tried both the virtual Alexa switch with mirrored contact and the multi switch.

@granite and @drjekel - Are you using the Separate Contact option in settings under the AlexaSwitch? The contact created with the Alexa switch in known problematic for quite some time after Smartthings and Alexa changes which is why @TAustin added the Separate Contact option. If you are using the Separate Contact option and the Separate Contact is not reliably being set, than I would defer to @TAustin

1 Like

I tried removing the switch component from my Alexa’s side, as you had said multiple changes at one time was causing issues, so only the contactor was sending info to the alex, but there was no change unfortunately.
@tktps - I did separate them under the settings in the AlexaSwitch, and the state of the contact only is not being carried from Smart Things to Alexa.
Is there a different virtual device I should set? I tried a bunch of different ones, like temperature, motion, etc, none of them seemed to get any info reliably to alexa.

@drjekel Not sure what you mean by removing the switch from Alexa. No need to remove anything from Alexa … It can auto discover all components … no issue. Set up Alexa Switch in Smartthings. Turn on Separate Contact in Settings of the Alexa Switch. Then in Alexa when testing the condition use the Separate Contact created NOT the switch. If you need to change the status in Alexa, use the switch.

Sorry @tktps the removal of the ‘switch’ component was in reply to @granite saying that getting multiple signals at once was what his problem was. I have both the contactor and the switch (separate) as two things in my alexa and smart things. So i decided to try and remove the switch component from the alexa side, to see if simplifying the signaling would do anything, which it didn’t.

And in reply to your comment, I have tried all that, separate contactor and swtich, both come in fine when discovering, but there is no state change in either the switch or the contactor. Oddly enough if I open the contactor, not just looking at it among other devices, but selecting it, it will sometimes update the status from open to closed, vice versa, but this is not triggering routines in alexa.

Thanks for your help, sorry for the confusion! Any other suggestions?

Have you tried the Alexa Multi-Trigger mentioned above? I think it was intended to resolve these type of issues?

1 Like

@Carson I’m not sure what you mean by opening the contactor. There should be a switch and an embedded contact as well as a separate contact if you are using the Separate Contact setting. You can’t open and close the contacts directly. You set the switch on and off and it in turn opens and closes the contacts accordingly. Then test the separate contact in Alexa and it should work. If it’s not, try posting screen shots of you Switch/Contact info and Alexa tests

As a last ditch effort have you tried deleting the virtual Alexa Switch from ST and Alexa apps and recreating the switch with seperate contact sensor and then recreating the Alexa routines with the new virtual Alexa Contact sensor?

@JKnight I haven’t tried it. Getting the first driver installed in my hub was something that has worked in the past so I assumed it would be the most stable. The ‘multi-trigger’ speaks of being a rush / test job. I didn’t feel like experimenting with that route, but if you’re suggesting it as something that I should try out, it feels like I’ve exhausted all avenues with this driver, so I’ll try it out if I can’t get this one working. Thanks for the suggestion!

@tktps sorry for any confusion! Let me be as clear as I can, I think we’re on the same page, but I’ll draw out the process as clear as I can. Let me know if it’s clear!
Smart Button → links to virtual switch/contactor (separated via the settings menu).
Click button → virtual switch toggles on/off (this works, no issues)
Virtual switch → toggles contactor open/closed
No issues on the smartthigns side. All input from the button is captured, and the switch is toggled, and the contactor is toggled.

Virtual contactor open/closed state does not transfer.
Switch on/off state does not transfer.

In alexa, with all devices open, contactor will not change state when button is pressed.

Just a side point, that I noticed, not sure if relevant. If I open the contactor device within alexa, to view it’s state (where there is a settings gear in the top right corner, where you could click it and you would be able to delete the device), this will SOMETIMES update when the button is clicked. However regardless of the state shown here, it will not trigger the routine that is based on it.

In the routine, if I manually run the routine, it will execute the desired smart home output (in my case, turning on or off a light). No state change is found in the contactor, and no routine is triggered, even in the case where I am viewing solely the contactor, and I see it’s state change updated. The state change does not update every time the button is clicked, it updates randomly, usually it requires a long wait period before pressing the smart button again. Again, regardless of the state listed here though, it does not update when looking at the all devices screen, and it will not trigger the automation.

Okay, hopefully this novel helped explain my situation a little better! Thanks for your willingness to help!

I agree with everything you said, but you may want to give it a try if nothing else has worked so far. I had 2 of about 20 virtual AlexaSwitches that were acting up and not working/triggering with Alexa, and I changed the 2 over to the Alexa Multi-Trigger and haven’t had any issues since.


@drjekel not sure what else to tell you … sounds like you are set up correctly. i assume you are on latest driver level?


Carson, based on what you are saying, it sounds like the problem is actually on your Alexa side of the configuration or the bridge between them. It sounds like SmartThings appears to be operating the button and contact correctly.

Here’s what I suggest:

Remove ALL references to the button and contact in both ST AND Alexa.

Create a new Alexa Switch
Edit the switch’s Settings

  • create the separate contact
  • set Auto-revert to Off
    At this point, you should have received at least one notification from Alexa that a new device was added. If not, say Alexa Discover Devices
    See if it works by changing the switch state on either end, and seeing the results.

Another thing to try is to drop the SmartThings Skill and then re-add it.

@Terri_Baker I have deleted and remade the routines on both the alexa and smart things side, completely, multiple times. But just to make sure, i’ll do it one more time right now before I hit send on this reply. Same functionality. The devices are discovered no problem. They work on the smartthings side fine, but they will not trigger the routine.
@TAustin - just as an FYI. I have noticed that while previewing the device in alexa, if I wait between smart-button triggers, there actually will always be a state change noticed on the alexa device. But only if I am previewing soley that device, either the switch or the contactor. But the state change is not triggering the routine through alexa. And the device state is not being updated in the device list view, where all other lights/swtiches are listed etc.

@danhvos - thanks for the suggestions! I tried remaking everything, but when adding devices I have been doing this through “add device” on the alexa app, selecting ‘contact sensor’ and then selecting other for brand and then selecting ‘can’t find matching logo’, for it to just start searching. And it finds everything. Is there a difference between what i’ve tried, and asking alexa to discover devices via voice? I have not tried dropping and re-adding the smart things skill on the alexa side, but I did just recently re-connect the alexa via the smartthigns side of it…
I will try re-adding the skill on the alexa side of things.
@JKnight My next steps after trying the above will be trying to install the multi-trigger thing and setting it up through there.

@drjekel I suspect that this has something to do with how your Smartthings and Alexa are linked. I never have to added devices in the Alexa app. They automatically populate when created or changed in Smartthings. So, something doesn’t sound right


Hmm… okay thanks for the line of troubleshooting @tktps. I’ll see what ways I can test/reconnect these two things. Perhaps this is truely the issue, it’s a shared household and I am not the ‘OWNER’ of the home, but have full access in smart things… perhaps there is an issue during the linking phase because of this. I’ll let you know what I try and what the outcome is when I have time to test. Thanks for your help!

There can be only one Alexa/Amazon account associated with a ST/Samsung account. If you link two Alexa/Amazon accounts to a single ST/Samsung account, one of them will become inactive. Be sure that the owner of the home is using a unique ST/Samsung account, separate from yours, and that each of you use a separate Alexa/Amazon account for linking in the ST/Alexa skill.