Problem with ThingShield

I don’t seem to be able to find the correct location for the ThingShield libraries. Can someone help? I keep getting this error:error:

‘SmartThingsCallout_t’ does not name a type

I have unzipped Shield following the (vague) directions found here:

The default path to the .h file ends up looking like
C:\Users\Brent\Documents\Arduino\libraries\SmartThings\Shield Library\Shield Library\SmartThings

I tried moving the files to a path like this:

and several other locations.

It looks to me like the second path (C:\Users\Brent\Documents\Arduino\libraries\SmartThings) would be the correct one, since it’s important that the folder matches the name of the SmartThings.cpp and SmartThings.h files it contains and is top level (I believe). After that, have you tried quitting the Arduino IDE? That’s what the problem usually ends up being for me.

If that doesn’t work, you might want to try downloading version 1.0.5 of the Arduino IDE and using the library import feature that is talked about here - looks much smoother.

I am having the same problem - I tried adding the libraries both ways. Did you get this working? I am running on a MacBook Pro

I actually got this working. The problem was that the zip file I downloaded had illegal characters in it when I tried to import it into the Arduino app. I changed the file name(took out spaces) and imported and it worked fine.

Where did the ST Shield Library get moved to? doesn’t seem to work any longer.

This worked for me too. Good call. For others, makes sure you pull the space out of all of the files. I think there were three different "Shield Library"s.