Problem with controlling a roller shutter with smarthings and a fibaro switch (FGRM-222)

I do not have any switches that I can use, can I simulate one?

The log shows this:

13:07:56: debug Executing ‚ÄėForce Calibration‚Äô

But nothing happens, no movement of the roller shutters…

Now it did something, it went down for 2 seconds and then up for 1 second and then it stopped…

The problem is now all the other functions do not work anymore, no open and no close

Probably it tries to calibrate but because there are no actual motors attached but instead a bus that does not give back any signal it just stopps and does not finish to calibrate…

After turning power off and on again on the fibaro it works again

I just changed cables so that the fibaro is directly connected to only one motor and I am doing the calibration right now with your button

1 Like

Lets see if it works :slight_smile:

Now with just a single roller shutter attached it calibrated (went all the way up, then down and then up again).

Unfortunately the slides does not work now…

I rebooted everything and used the original device type again and now the slider works and I can also set the exact position of the roller shutter in CoRE!! :slight_smile: :relieved:

At the moment I only have one motor attached, I will try to change the cabling so that the bus for the whole house is connected instead of only one motor now…

1 Like

Arghhhh it does not work, once the bus is connected and not a single motor the fibaro device is not able to use the slider anymore :frowning:

Once the bus is connected and not a single motor the fibaro device is not able to use the slider anymore… should I connect one motor in parallel to the fibaro and see if that helps?

Ok sounds great! Would be perfect if I could set parameter 18 to 0 I guess so that no power feedback is needed to stop the motor…

  1. Motor operation detection.
    Power threshold to be interpreted as reaching a limit switch.
    Available settings: 0 - 255 (1-255 W)
    The value of 0 means reaching a limit switch will not be detected
    Default setting: 10 (10W).
    Parameter size: 1 [byte]

Just quickly checking, why are we doing the 18 seconds again? :slight_smile: something much shorter would be needed.

I probably need something like 1,8 seconds (1800 ms)

Thanks I will check now, was out of office… will let you know what comes out of it.

1 Like

Not sure if it is working, I changed the settings and it seemed to update but it does not change anything in the behavior of the device…

I don’t know what to do anymore… it worked perfectly with the slider and the single roller shutter attached but not anymore once connected to the bus in my house :frowning:

Hi Robin, I tried to force auto-calibration with changing 29 to 1 and it worked but it only moves a bit and then stops… whatever I tried with parameter 18 did not change anything…

Just tried it and it does not stop after 2 seconds, I guess param 22 is something different then… well nothing to do I guess.

Thanks again for all the help here!!

So you think it will work to get a dual relay switch and then set the auto stop after 2 seconds in the device itself?

Can I only enable the auto-off in the dual relay switch in some situations or will that device then always turn itself off every time? Because that would mean that I will never be able to move the blinds all up then…

Actually it is an EnOcean bus from Eltako. I believe it is a smart bus and the rollers move when they get a signal to move and not when power is on the bus… I had that solution in the house and used the fibaro devices to make the given automation system compatible with SmartThings…

Sounds awesome!!!