SmartThings Community

Presence sensors: Just stopped working [Platform issue now fixed!]

(Mike Turner) #72

Update just received from support:

Hey Mike

Over the last few days your Presence Tag issue has been a trending with multiple users, there seems to be a firmware issue where by the Tags don’t report the correct state or battery levels. There is currently a team of engineers working around the clock to find a solution. I will relay updates as soon as they come in. So please sit tight, and I will continue to pester the engineering department until we have a fix.

Thank you, for the ongoing patience.

Cheers,
Tom

0 Likes

#73

After the update both my presence sensors showed away. So last night i removed and re paired both my presence sensors. It seemed to work but i now see that rthe presence sensors now show present at all times.

0 Likes

(Mark) #74

Yep exact same problem for me as well.

0 Likes

(Stephen Hill) #75

Glad it’s not just me. I’ve got 3 presence sensors (1 x iPhone, 1 x Android, 1 x Presence Sensor). The Android one seems to work, but the other 2 still claim to be ‘Present’.

0 Likes

(Merlin Ross) #76

Several weeks ago, I had similar issues. I re-paired the presence sensors, and they would work for a few days – then go bonkers several days later. I use a v2 ST hub. My “best fix” was to unplug the hub, and indeed remove the batteries to force a “hard reboot.” I haven’t had any errors/issues since I did the hard-reboot.

For the fob sensors, my assumption is that the Zigbee network periodically malfunctions/jams, and the sensors can’t properly communicate over the network. So, if their last-status was “home” – then their status gets stuck on “home.” Ditto if their last-status was “away.”

Removing ONLY the power supply, or ON the batteries won’t cause the ST hub to reboot. You have to remove BOTH power sources to force the reboot.

Afterwards, I learned that there is an option via the IDE website to somewhat “repair” the Zigbee network?..
Personally, I prefer the ability to hard-reboot electronic devices every now and then – just to make sure caches and such get properly-cleared/flushed.

0 Likes

#77

The repair utility available through the IDE is for Zwave. Not Zigbee. Zigbee will automatically repair itself as long as you take the Coordinator off power for at least 15 minutes.

The SmartThings hub is a single plastic box, but it actually has connectors for three independent networks: A zwave network, a zigbee network, and connection to your ethernet. (The v2 hub also a Bluetooth connector, but it has not yet been activated.)

So you need to “heal” the address tables in the Z wave and Zigbee networks independently.

Taking your hub completely off of power will force a zigbee heal. It will also force your local hub to re-sync with your cloud account. However, it will not force a rebuild of the Z wave address tables. No matter how long it’s off power. That protocol requires that the utility be run. It’s just how Zwave works, whether SmartThings is part of the picture or not.

As far as a presence sensor getting stuck, there’s no question that if the fob loses connection it might be marked as “away” when it was actually still in the house. This could just be from local interference.

Always being marked as “present” though, is a completely different kind of problem. Normally, the fob checks in every 30 seconds, and there is a parameter which causes your account to mark it as away after it misses a certain number of check-in’s. So it should need to repeatedly check in in order to maintain its status of "present.

The fact that a number of people have fobs being marked as present when they are not, like mine, indicates more of a backend issue or an account level issue. Because it’s not like pretend check ins are being generated.

So definitely something weird is going on.

0 Likes

(Shaun Reinson) #78

For those with the consistent presence sensor fault, the main diagnostic - apart from always present - is that it never gives a battery reading.

If you have a battery reading, then its probably okay, and any firmware fix is unlikely to cure existing present/non-present issues (usually caused by various radio/wifi and other environmental issues)

1 Like

(Stephen Hill) #79

This sounds correct (my presence sensor isn’t given a battery reading). No idea why the phone presence sensors aren’t working though.

0 Likes

(Paul Green) #80

My presence sensor has suddenly stopped working two days ago and thinks I’m constantly “away”… I say stopped working… The key finder beep still works when I go in to it on SmartThings app, and it still reports a battery life, so I’m happy it’s fully connected.

Have ST done a sneaky firmware update on the hub over the last few days?

I’m loathed to go through support, as I don’t want o be told to remove all routines that use the presence sensor and re-connect everything.

Just when I thought ST had stabilised as the product I paid for three months ago, this happens.

0 Likes

(Dean Smith) #81

This is a big problem for me at the moment - My wife has the sensor but it isnt working and hasn’t been for about 5 weeks now.

She cant use phone presence as she doesn’t have a phone able to do it. Thats why I brought a “product” that is meant to act as one… which doesn’t work.

Please ST can this be a priority now that oAuth is fixed as its a integral part of the system and just doesn’t work.

0 Likes

#82

@deano12 oAuth isn’t fully fixed yet. Only The IFTTT oAuth integration as far as i know.

0 Likes

(Dean Smith) #83

Thats true. However as far as I know the ST backend has the fix implemented. It’s now just a case of all the 3rd Parties updating their side with the required changes.

I was more referring to the investigations of what was wrong.

0 Likes

(Jon) #84

Another UK here with presence sensor stuck at present. Started approx two weeks ago - deleting and re-pairing via official methods doesn’t help - I get one message to say present and nothing after that first log entry.

0 Likes

#85

The wife’s one had just stopped working the other day and is permanently away… It had been working fine until now (config unchanged), and also people are reporting the problem at different times so it’s quite puzzling as to what might be triggering the problem?

0 Likes

(Alec Howson) #86

same here. both mine are no longer functioning. both stuck at present. one is missing its battery indicator but can be made to beep

support ticket raised

0 Likes

(Mark Freelance) #87

Another name in the hat, not had problems at all but the last week it’s been intermittently crap.

0 Likes

(Stephen Hill) #88

Annoying really because just when you think you have a bit of stability now that OAuth is fixed this then rears its head. A month or so of it all being stable isn’t a lot to ask.

2 Likes

#89

Yep mine too. All reported and awaiting a Level 2 response.

0 Likes

#90

So its now over a MONTH since this started and it still hasn’t been fixed. How can engineers be working “around the clock” and it still not be fixed? Surely this has to be the highest priority issue they have?
Staggering that after a month it still isn’t fixed and also staggering that the update that broke all this wasn’t just rolled back!!!

Unacceptable. Im going to try and get mine returned and refunded as for me the platform is unusable without them and hasn’t worked for over a month now. Disappointed to say the least.

0 Likes

(Bob Tume) #91

I feel your pain

Since the “working on it around the clock” email I don’t even get the “we haven’ t forgotten you” messages anymore!

I asked for an update a while ago and was told effectively “we will let you know when it is fixed”

Pretty poor

1 Like