Preconditions stopped working (Jan 2022)

My preconditions in my routines have stoped working is there an issue with these again?

I have a routine that uses a precondition and the precondition is no longer checked and the routine completes when it should not. I have tried setting a few different routine with the check precondition option and none of the preconditions are checked and the routines complete.

Is there something going on or something I need to do? All I am doing is pre condition checking the location mode. I do not want the routine to continue if the location mode is not away. Simple routine that runs every time when location is home and should not.

I’ve deleted it, unplugged my hub for several minutes. Set up several different routines and issue remains.

Sent email to support

post a screenshot of your Routine(s) so we can get a better look at what you are describing

Here is the most simplest. This first image works but as soon as I add additional devices and change the when any condition below is met then the precondition does not get checked.

Ths does not work correctly


Looking at the app version, 1.6.76 it was updated last week about the time this broke.

I’m seeing the same problem.

I’ve been having the same problem for a couple weeks now.
So far my fix has been to separate them to two different routines if there are multiple conditions.
I’ve also been able to delete the routine and start over.
Mine originally included two preconditions and wo locks for the condition. Pretty close to @silverbullet07
The result was that the routine would run anytime the door was unlocked and ignore the precondition.
This had been running without a problem since last spring or early summer when I moved almost all my processes from Webcore to the smartthings app.

On a different note. At the same time the preconditions started having problems. I found that my routines that have multiple conditions with time delays started ignoring the time delays.
A called tech support. They suggested that I separate the routines to make them as simple as possible.

It’s a shame that all they can tell you is to separate into individual routines. Seems like they will never work out all the bugs and make this a dependable systems. I don’t know how much longer I’ll want to put up with this aggravation. As I get older, I keep wanting less aggravation in my life. :grinning:

1 Like

Looking like it might just happen to be the same thing I’m dealing with here, which gives me (some) hope that this might get resolved in a reasonable timeframe and fix my issue.

Received an update from support today.

Hi Harold,

Hope you are doing well.

We are writing back with an update on this issue. After a certain investigation, we like to inform that we were able to create a similar automation with same result. It looks like the latest iOS app is failing to properly set the location mode as a precondition. We have reported this issue to our developers and they are working very hard to fix this as soon as possible. We request you to please wait for sometime until we fix this issue.

Feel free to write back to us for any further assistance.

Thanks for being best part of Samsung.

Kalemula Aditya
Samsung SmartThings Support

1 Like

Just checked the new update that came out yesterday. Looks like preconditions are working again.