Piston not firing on odd occasions?


(Stephen Hill) #1

I have a piston which is set to fire at 6am on every weekday morning, and turn on a smart plug:

Problem is - on a few occasions (most recently this morning) this didn’t fire. Can anybody help me try and debug exactly why this happened.

Annoyingly - it works perfectly 90% of the time but I’m at a loss to see why it doesn’t that 10% of the time.

EDIT - Just to add, the ‘Evening’ mode is triggered at Sunset, and ‘Morning’ is triggered at Sunrise (which was 6.10am this morning - so it should have run fine this morning)


(Simon) #2

I have a similar piston to open an close curtains. This looked to have failed twice. However I suspect now it was just a massive Event delay. Take a look at your runtime statistics and see if anything stands out.


(Stephen Hill) #3

Looking at my stats it seems as though the ‘ON’ command was sent (at 6am) - just nothing happened.

Not really sure how to check event delays etc…


(Joel W) #4

I have one that is supposed to turn off a light at 11:20 PM but has failed two days in a row.


(Rick S) #5

I have a morning Piston to change mode to Home and turn on a light. Mode changes, light won’t go on. Been happening for about 2+ weeks now and I can’t figure it out

Good luck
Rick


(Stephen Hill) #6

In a weird way - I’m glad it’s not just me. But this just makes me thing that it’s an issue with Smartthings, rather than CoRE.


(Rick S) #7

I would agree, however when I contacted ST support, they said since they saw the Piston fire (mode change did occur) everything looked normal on their end (FWIW) and to contact the CoRE developer - LOL

Rick


(Stephen Hill) #8

Just to say that my piston worked fine this morning, which again leads me to believe that the issue is at Samsungs end.


(Rick S) #9

I ended up removing the light completely from my system, then re-adding it back in, then back into each Piston and it worked this morning. Go figure

Rick