Phillips Hue Grouping, Scenes and Alexa

I’m running into a logical setup issue with my Phillips Hue groups/rooms. I am going to use my basement for this example…

My basement has a total of 4 BR30 recessed Hue bulbs; two at the front of the room and two at the back. There are times where we will turn off the rear lights and leave the front lights on (near the TV) but dimmed, or vice versa. The point is, I do need independent control of each set of lights (back vs front). Therefore, I did the following:

In the Hue app I have defined two rooms, Basement Front and Basement Back. Each room has the respective bulbs in it. Now at this point, Everything works fine/great. I can use Alexa to control each set and I can also use each Hue Dimmer Switch to control each set of lights.

However, I also wanted to be able to say " Alexa, Turn off the Basement lights" and all of the lights turn off. So, in the Alexa App, I created a Alexa group called “Basement” and using the Hue skill, I added “Basement Front” and “Basement Back” to the Basement group. Awesome! Now I can tell it to turn on/off and even do standard colors without an issue!

There’s only one catch - scenes will not work. For example, I setup a “Normal” scene for all of my rooms, which allows me to bring the room back to the default color I set. If I say “Alexa, turn on Normal in the Basement” she responds with how there is no setting or that for the group Basement. I had thought maybe she would execute the scene on the child group of lights, since the scene does exist, but this doesn’t appear to be the case.

So with that said, has anyone successfully configured a room with hue lights where you can independently control the lights via multiple dimmer switches (each switch dedicated to specific lights) and a parent Alexa group, per se, including working scene control? I’m trying to figure out if this is just a logistical error in the setup on my part, of if it isn’t possible to accomplish this, at this point in time.

Thank you!

If I understand what you’re describing, your “normal” scenes are scenes that you created through the Hue app? Not through the SmartThings app?

If so, you cannot use them with an echo group. You have to get to them through the hue bridge instead.

There are several ways to do that with one voice command.

You can do it with SmartThings, you can do it with IFTTT, or you can just do it with an Alexa routine.

For the Alexa routine, it’s easy. ( in the example below, “bright” is the standard hue scene created in the hue app and available in multiple Hue rooms. I just added each one that I wanted one at a time as an “action” in my new Alexa routine.)

  1. Open the Alexa app.

  2. Add a new Alexa routine choosing whatever start phrase you want.

  3. For “actions” choose “smart home” and then add each individual scene to the routine that you want.

  1. “Create” The routine to save it.

  2. Now wait about a minute, it takes a little while for this to get all set up.

After that, whenever you give the voice command for that routine, your multiple Hue scenes will execute at the same time. :sunglasses:

If you want to be able to, instead, push a button on a minimote and get the normal scene for both sections of the basement, probably the easiest way is to use IFTTT with one applet for each Hue scene. Otherwise you would have to re-create all of the settings from the Hue app as a SmartThings scene, which is going to be a lot of work.

1 Like

Genius, @JDRoberts! I will give that a try and report back, however I’m betting you just solved my problem!

1 Like

I know this topic is old, but I just did this type thing and wanted to share it.

In my case, I was using the Hue scene ‘bright’. The phrase “Alexa, turn on Bright in the Kitchen” was and is working. Except I have a trio of pendant lights above the island counter, and that trio is on a Zooz smart dimmer that is not Hue compatible.

Answer? An Alexa routine that deploys the exact same phrase. It performs two actions: turn on the Bright Hue scene in the kitchen, and turn the Zooz dimmer on in Smartthings at 100 Percent.

1 Like