Original Multi Temperature Sensor Gives Mediocre Data


(Hfb) #1

So, I have been comparing the original SmartThings multi sensor temperature sensor and I just don’t like it at all. Here’s some data I have been taking. I’ll explain in a bit.
https://thingspeak.com/channels/16204
The first graph shows the data you would get by looking at your smartphone app. I used a SmartApp to send the data directly to ThingSpeak whenever there was a change in temperature. It only shows 1 degree F resolution and has these 2-3 F spikes that just look bad and inconsistent. Not only that, there is a horrible offset that you can’t account for and it ALWAYS reads low by anywhere from 2-5 F depending on the device. That’s true of all 11 devices I have.
The second graph shows the data you get with a Python script I wrote to grab the raw data from the web. That data is in Celsius and is in tenths of a degree resolution. Not all that bad and much more along what I expect except for the fact that this too is off by about 2-5 F after converting from C to F. I adjust for it in my script so it’s the correct temperature. What did I use to “calibrate” it? Just some cheapo temperature displays I had around the house from before that were all within 0.5 F of each other. Kind of ironic that the ST one is always off huh? Not only that, when the spikes you see in the first graph line up just right at the 5 minute interval I run the script, it makes this look horrible too. The spikes occur roughly every hour but drift over time. I’ll see them on some sensors until it drifts outside the 1 minute my script runs to get the data and it’ll eventually move to the others. It’s REALLY annoying.
The third graph is the onboard temperature sensor on an Electric Imp Hannah dev board. No offset or anything at all and it’s just right compared to all the ST sensors I have. I was always curious what the results would be if I used a typical DS18B20 or LM35 and I got it directly from this dev board. It cuts out periodically for a few minutes but that’s not uncommon for ST either and at least I see all the small changes. If the multi sensor can’t communicate with the hub for whatever reason, you see a flat line as I’m just pulling the last reported data. I don’t get that at all with this setup.
All data is logged in 5 minute intervals. The Electric Imp wakes up every 5 minutes. I have my Python script that runs on a Raspberry Pi every 5 minutes to post the data. Then of course, my SmartApp does it every time there is a change.
Seeing how much better the data from the DS18B20 is in resolution, continuity, and without the hourly spikes, I’ve decided I’m going to just use the XBee’s I’ve had for a while and rely on that instead. I brought up some of these issues in the past and was told they’ll look into it but didn’t hear anything back. I guess there’s a V2 of the Multi out but unless it addresses the issues, it’s kind of a waste for me but most people already knew that who have used them for a while for temperature purposes.
Anyway, just wanted to post something I found and get it off my chest as it has been bothering me for a while.


(Ben Edwards) #2

You can now, set an offset for the temp sensors if you find them to be consistently low or high.


(Hfb) #3

Good to know there is an offset function in the app! I’ll have to add those in for each one. I assume this is only for the app itself and it showing the proper offset in degrees and not a tenth of a degree or anything else like it correct? If I add the offset it won’t change on the web?


(Ben Edwards) #4

Yeah - I think to a degree and not smaller units.


(Barry) #5

OK, so good for the offset.

But what about the +3F spike every hour-ish? Clearly a bug/defect/issue, and I too experience this on every single ST Multi I have - but NOT on the Aeon Multi’s that I have.

It seems that ST just ignores this complaint every time it comes up…


(Ben Edwards) #6

A 3F spike on the hour is not a widespread thing we have seen. If you are seeing it you can work with support and they can help diagnose and get a new device to you if it is faulty.


(Barry) #7

Um, OK. I’ll email Support, since 12 of the 13 I have demonstrate an hourly spike of 1, 2 or 3 degrees. The warmer they are, the bigger the spike (ie. if average temp in in the 50’s, 1-degree spike, 60’s 2 degree spike, and 70+ 3 degree spike). They all pop up, then drop back down ~3 minutes later.

Me, I don’t understand why there is a spike at all; all 7 of my Aeon’s show smooth temp transitions with no multi-degree spikes whatsoever.


(Hfb) #8

Don’t get your hopes up too high that anything will be done about it. I contacted ST about 6 months ago about this very issue and didn’t get anywhere with them. All 11 of mine do this exact same thing. See here for 8 of them I have been watching a while.
https://thingspeak.com/channels/15361
Yeah, it’s really annoying but what can you do when you’ve gone to the source a couple of times with no resolution?


(Ben Edwards) #9

Most of your measurements don’t fluctuate more than an a degree from hour to hour. These are not scientific instruments and these are well within the functional specs of the devices. Settle down.


(Hfb) #10

Ha ha ha! It’s normal for inexpensive sensors to spike every hour huh? That’s awesome! KA, DD, and KTB also exhibit 2 degree spikes each hour. Scientific precision instrument or not, is it not normal for temperature sensors to spike once an hour for no reason. My $0.20 LM35 doesn’t do that and it’s far from a scientific instrument. Same for all my cheapo Walmart temperature displays in the house. The DS18B20 is a little more expensive but you can see in the very first link that it doesn’t sit there and spike on any periodic basis as well. I guess if we say it’s normal, it’ll eventually become that way.


(JJG) #11

You might want to give a try at the Fibaro FGK-101, whose US version ships this month, and which uses the DS18B20.
Fibaro has been making Z-Waves devices and controllers in Poland since 2010, and all their product are beautifully designed and carefully crafted.
I posted a custom Handler for the FGK-101 there :


(Ben Edwards) #12

I already mentioned above that it is not normal and support should be contacted. I said it wasn’t a widespread issue. And my point was there was a 1 degree fluctuation which isn’t a big deal.


(Hfb) #13

It’s probably not widespread, possibly because people don’t look at the data as much.
Regardless, I have contacted support a couple of times and haven’t gotten anywhere, hence some of my sarcastic remarks. I wish something could be done about it but I haven’t gotten anywhere with it unfortunately when I have tried.


(Edward Pope) #14

@Ben would you be able to push an update through the Hub to the device through the ZigBee network? Is there a way to update the microcode for the device?


(Ben Edwards) #15

The end devices would need thier own firmware updates and I am not sure the state of the over the air updates for them. @doug?


(Drew) #16

Any progress or update on this issue? I’m seeing the same sort of spikes on a SmartSense Multi that is approximately 2 weeks old.


(Hfb) #17

It would be nice if there were updates with some sort of fix. I would gladly trade in my 11 units for stuff that doesn’t have this issue.


(JJG) #18

AFAIK, there has been no fix for this erroneous temperature sensor.
The “fix” is to use a non-SmartThings sensor, like the Z-Wave Fibaro FGK-101\US with DS18B20 I have been using successfully for 9 months. See my previous post of October 14th, 2014 in that same thread.
The only caveat is that you will need to activate my custom Fibaro FGK-101 Device Handler (unless the latest standard handler now works properly with the FGK-101).
The only (dubious) action ST seems to have done to mitigate this imprecise temperature issue is that they modified the mobile app temperature displays so that they now report only degrees (xy°C) and not tenth of degrees (xy.z°C); this is detrimental to precise temperature sensors like the Fibaro, whose accuracy is better than 0.5°C.


(Ben Edwards) #19

If you find that the temperature data is consistently off in one direction you can introduce an offset for the device. It’s on the device detail page under Preferences in the mobile app.