Orbit Iris Faucet Stops Working


I have recently installed a Orbit Iris Faucet water valve that works great for about 30-60 mins. After that it becomes completely unresponsive. I have tried the only two different DHT’s I can find and get the same result. The only way I can get it to work again is to disconnect and re-pair. The device is within 3m of the hub so it is not a connectivity issue.

I hear that many devices stop working if they have not sent or received a command for some time. Is there a bit of code that I can add to the DHT that will send a check in (or battery status update or similar) every 20 mins or so. Failing that any other ideas would be greatly appreciated



Does the Orbit screen go blank? Mine would go blank when I had this problem, due to a bad battery connection. Very frustrating. Sadly, threw it in the garbage. Good luck.

1 Like

No nothing like that. The screen stays on and displays the correct time. The hub is receiving the commands the valve is just not responding. Don’t think it is anything mechanical either as the valve works when I put back into manual. Looks like mine is also destined for the rubbish bin which is annoying considering I have just paid NZ$85 to import one from the US