On/Off button is missing from some of the virtual switches

Some devices are not showing on/off button. These are virtual devices (Simulated Alexa Switch which acts as sensor and switch both), strange thing is - some of them are showing the on/off button and some are not despite being the same type of virtual device. All virtual devices used to work fine, the problem started today. Is anyone else facing this issue? Please help, thanks in advance.

1 Like

Have you tried editing/saving the DTH in IDE and also toggling them in the classic app?

See if they’re still ok in classic and groovy IDE. My New App started playing up just over 12 hours ago, and gradually things are first showing as connected but without their controls, and gradually changing to show as disconnected. Started with one device, and gradually others are joining in. All working perfectly fine with automations, groovy, and classic app

I have the same issue with a Xiaomi window/door sensor in the new app. For the last couple of days it has showed “Connected” rather than open/closed and clicking on the device in the new app gives no other information other than “Connected”. The old app shows the status of the sensor correctly. I have other Xiaomi sensors that are all behaving correctly in both apps.

Then I think there is no point us trying to meddle with our apps or devices I think there is probably some glitch up the line somewhere between the app and the app server at SmartThings cloud. It’s probably a different service handles each version of app.

I tried editing and saving the DTH in IDE, nothing changed. Also, those devices are showing only push button in classic app, I clicked them, but no luck.

Related question - is there a way of creating a virtual switch via the new App or does this still rely on you having to do this in IDE?

Well I think classic app does tend to increasingly show things as just on/off switches, possibly part of their plan to encourage migration

I had the same issue with Virtual devices. Made sure that the Name and Label are the same. And that it had a Zigbee ID and a Device network is filled in. Then everything worked normally in both SmartThings new and classic apps

Thanks a lot for your help! Zigbee names were blank, the moment I entered zigbee names, it started working. May I ask how did you figure this out, because I have other virtual devices with blank zigbee names and they are working fine.