Old topics, same problems!


(Marc Purkiss) #1

Hello all
I am new to Smartthings. I have followed this guide


I have followed these instructions to the letter multiple times but I just cannot get it to work.
I can get up to the point where I am supposed to see MyApps in Smartthings mobile but it is never there. If I click on the My Locations tab in the IDE, click on the name and then logout of the IDE (as a thread on this community suggested) when I log back into the IDE my SmartApps are gone and I now don’t have a settings button, so I can’t reinstall. I have searched for solutions, tried a few suggestions but nothing works.
I would be very grateful for any assistance.
Thanks


#2

You may be logging into the wrong shard in the IDE. See the thread below:


(Marc Purkiss) #3

Hi PhilB
Thanks for your reply. I followed your suggestion and I can now see webcore SmartApps. It appears I am na01 even though I am in the UK! However, as soon as I click on my locations and then back to SmartApps, the settings button disappears and the smartapps are gone.
Any suggestions?
Thanks


#4

Is it possible the shard you were on changed in the address bar when you did that. That would be strange, in my experience if you log into the wrong shard and then move to another you have to log back in again. But, I don’t really get why you can see your smartapp until you click on you location and they you can’t see them anymore.


(Robin) #5

You will not be on na01 in the uk…

Log into any shard of the IDE, go straight to locations and click on the name of your hub. This will push you into the eu shard.

Then go to smartapps and install the 4 webCoRE apps.


(Marc Purkiss) #6

Hi
Thanks for your reply. I can do as you suggested but when I go to My Smart Apps I dont have a settings button so I cant follow the procedure to install Webcore.
When I’m on the na01 URL I get the settings button.
Thanks


(Marc Purkiss) #7

UPDATE
Hi
I installed a smart app from template and published. I can now see My Apps in my Smartthings mobile app.

So it’s just the issue of installing Webcore due to the fact that I dont have a settings button on My Smart Apps page.
Thanks


(Robin) #8

By settings button I assume you mean GitHub integration?

We don’t have that by default on the EU servers… but follow this link and you can activate it:

https://graph-eu01-euwest1.api.smartthings.com/githubAuth/step1

Be warned that this considerably slows down the loading of the smartapps and device handler pages of the IDE but personally I think it’s well worth it considering the current frequency of webCoRE updates.


[DEPRECATED Thread: visit community.webcore.co for assistance] webCoRE - Piston Design Help (ask your fellow members for assistance)
(Marc Purkiss) #9

Thanks for your help PhilB. All sorted.


(Marc Purkiss) #10

Robin, thanks for your help. I have followed your steps and I now have Webcore installed successfully.


(Robin) #11

Glad to hear it :slight_smile:

Thank for the update