[OBSOLETE] Xioami Zigbee Door/Window Sensor, Motion Sensor, & Smart Button Device Type

Thank you I will try that and see how it goes. I might look for additional repeaters too. I agree a quality Zigbee mesh is definitely a must

Folks, I bought a single Xiaomi button and paired it with my Hub ~5 months ago. Now the button is shown as disconnected and it is not working. I remember I have to “List Events” and add but I don’t remember the details. I have the a4refillpad device handler already installed and currently there is a Xiaomi Button device under my devices, added 5 months ago.

I tried holding the “Link” hole for a few seconds. And then poking it again and seeing it blink twice. But I don’t see any Events under “List Events”. I am kind of stuck here. How can I pair the button again?

I have 1 Aqara type 2 pushbutton, working nice, controlling the lights downstairs.

Ordered 2 more, but their battery drains as lightning :cloud_with_lightning:.

The original AQ2 is working for months, still 70% battery.

The new buttons are in a week down to 1% and 9%.

Any idea, delivered with bad batteries?

Grtn Ben

Do you know of it’s really is down to 1% and 9% or its just the way those button are reporting which confuses the DTH? Maybe swap a battery over to the original button and see what the rating is there?

Another option is to ignore the reading and see how long they take to die.

I haven’t changed anything yet, but the p/b with the 1% battery is now 98%.

The DTH looks OK with the button I already have for months. That button reports now 70%.

Will wait a little longer for the 3rd button, to live or die. :sunglasses:

Which DTH are you using? The older ones linked to in this thread do not report battery voltage correctly.

You should use DTHs from this thread:

I eventually cut the power to my Zigbee switch as it is the only Zigbee relay in my home. At first, the button is still not pairing. I eventually find out the ‘catchall’ msg is happening with the 3 long blinks instead of the 5 short blinks. I tried it a couple of times and finally get the button added back to my Hub manually.

Do you do this right in front of the ST hub? I don’t have anywhere near the success rate as you have posted about.

Hello, not sure what else to do in order to see a catchall message. I see the door sensor as is mentioned that it should, 5s, 3 blinks, release, press once, 2 short blinks. Everytime blinks seems to be fine. From 2 sensors none of them are generating in the hub (v3) a catchall. I see different messages, hubinfo, pings… and such but there is not catchall. I have latest software version for the hub and application on my phone.

Is there any other way to find the device ID? Do I need to activate the catchall option? I have 2h of resetting the sensors… and still nothing. What else should I try?? Thank you!

LE: I tried again and I’m sure that, what I get is a hubinfo instead of catchall. The hubinfo description looks like this:
hardwareID:xxxx, version:16, mac:28:XX:XX:XX:XX:XX, localip:xxx xxx xxx xxx, localSrvPortTCP:39500, localSrvPortUDP:0, zigbeeFWMajor:3, zigbeeFWMinor:0, zigbeeFWBuild:8, zigbeePanID:35BB, zigbeeNodeID:0000, zigbeePowerLevel:8, zigbeeChannel:19, zwaveVersion:5.03, zwaveSerialVersion:5, zwaveHomeID:EC4XXXX, zwaveNodeID:01, zwavePowerLevel:full, zwaveRegion:EU, bootloaderVersion:0, goldenImageMajor:0, goldenImageMinor:0, goldenImageBuild:0, zwaveControllerStatus:29, zwaveSucID:01, appengineEnabled:0, zigbeeEui:2XXXXXXXXXX, type:report, appengineConnected:0, appengineVersionMajor:0, appengineVersionMinor:0, appengineVersionBuild:0, videocoreVersionMajor:0, videocoreVersionMinor:0, videocoreVersionBuild:0, batterygpiostat:00, uptime:2179, updaterVersion:0, zigbeeRadioEnabled:1, zigbeeRadioDetected:2, zigbeeRadioFunctional:4, zwaveRadioEnabled:8, zwaveRadioDetected:16, zwaveRadioFunctional:32, bluetoothRadioEnabled:0, bluetoothRadioDetected:0, bluetoothRadioFunctional:0, presenceTimeout:120, zigbeeUnsecureRejoin:0, zigbeeType:15, zigbeeOta:2, leeEnabled:1, emmcHealth:1, emmcLifeTypeA:1, emmcLifeTypeB:1, batteryVoltage:65535, zigbeeNcpFWMajor:3, zigbeeNcpFWMinor:0, zigbeeNcpFWBuild:1, localDeviceCommands:2, sendAllDevices:4, zwaveLibraryType:CONTROLLER_STATIC, zwaveZipGatewayVersionMajor:0, zwaveZipGatewayVersionMinor:0, zwaveZipGatewayVersionBuild:0

Any idea? I am sure that thehubinfo message is caused by resetting the sensor, I timed it.

If you are unable to pair a Xiaomi / Aqara device the “normal” way, then the only method to obtain the Device Network ID is in a catchall or zbjoin message. The hubinfo description does not contain useful information.

There are a number of things you can troubleshoot that could be preventing the pairing of a Xiaomi / Aqara device:

  1. Check if you are using any Zigbee repeater devices. Zigbee repeaters work like WiFi extenders to increase the range of the Zigbee network by allowing end device to connect to the repeater instead of direct to the hub. Most mains-powered Zigbee devices (except some brands of Zigbee bulbs) will act as a repeater. Only IKEA Tradfri smart outlets, a XBee Zigbee developer modules, and this user-created device are confirmed to be compatible with Xiaomi / Aqara devices. Nearly all other Zigbee repeaters cause Xiaomi / Aqara devices to be dropped from the Zigbee network after a few hours, and some Zigbee repeaters don’t even pass any messages on to the hub.

  2. Only the Samsung “Classic” mobile app should be used when pairing Xiaomi / Aqara devices. The new Samsung Connect app will not work.

After confirming that there are no Zigbee repeater devices on your network, and you’re using the “Classic” mobile app, this is what you’d be looking for:

When you click on the date/time for the catchall message the DNI (device network id) will be here:

In the first screenshot you’ll also see that I got a zbjoin message. If the device doesn’t show up during pairing in the mobile app, the zbjoin message is even more helpful, because it contains both the DNI and the devices unique ZigBee ID:

Manually add a device in your hub’s IDE and enter the DNI (and if you have it, the ZigBee ID), choose the correct Device Handler, name the device and save.


What sensor are you attempting to pair, which device handler are you using, and which app are you using? You shouldn’t need to use the catchall method with the newer device handlers. Using the catchall method should be a last resort, as it often results in having a missing or incorrect zigbee ID, which will cause it to be unable to rejoin the network if it happens to drop off for some reason. The latest device handlers can be found here:

If that doesn’t work, and you absolutely need to use the catchall method, make sure you’re looking at the correct events list. You’ll log into the IDE, click on locations, select your location, scroll down, select list events, and then on the events list click the “all” tab at the top.


@veeceeoh your reply made it clear! Big thanks! The trick is to use “Smartthings Classic” otherwise the catchall messages are not listed in api account.

Also I realized that sensor to be in pairing mode is needed only the 5s. reset press, nothing after.

Thanks again for quick reply guys!!

I think the latest ST update prevents these from being added. Either with the beta DH or the catchall method, I cannot get two sensor attached which once worked.

Have you tried replacing the batteries before starting the pairing process? Sometimes if the batteries are a bit low they’ll blink indicating it has power, but it doesn’t have enough juice to actually pair.

1 Like

No, they read 3.0 and 3.06 volts on my multimeter. I will order some new ones and see. Have been trying to add these two for the past month and they constantly drop after an hour and never report the battery. I have 6 others that I have no problems except with the pain to add them the first time.

Thanks for the suggestion.

What devices and what are the model numbers? I’m wondering if maybe they’re new models with different firmware.

Xiaomi Aqara Temperature Humidity Sensor


ID: 2016DP6443

This is with a Gen 2 hub. I have 6 others which I am pretty sure are the same that I have not had issued with.

1 Like

I’ve two of the same model, and they were a huge PITA to pair, unlike all of my many other Xiaomi and Aqara devices. Acted like they’d paired several times, but didn’t fully pair. I suggest removing them, re-pairing them very close to the hub, and leaving then very close to the hub for at least a few hours (or overnight). If they don’t report battery within a couple hours, try again. Might take a couple attempts.

Which DTH are you using? I’d suggest the one from here if you’re not already using it:

Is the Battery status updates with the motion detected or separate update from the sensor?

Brand new energizer batteries and still can’t get these two to pair. Both had been paired on the system before. Is there a specific limit as to how many Xiaomi Zigbee devices you can have?