[OBSOLETE] Xioami Zigbee Door/Window Sensor, Motion Sensor, & Smart Button Device Type

Hi
how can i change the heartbeat interval to 15 minutes. Sensor Aqara Window / Door

Does anyone know where I need to change on the DH to make the door sensor reverted?
I tried changing here:

tiles(scale: 2) {
multiAttributeTile(name:“contact”, type: “generic”, width: 6, height: 4) {
tileAttribute(“device.contact”, key: “PRIMARY_CONTROL”) {
attributeState “closed”, label:’${name}’, icon:“st.contact.contact.closed”, backgroundColor:"#00a0dc"
attributeState “open”, label:’${name}’, icon:“st.contact.contact.open”, backgroundColor:"#e86d13"

where ${name} is I put the state, opposing to “attributeState”, it changed but on ActionTiles the state as still normal.

Can someone help me?

thanks!

Did you get to invert the door sensor?
I’m trying to find a way, I tried to create an alternative DH based on the original one and changing some stuff, but I couldn’t.
If you did it, can you share it with me, please?
thanks!

Those do not include DH for the wall switch.

Im not sure where exactly i should post this info or even if its still relevant to anyone as i don’t see many post about problems pairing lately but i recently moved apartment and had to repair my Xiaomi buttons and temp sensors to the hub. It was as usual a little complicated but once i figured out exactly what to do then it was super easy and avoids all the button mashing some posts recommend.
I know a previous post by someone mentioned that when pairing the temp sensors the sequence of light flashes is important, it turns out the light flashes for the temp sensor and the buttons are the same to indicate its in pairing mode.
For the temp sensor - Start the hub searching by add a thing - push and hold the button on the temp sensor until it flashes three times, then push the button to see two light flashes, the two light flashes seem to be the pushes that the hub will detect so just keep pressing it every 5 seconds or so and checking the app to see if a thing is added. You might need to back out and restart the add a thing search but you can just keep pushing the temp sensor every 5 sec or so and it will be detected and paired.
For the button - Push and hold the actual button, while the button itself is pressed, insert a pin into the link/reset hole on the underside and hold that down also. The led will blink three times, now while keeping the main button pressed push the pin into the link hole every 5 sec or so to get the double flashes, again each of these pushes give the hub a chance to detect.

sorry if this is old news or painfully obvious to everyone but me but i thought it best to share in case someone else had the same issues i had in understanding the process of pairing

hope it helps

1 Like

Can you do a DH for Aqara S2 door lock? it uses zigbee…

I have had fully functioning Xiaomi door and motion sensors for over a year now. In the last week, I have lost communication with 3 door sensors and a motion sensor. I have tried re-pair the door sensors, but I always get the “solid blue” after the three flashes, indicating an unsuccessful pair (verified by the lack of a catchall in the events log). I can’t even pair my Smartthings-branded outlet (which is also Zigbee), so I suspect there is issues with Zigbee.

Is anybody else having problems with their Xiaomi/Zibee sensors?

I have been having issue with my Xiaomi/Aqara devices as well I have had rock solid for more than a year but the past few week they keep dropping off. I still have two motion sensors and 3 leak sensor still not able to reconnect

That is “normal”… sometimes they work few days, hours, weeks, months… and then suddenly issues. I just added one additional xiaomi open close sensor and suddenly my trådfri bulbs and other xiaomi open close sensors lost connection. I had to pair them again without removing sensors from smartthings. Just search new devices, pair messed up sensors normally and it rebuilds connection to hub again. Thank god it works like that. If I would have to pair them fully (remove device that is not working and pair it again) every time they lost their connection I would throw them away.
Couple of weeks ago I was very close to buy zwave open close sensors to replace all xiaomi sensors. For some reason seller was so slow that I decided to cancel order. If I find good offer I would definitely buy z wave sensors and forget using xiaomi sensors.

That’s not my experience at all…!
It usually comes down to at Zigbee repeater that is acting up, making the Zigbee mesh unstable, and not the endpoints themselves.
@idioffo89 When it happens, try to power cycle your mains powered Zigbee devices - that usually do the trick…
It’s all about the quality of your Zigbee mesh… :slight_smile:

Thank you I will try that and see how it goes. I might look for additional repeaters too. I agree a quality Zigbee mesh is definitely a must

Folks, I bought a single Xiaomi button and paired it with my Hub ~5 months ago. Now the button is shown as disconnected and it is not working. I remember I have to “List Events” and add but I don’t remember the details. I have the a4refillpad device handler already installed and currently there is a Xiaomi Button device under my devices, added 5 months ago.

I tried holding the “Link” hole for a few seconds. And then poking it again and seeing it blink twice. But I don’t see any Events under “List Events”. I am kind of stuck here. How can I pair the button again?

I have 1 Aqara type 2 pushbutton, working nice, controlling the lights downstairs.

Ordered 2 more, but their battery drains as lightning :cloud_with_lightning:.

The original AQ2 is working for months, still 70% battery.

The new buttons are in a week down to 1% and 9%.

Any idea, delivered with bad batteries?

Grtn Ben

Do you know of it’s really is down to 1% and 9% or its just the way those button are reporting which confuses the DTH? Maybe swap a battery over to the original button and see what the rating is there?

Another option is to ignore the reading and see how long they take to die.

I haven’t changed anything yet, but the p/b with the 1% battery is now 98%.

The DTH looks OK with the button I already have for months. That button reports now 70%.

Will wait a little longer for the 3rd button, to live or die. :sunglasses:

Which DTH are you using? The older ones linked to in this thread do not report battery voltage correctly.

You should use DTHs from this thread:

I eventually cut the power to my Zigbee switch as it is the only Zigbee relay in my home. At first, the button is still not pairing. I eventually find out the ‘catchall’ msg is happening with the 3 long blinks instead of the 5 short blinks. I tried it a couple of times and finally get the button added back to my Hub manually.

Do you do this right in front of the ST hub? I don’t have anywhere near the success rate as you have posted about.

Hello, not sure what else to do in order to see a catchall message. I see the door sensor as is mentioned that it should, 5s, 3 blinks, release, press once, 2 short blinks. Everytime blinks seems to be fine. From 2 sensors none of them are generating in the hub (v3) a catchall. I see different messages, hubinfo, pings… and such but there is not catchall. I have latest software version for the hub and application on my phone.

Is there any other way to find the device ID? Do I need to activate the catchall option? I have 2h of resetting the sensors… and still nothing. What else should I try?? Thank you!

LE: I tried again and I’m sure that, what I get is a hubinfo instead of catchall. The hubinfo description looks like this:
hardwareID:xxxx, version:16, mac:28:XX:XX:XX:XX:XX, localip:xxx xxx xxx xxx, localSrvPortTCP:39500, localSrvPortUDP:0, zigbeeFWMajor:3, zigbeeFWMinor:0, zigbeeFWBuild:8, zigbeePanID:35BB, zigbeeNodeID:0000, zigbeePowerLevel:8, zigbeeChannel:19, zwaveVersion:5.03, zwaveSerialVersion:5, zwaveHomeID:EC4XXXX, zwaveNodeID:01, zwavePowerLevel:full, zwaveRegion:EU, bootloaderVersion:0, goldenImageMajor:0, goldenImageMinor:0, goldenImageBuild:0, zwaveControllerStatus:29, zwaveSucID:01, appengineEnabled:0, zigbeeEui:2XXXXXXXXXX, type:report, appengineConnected:0, appengineVersionMajor:0, appengineVersionMinor:0, appengineVersionBuild:0, videocoreVersionMajor:0, videocoreVersionMinor:0, videocoreVersionBuild:0, batterygpiostat:00, uptime:2179, updaterVersion:0, zigbeeRadioEnabled:1, zigbeeRadioDetected:2, zigbeeRadioFunctional:4, zwaveRadioEnabled:8, zwaveRadioDetected:16, zwaveRadioFunctional:32, bluetoothRadioEnabled:0, bluetoothRadioDetected:0, bluetoothRadioFunctional:0, presenceTimeout:120, zigbeeUnsecureRejoin:0, zigbeeType:15, zigbeeOta:2, leeEnabled:1, emmcHealth:1, emmcLifeTypeA:1, emmcLifeTypeB:1, batteryVoltage:65535, zigbeeNcpFWMajor:3, zigbeeNcpFWMinor:0, zigbeeNcpFWBuild:1, localDeviceCommands:2, sendAllDevices:4, zwaveLibraryType:CONTROLLER_STATIC, zwaveZipGatewayVersionMajor:0, zwaveZipGatewayVersionMinor:0, zwaveZipGatewayVersionBuild:0

Any idea? I am sure that thehubinfo message is caused by resetting the sensor, I timed it.

If you are unable to pair a Xiaomi / Aqara device the “normal” way, then the only method to obtain the Device Network ID is in a catchall or zbjoin message. The hubinfo description does not contain useful information.

There are a number of things you can troubleshoot that could be preventing the pairing of a Xiaomi / Aqara device:

  1. Check if you are using any Zigbee repeater devices. Zigbee repeaters work like WiFi extenders to increase the range of the Zigbee network by allowing end device to connect to the repeater instead of direct to the hub. Most mains-powered Zigbee devices (except some brands of Zigbee bulbs) will act as a repeater. Only IKEA Tradfri smart outlets, a XBee Zigbee developer modules, and this user-created device are confirmed to be compatible with Xiaomi / Aqara devices. Nearly all other Zigbee repeaters cause Xiaomi / Aqara devices to be dropped from the Zigbee network after a few hours, and some Zigbee repeaters don’t even pass any messages on to the hub.

  2. Only the Samsung “Classic” mobile app should be used when pairing Xiaomi / Aqara devices. The new Samsung Connect app will not work.

After confirming that there are no Zigbee repeater devices on your network, and you’re using the “Classic” mobile app, this is what you’d be looking for:

When you click on the date/time for the catchall message the DNI (device network id) will be here:

In the first screenshot you’ll also see that I got a zbjoin message. If the device doesn’t show up during pairing in the mobile app, the zbjoin message is even more helpful, because it contains both the DNI and the devices unique ZigBee ID:

Manually add a device in your hub’s IDE and enter the DNI (and if you have it, the ZigBee ID), choose the correct Device Handler, name the device and save.

2 Likes