[OBSOLETE] Xiaomi Zigbee Outlet (Steps to Pair any Xiaomi Zigbee device!)

Should do with an Chinese to us adapter.

Apparently I have no idea what I am doing.
I got the catchall to show up, but how do I “Add a New Device using IDE” or find the Device Network ID for, “Fill in the Device Network ID, you can find it from the catchall log”?

yesterday I received the Xiaomi Aqara Smart Wireless Switch and, with my astonishment, was detected automatically without the need of the usual procedure. Great !!!

@BigKahunaFSU When your logged into ST, using the top navigation menu, click on “My Devices”, then choose “New Device”. Follow the instructions as noted in the first post of this thread.

Ok, I see where the name is now. (Didn’t see it IN the catchall). Now, How do I get the status to from inactive to active or online?

How did you get the catchall to come up, following instructions but cannot see it in the IDE when adding the device in ST??

Well, when looking at the string of numbers and letters, I didn’t SEE the actual “name” in the string, or at least didn’t realize that that specific set of characters was the name. Not until it was pointed out I another thread I had read I a different matter. Thanks for being helpful. But I got it added and it works as it should now.

Rave, thank you for your topic. I recently bougth a zigbee xiaomi outlet and there is no way to find it att ST App. To sync I press and hold until the led blink. But nothing.

could someone please provide a link where I can buy these plugs? For some reason I cant find the zigbee plug on gearbest website.


I need help!
Just bough a new SmartThings hub, but i can’t get my xiaomi devices paired (outlet and smart button)…
Installed the device handlers, try to pair, but it just don’t work, i clicked the little button 100 times, nothing happens.

Also tried to create a device, but i can’t get that working…
Added both id’s on the back of the xiaomi device…
Also tried to get the network id from my xiaomi hub, but i only can find the MAC and IP adress in there…

Can some one help?
A little push in the right direction will make me very happy :slight_smile:



You can find it using the AliExpress app on your phone.
Look for the international version, the standard is only chinese…

I have started an all inclusive thread for the Xiaomi Zigbee sensors. Please refer to this thread.

I hope to have all these other Xiaomi threads closed.

I just got a Xiaomi motion sensor.

I can pair it. but it lost connection hours later.

I will try this:

On the sensors, after pairing I continued to click on the reset lots of times. It seems to have done the trick and make the sensor stay connected to ST overnight for the first time.

Look here:

Thank you!

How can i know if the sensor is pair to hub directly?
Once paired to hub directly, will it automatically change to pair through other router later?

Therefore when pairing you need to make sure all other zigbee routing devices are off and that the device is pairing directly to the hub.

I’ve got 7 of the water sensors but one of them is not working properly and giving me a strange reading (Current states: - battery: 58, - checkinterval: 7620??). It’s not giving me the Dry/Wet status. Perhaps it’s just defective or is there something else I can do?

You’re using the most up-to-date device handler from the bspranger GitHub repository, right?

From your screenshot, it looks like the sensor was paired correctly (The ST hub received its Zigbee Id, which is great.)

If so, perhaps this particular leak sensor has a bad battery. Best to check the actual voltage reported. In your SmartThings mobile app, view the device, and switch to the “Recently” tab, which lists all events from the sensor. Scroll down until you find a “Raw Battery is…” message. What’s the voltage reported?

Thanks for the reply!

Not sure if I have the latest DH or not. It’s been a while since I added any new DHs so I’ll have to refresh my memory on how to do that. But all of my other sensors are working fine. The only feedback on my app was from last night and it shows 58% battery (not “raw battery”).

In the IDE, three hours ago I see a couple of refresh and configure commands sent to the device but no response. I’ll try to put in a new battery and try again, but I’m guessing it’s just a bad device.

I just realized you’re not using the latest DH from bspranger. In addition to battery and checkInterval listed in the Current States list for the device, there should also be lastCheckin, lastWet, lastWetDate, and BatteryRuntime.

I am using the latest DH from bspranger with my Leak Sensor and it works great. The voltage range used to calculate the battery percentage has been adjusted to make the reported percentage more realistic with expectations.

You should copy the code text from here, go to the My Device Handlers tab in the IDE, click on the name of the DH (“bspranger : Xiaomi Aqara Door/Window Sensor”), select all the code that’s in there and delete it (so the code window is blank), and paste in the new code text. Then click the Save button, and finally click Publish, and select For Me in the drop-down menu. Then all of your Leak sensors will be using the new DH.

Then both in the Device Events log in IDE and also in the ST mobile app you’ll see the raw voltage reported in addition to percentage, like this:

NOTE: for all of the Xiaomi DHs to work properly, your hub needs the timezone set for your location. Please make sure that it’s been set for you local timezone.

Also note: any refresh commands to Xiaomi devices or using the refresh button for the device in the ST mobile app will not update the display to the latest status. All it does is resend the configuration for the device health reporting time interval, which gets set up when the device is first paired anyhow. Xiaomi devices do not strictly follow ZigBee Home Automation 1.2 standards, and so the normal ZigBee reporting, configuration, and refresh commands do not work at all.


Thanks Keith, for the detailed instructions! Well, I installed the new DH, and all of my other sensors are reporting in just fine, but that one still does not give any dry/wet status. I haven’t had a chance to get a new battery yet, but I’m really leaning towards it being defective. Since I got it cheap from China, I don’t think it would be worth it to try and get it replaced. Any other suggestions?

BTW, here’s the latest status on that device: