[OBSOLETE] Visonic Powermax Alarm

Thats interesting, I wonder if they did something similar to the US models in Spain. Ive sent Jose an Arduino and another debug part, will see if that fixes things for him!

1 Like

I can get alarm status in the JSON endpoint and in ST app but I cannot change status to arm home or away or disarm neither in the web nor in the app. There isn’t alno any zones created, I have tested some methods but I am not able to enrroll them.

I have some arduino nano clones I shall try this weekend whith them.

Thak you for your work and this great integration.

The nano may help you enroll successfully, but in the short term you can try changing the pin in the web interface of Wemos to match one of your user pins. That way at least control should work.

The way enrolling works is that the download code (in Wemos web interface) is used to create an account in the alarm that only has access through serial (hence secure). If that fails for some reason you can tell it the pin to use, it likely won’t give as much data as enrolling (i.e. zones may not be named) but you should get virtually all zone/panel status.

If you’re a developer then maybe you can do a TeamViewer screen share aswell, and I can show you some of the debugging in telnet.

1 Like

Hi Charles,

I have tried with all the pins and after several hours investigating I find myself almost in the same situation. I have installed the arduino nano and with this I have got three new child devices: Alarmarmaway, Alarmarmhome and Alarmdisarm but none of them work.

From time to time it finds one of the five zones that I have defined in the panel, zone motion 2 but after a while it disappears and in no case has it been reflected in the smartthing app.

Of course that I would like to share a Teamviewer sesion with you when you want.

Thank you for your help and best regards.


If you are seeing the zones appear, that means the alarm is able to listen to the Powermax, but enroll is failing. In this case every time you restart Wemos it will forget the zone history, but if you leave it then it should still work for motion detecting at the least - though we’re do need to work out why no commands are heard by the alarm. Once you see all your zones in the zones page (they appear after they have been triggered - motion/open/close) then you can open the settings page in ST and change something, at this point it will import your zones (even though not enrolled).

Will drop you a message to arrange.

I’ve just switched over from SmarthingThings to Home Assistant, and getting the alarm panel going in HA has been the final piece of the puzzle! Just wanted to share some info on how to set this up for anyone else switching over, there is some info in this thread but I hope it might help someone to have all the info together.

You will need an MQTT broker installed, this is quite straightforward if you are using Hass.io as an add-on is available.

You will then need to add some entries to configuration.yaml.

To configure the alarm panel you just need to add something like:

    platform: mqtt
    name: 'Visonic Powermax'
    state_topic: 'alarm/panel'
    command_topic: 'alarm/set'

and to configure the zone sensors you need to add something like:

  - platform: mqtt
    name: "Visonic Front Door"
    state_topic: "alarm/zone1"
    payload_on: "Open"
    payload_off: "Closed"
    device_class: door
    unique_id: "visonic1"
  - platform: mqtt
    name: "Visonic Living Room"
    state_topic: "alarm/zone2"
    payload_on: "Violated (Motion)"
    payload_off: "No Motion"
    device_class: motion
    unique_id: "visonic2"

The unique IDs let you assign things to rooms.

you can work out the right order for the entries by looking at the JSON on the alarm status at e.g. http://192.168.1.XXX/status.

You will need to configure the Wemos something like this:

Thanks again Charles for all your hard work with this!

I bought the esp8233 preprogrammed from you , @cjcharles a couple of years ago. I assume you’ve updated the code since, can i just update using the web interface using your PowerMaxEsp8266.ino.bin file from your github via the update firmware bit of the web interface? or will it break things etc?

thanks @Jojoba86 - i’ve just installed HA and was looking at getting it integrated in some way.
edit: just tried to set it up but am struggling. do you hang out on any discord channels i can ask you some questions on?
I’ve configured it, i see it when i ‘listen’ in HA. But it isn’t adding the sensors into my HA setup at all. any ideas?

edit: ok somehow managed to get them in.

can you activate the alarm (as in arm/disarm) using this setup? like you could with ST?

ok i got it working in HA although it seems to just randomly no longer bother sending MQTT events. anyone have that issue? firmware related?

Yup just upload latest firmware via Web interface

Great stuff. Is there a mqtt notification to look out for for when the alarm is going off so I can get HA to set up alerts for that?

just tested monitoring the MQTT and didn’t see any topic activity for anything other than armed/door open/shut/disarmed. nothing to show that the alam had been triggered. is there something i need to configure in the control panel so that it sends some kind of notification like it does for other things?

So everything is working but the alarm message isn’t appearing correctly? I’m sure I simplified that so it should just be “alarm” but I’ll need to refresh my memory in the source code later.

well, i mean i’m not seeing ANYTHING come up in the logs when i monitor MQTT and the alarm is triggered. so i didn’t know if it was something which needed configuring on the unit itself.

And you are waiting until the alarm actually sounds? After checking the source code, all the types of alarm that I can think of are sending a ‘triggered’ message to the alarm/panel topic. What do you see the alarm status as, in the activity log of the ESP? And what status does it show on the /status page of the ESP when the alarm is triggered? I assume not one of the states shown in the screenshot below…

yes, the alarm is sounding and i left it doing so for about 10 seconds (much to the neighbours annoyance).
I’ll have to do it again when i’m able to see what the ESP is showing it as doing at that point as it is no longer in the logs.
(unless there is a way of setting the alarm off ‘silently’?)

Not unless you disconnect the battery from the external siren, but I’m really not sure why you wouldn’t see the triggered message…

ok i tried it again.
here are the MQTT logs from within HA. (also using a MQTT explorer which shows the same)

Message 13 received on alarm/problem_report at 10:52:
No problems detected
QoS: 0 - Retain: false

Message 12 received on alarm/panel at 10:52:
QoS: 0 - Retain: false

Message 11 received on alarm/zone3 at 10:52:
Violated (Motion)
QoS: 0 - Retain: false

Message 10 received on alarm/zone3 at 10:52:
Violated (Motion)
QoS: 0 - Retain: false

Message 9 received on alarm/problem_report at 10:51:
No problems detected
QoS: 0 - Retain: false

Message 8 received on alarm/panel at 10:51:
QoS: 0 - Retain: false

needless to say that there was a trigger event happening between message 11 and 12.

also within the wemo logs

#0	2021-08-24 09:52:39	Disarm
#1	2021-08-24 09:51:39	Arm Away
#2	2021-08-24 09:51:30	Exit Delay

I think the alarm doesnt trigger an alarm message as soon as the siren goes off, it typically waits for ~20s to be confirmed and then to trigger the external siren (at which point it sends the message). That said I would still expect something in the logs as I no longer get the delay since I added the extra alarm types, and it works perfectly for me.

Im not entirely sure why you are not having the triggered event, what zone type is the zone that is triggering? (e.g. perimeter/internal/…) Might be useful to send me your /status page by PM which has all the zone types and configuration.

I have PowerMaxPlus (US) and have been using it with Smartthings and Cj’s Wemos and Arduino boards for the past four years. Everything has been working quite well for me even with the changes to the Smartthings app. Last week I changed my router from Verizon to TP-Link Deco x60 mesh. Now the Wemos doesn’t find my WiFi SSID. If I connect to the Wemos board using a USB cable, do I have to disconnect all of the wires from the Wemos to my PowerMaxPlus or can I just disconnect power to the Wemos and PowerMaxPlus? I don’t see “VisonicPowermaxBridge” broadcasting while it is connected to the PowerMaxPlus.

It will probably only re-broadcast the VisonicBridge AP after a power cycle (unless you specifically set it to do so whenever wifi drops). Normally it should reconnect automatically if you create a WiFi network with the details of your old network.

If you want to change the WiFi details you can follow the reset process (power cycle the device >5x with about 1-1.5s of ‘on time’ for each cycle (you can have unlimited ‘off time’ as the Wemos doesnt know how long it is off for). To do this you will need to pull the power cable out of the Wemos (multiple times)