[OBSOLETE] Visonic Powermax Alarm

Hi Charles, Quick One… I have set email and text alerts so when my alarm state changes it emails and texts me… works a dream for Disarm, Arm Home and Arm away… but it is not working for Alarm going off… can you let me know why “Both” is not working in this webcore code? of do I need to code it differently?

Thanks in advance - ignore email and text address. they are correct and work with the other systems.

Sorry about the delayed reply, I have been away for a few days.

Hi @G4seb - Yes, the integration should work with your Powermax Pro with just the Wemos, no need for the Arduino. It does require a hub, but this integration is compatible with many Smarthome platforms now, from Hubitat to Home Assistant and several others (either using the web calls that Smartthings uses or with the MQTT features built into the Wemos). This way you are free to change Smarthome platform as you wish (and I can probably add other platforms as needed). To access the Smartthings web IDE you are better off using https://graph.api.smartthings.com and it will direct you to the right place. All of the instructions are on Github - the link is in the first post, and sorry for a long/wordy post!

@adavison007 - Thats very strange, I would expect it to work fine with that setup. I can try and do some more testing on my side, but a few quick questions:

  1. Are you finding the integration shows as ‘both’ and it doesnt trigger Webcore, or are you finding it never shows ‘both’ in Smartthings (they would have very different solutions).
  2. Are you running the latest firmware?
  3. When the alarm goes off, what messages do you see in Live Logging? Perhaps it is not recognising a certain type of alarm that you are triggering (Powermax recognises lots of different types of alarms depending on what has triggered and how long it has been going off for).

Hi @cjcharles ,

I finally received your package, thank you!

Now I’ve got some problems, could you help me?



I’ve tryed to change installer master code to 3622, but still the same. If I try to enrole powerlink on the alarm menu, i get a long bip.

Any idea?

edit: connections used

@Arielgr Hi, as you can see, my connections are very similar to yours but labeled PC, did you use an arduino? How is ti going today?

Thank you all,

Your connections look good. I will drop you a PM regarding this before sending you an Arduino as Im sure you shouldnt need one. The Powerlink code is normally different to the Installer code in old panels, hence I would suggest putting your installer code back to its previous number. I would then try restarting the panel, then try restarting the wemos, and finally you may need to play with the settings in the Wemos webpage (but go with these steps first).

Thank you very much, you got PM!

Any thoughts on this anyone?

@adavison007 Did you see my questions above? It might be easier to do a text comparison with the ‘alarmStatus’ field if you can, since that is more reliable at taking the ‘disarmed’/‘armedhome’/‘armedaway’/‘alarm’ status than the ‘alarm’ field changing between off/siren/strobe/both.

1 Like

@Arielgr - FYI I updated the handler after finally testing something on my end to fix the child devices working smoothly now for control of alarm status.
Its weird, the only change I made was to change which command was called first (i.e. ST device update v.s. Wemos status change) and that fixed it, so I guess some weird validation is now happening in ST that I dont know about.

Hi @cjcharles ,
Thanks so much for fixing the device handler code - I updated on my end and tested and the new child devices are working now great - this is a great new functionality that enables easily arming and disarming (careful :wink: through Google home / assistant for example.
I also found why smartthings doesn’t always show an active alarm in my case… some of my zones are set as “Perimeter” and “Perimeter-follow” zones, and when these trigger the alarm, the alarm type shows as “Perimeter Alarm” rather than “Confirm Alarm” (line 587 here ) - there are other Alarm types that can trigger and seem to be missing, but these are likely the main ones…

Otherwise things seem to be running fairly smoothly now - thanks!!

1 Like

That’s a good one for me to add to the device handler, didn’t know that! Thanks

Hi José,

Have you solved your problem? I am just in the same situation and also with a spanish powermax pro.

Thank you and best regards.

Thats interesting, I wonder if they did something similar to the US models in Spain. Ive sent Jose an Arduino and another debug part, will see if that fixes things for him!

1 Like

I can get alarm status in the JSON endpoint and in ST app but I cannot change status to arm home or away or disarm neither in the web nor in the app. There isn’t alno any zones created, I have tested some methods but I am not able to enrroll them.

I have some arduino nano clones I shall try this weekend whith them.

Thak you for your work and this great integration.

The nano may help you enroll successfully, but in the short term you can try changing the pin in the web interface of Wemos to match one of your user pins. That way at least control should work.

The way enrolling works is that the download code (in Wemos web interface) is used to create an account in the alarm that only has access through serial (hence secure). If that fails for some reason you can tell it the pin to use, it likely won’t give as much data as enrolling (i.e. zones may not be named) but you should get virtually all zone/panel status.

If you’re a developer then maybe you can do a TeamViewer screen share aswell, and I can show you some of the debugging in telnet.

1 Like

Hi Charles,

I have tried with all the pins and after several hours investigating I find myself almost in the same situation. I have installed the arduino nano and with this I have got three new child devices: Alarmarmaway, Alarmarmhome and Alarmdisarm but none of them work.

From time to time it finds one of the five zones that I have defined in the panel, zone motion 2 but after a while it disappears and in no case has it been reflected in the smartthing app.

Of course that I would like to share a Teamviewer sesion with you when you want.

Thank you for your help and best regards.


If you are seeing the zones appear, that means the alarm is able to listen to the Powermax, but enroll is failing. In this case every time you restart Wemos it will forget the zone history, but if you leave it then it should still work for motion detecting at the least - though we’re do need to work out why no commands are heard by the alarm. Once you see all your zones in the zones page (they appear after they have been triggered - motion/open/close) then you can open the settings page in ST and change something, at this point it will import your zones (even though not enrolled).

Will drop you a message to arrange.

I’ve just switched over from SmarthingThings to Home Assistant, and getting the alarm panel going in HA has been the final piece of the puzzle! Just wanted to share some info on how to set this up for anyone else switching over, there is some info in this thread but I hope it might help someone to have all the info together.

You will need an MQTT broker installed, this is quite straightforward if you are using Hass.io as an add-on is available.

You will then need to add some entries to configuration.yaml.

To configure the alarm panel you just need to add something like:

    platform: mqtt
    name: 'Visonic Powermax'
    state_topic: 'alarm/panel'
    command_topic: 'alarm/set'

and to configure the zone sensors you need to add something like:

  - platform: mqtt
    name: "Visonic Front Door"
    state_topic: "alarm/zone1"
    payload_on: "Open"
    payload_off: "Closed"
    device_class: door
    unique_id: "visonic1"
  - platform: mqtt
    name: "Visonic Living Room"
    state_topic: "alarm/zone2"
    payload_on: "Violated (Motion)"
    payload_off: "No Motion"
    device_class: motion
    unique_id: "visonic2"

The unique IDs let you assign things to rooms.

you can work out the right order for the entries by looking at the JSON on the alarm status at e.g. http://192.168.1.XXX/status.

You will need to configure the Wemos something like this:

Thanks again Charles for all your hard work with this!

I bought the esp8233 preprogrammed from you , @cjcharles a couple of years ago. I assume you’ve updated the code since, can i just update using the web interface using your PowerMaxEsp8266.ino.bin file from your github via the update firmware bit of the web interface? or will it break things etc?

thanks @Jojoba86 - i’ve just installed HA and was looking at getting it integrated in some way.
edit: just tried to set it up but am struggling. do you hang out on any discord channels i can ask you some questions on?
I’ve configured it, i see it when i ‘listen’ in HA. But it isn’t adding the sensors into my HA setup at all. any ideas?

edit: ok somehow managed to get them in.

can you activate the alarm (as in arm/disarm) using this setup? like you could with ST?

ok i got it working in HA although it seems to just randomly no longer bother sending MQTT events. anyone have that issue? firmware related?

Yup just upload latest firmware via Web interface