[OBSOLETE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

I have tested with my car charger (110V @ 12A) and an electric kettle (1500W).
The voltage was around 107V and the current was low (and hence the power).
I will run the test tonight again and will send you the exact numbers. If I remember correctly the current for the car charging and the electric kettle was around 5.8 A.

Hi Eric, I have measured the following devices both on the Sonoff POW and the Aeon HEM.


Aeon measured 922W

Electric kettle

Aeon measured 1295 W

Toaster Oven

Aeon mesured 1200 W

The voltage seems to be okay, however the current is about half what it suppose to be. Hope that helps.

@erocm1231: Have you flashed any 2, 3 or 4 GANG Touch Switch (like Sonoff T1) like you have done with Sonoff Touch Switch?


I managed to flash two of my Sonoff TH16’s but had a lot more problems with the second one. Now it does not show temperature and humidity like the other one. Status shows:
{“power”:“off”, “uptime”:“0:0:31”, “temperature”:“nan”, “scale”:“F”, “humidity”:“nan”}

What could be the problem, now? I tried flashing again through FTDI and web. I also had to flash it several times before I could connect to it.

It actually started working at some point later. I thought I had bricked the unit in part or whole while trying to flash it. I tested the switch and sensor for a few days before flashing and this one sensor was off by about 6% in humidity and 2-4 degrees in temperature. Even while refreshing I sometimes get “nan” as result for humidity and temperature. So, I think the problem is with the sensor. The other switch and sensor is working properly and currently being used to run the dehumidifier in the basement.

Also, the switches I have are v2.0 and I noticed the RX and TX terminals are reversed from v1.0.

Yeah, if it is reporting NAN, then it isn’t getting the data from the sensor. Make sure the sensor is pushed in all the way. I read that on some units the case can actually get in the way and a bigger hole has to be drilled. If it still is giving you problems, might be a bad unit.

@Tiennd77 In the description it states that these won’t start shipping until July 20. Also, there is no US version released yet (although a company employee says they are coming soon).

Eric, I managed to get a power meter and compared results with the Sonoff POW running the same appliance simultaneously.

Power meter:
Voltage - 117.9 V
Amperage - 11.06 A
Power - 1301 W

Sonoff POW:
Voltage - 123 V
Amperage - 5.3 A
Power - 617 W

Hope that helps to resolve the issue.

Thank you Eric. Waiting for Sonoff T1 release.


Hi @erocm1231 , I tested on both Sonoff and S20, I can’t get the /reset function to work, and also can’t get the hold down button reset to work. Something is missed in the recent firmware?

I just got two Sonoffs and an S20. I setup the S20 first and it worked right away, but with the Sonoffs I can’t see the wifi network. I’ve reflashed them both multiple times, waited overnight, powered through AC power and through the FTDI adapter. When I flash it it looks successful showing:

starting app without reboot
espcomm_send_command: sending command header
espcomm_send_command: sending command payload
espcomm_send_command: receiving 2 bytes of data

Most recently I tried putting the Sonoff TH firmware on one, but the situation is still the same, no wifi.

Do you have any advice?

I put the basic sonoff firmware onto my 20s so the neon is only on when the device is switched on if this is any help?

I read through some ESPEasy forums and I think the problem is with my Serial adapter. I’ve ordered a new one and I’ll report back in a couple days when that arrives.

Did you reset the WiFi straight after flashing?
Once flashed let it boot up as normal then hold the button for about 20 secs and meet go it the led should blink.
Disconnect the power and restart then the WiFi should show up.

I tried to do the reset, by holding down for 20+ seconds, waiting and then rebooting. The LED didn’t blink with after holding it down and after disconnecting and reconnecting power I didn’t get any WiFi. I also tried to monitor communication over the serial connection, and it isn’t showing anything. Am I correct that they aren’t booting up?

Yeah it seems like it’s not booting.
On all the devices I’ve reset the WiFi on (20 second hold) the LED’s blinked :frowning:
Maybe it’s like you said your serial adapter have you double checked the pin locations on the headers tx,rx etc ?

I checked them so many times, haha. But, I would love if someone could double check for me.

I’m now doubtful that the adapter is bad because I got a new one, with a CH340G chip on it instead of an FTDI and its exhibiting the same behavior. Also, the S20 flashed successfully on the FTDI but the two Sonoffs did not.

I’ve done so many different things to try to get this to work, because I’m having trouble believing that I have two bad Sonoffs.

Here are some pictures. I hope that you see something wrong with it!

Once a long while back you said you would post the firmware source to the basic Sonoff. Can you please do that? I would love to build support for a couple of things into these as well as add the option to change the hostname.

Various people have asked recently but you haven’t replied to them. Does that mean you aren’t going to release the firmware source?

From what I can make out the pins look in the correct position , the pics a little blurry :frowning:
I can’t make out what position the jumper is in for the voltage ? Have you definitely got it set to 3.3v and not 5.
I noticed you soldered yours in place I never did that I just held the contacts in place whilst flashing.
How are getting the sonoff into flash mode which way you doing it.

Yeah, 3.3V. As far as the programming mode, I held the button down and plugged the USB into the computer, then waited a few seconds and let go of the button. I also tried holding the same thing except I held the button until programming was complete.

I’m stumped then :frowning:
It looks like you’re doing everything I did try putting a multimeter on and see if any voltage is coming out the output.
Also just noticed your board is the kind where you plug a USB cable into it and not direct into a pc check the voltage coming out from your board , you may have a dodgy cable?
Just clutching at straws really not too sure what it is now